aboutsummaryrefslogtreecommitdiff
path: root/src/exit/Makefile.am
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-09-10 16:59:32 +0000
committerng0 <ng0@n0.is>2019-09-10 16:59:32 +0000
commit04b6df21cd281e8cd540139f8d9ae85defc1961c (patch)
tree6357199445df8d5c0c631bc8f10aef838b1f9f1e /src/exit/Makefile.am
parent483b0139a218a5f8a8311bda3eb23bcd88f57688 (diff)
downloadgnunet-04b6df21cd281e8cd540139f8d9ae85defc1961c.tar.gz
gnunet-04b6df21cd281e8cd540139f8d9ae85defc1961c.zip
remove CYGWIN codeblocks, drop vendored Windows openvpn, drop win32 specific files.
configures and builds okay. testsuite wasn't checked, will be checked. diff including the plibc removal is now around 14370 lines of code less.
Diffstat (limited to 'src/exit/Makefile.am')
-rw-r--r--src/exit/Makefile.am19
1 files changed, 2 insertions, 17 deletions
diff --git a/src/exit/Makefile.am b/src/exit/Makefile.am
index ea4f08c73..b7286349d 100644
--- a/src/exit/Makefile.am
+++ b/src/exit/Makefile.am
@@ -1,11 +1,6 @@
1# This Makefile.am is in the public domain 1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include 2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3 3
4if MINGW
5 WINFLAGS = -Wl,--no-undefined,--export-all-symbols
6 EXITBIN = gnunet-helper-exit
7endif
8
9if USE_COVERAGE 4if USE_COVERAGE
10 AM_CFLAGS = --coverage -O0 5 AM_CFLAGS = --coverage -O0
11endif 6endif
@@ -32,20 +27,10 @@ libexec_PROGRAMS = \
32 gnunet-daemon-exit \ 27 gnunet-daemon-exit \
33 $(EXITBIN) 28 $(EXITBIN)
34 29
35if MINGW
36 gnunet_helper_exit_LDFLAGS = \
37 -no-undefined -Wl,--export-all-symbols
38 30
39 gnunet_helper_exit_LDADD = \ 31gnunet_helper_exit_SOURCES = \
40 -lsetupapi -lnewdev -lshell32 -liconv -lstdc++ \ 32 gnunet-helper-exit.c
41 -lcomdlg32 -lgdi32 -liphlpapi
42 33
43 gnunet_helper_exit_SOURCES = \
44 gnunet-helper-exit-windows.c
45else
46 gnunet_helper_exit_SOURCES = \
47 gnunet-helper-exit.c
48endif
49gnunet_daemon_exit_SOURCES = \ 34gnunet_daemon_exit_SOURCES = \
50 gnunet-daemon-exit.c exit.h 35 gnunet-daemon-exit.c exit.h
51gnunet_daemon_exit_LDADD = \ 36gnunet_daemon_exit_LDADD = \