aboutsummaryrefslogtreecommitdiff
path: root/src/exit/Makefile.am
diff options
context:
space:
mode:
authorChristian Fuchs <christian.fuchs@cfuchs.net>2013-01-31 08:52:46 +0000
committerChristian Fuchs <christian.fuchs@cfuchs.net>2013-01-31 08:52:46 +0000
commit729c3ac4bf294e9f358269197f5d7ff60ea18854 (patch)
tree96fdc4e2258402f29f45ccd10e9f220db9e30f55 /src/exit/Makefile.am
parenta41c9ae56159e89e05770588bcb8ab23cc52a87a (diff)
downloadgnunet-729c3ac4bf294e9f358269197f5d7ff60ea18854.tar.gz
gnunet-729c3ac4bf294e9f358269197f5d7ff60ea18854.zip
added gnunet-helper-exit-windows, which currently is just a copy of
gnunet-helper-vpn-windows
Diffstat (limited to 'src/exit/Makefile.am')
-rw-r--r--src/exit/Makefile.am20
1 files changed, 16 insertions, 4 deletions
diff --git a/src/exit/Makefile.am b/src/exit/Makefile.am
index be3a66a34..eb2a7a9aa 100644
--- a/src/exit/Makefile.am
+++ b/src/exit/Makefile.am
@@ -1,7 +1,8 @@
1INCLUDES = -I$(top_srcdir)/src/include 1INCLUDES = -I$(top_srcdir)/src/include
2 2
3if MINGW 3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols 4 WINFLAGS = -Wl,--no-undefined, --export-all-symbols
5 EXITBIN = gnunet-helper-exit
5endif 6endif
6 7
7if USE_COVERAGE 8if USE_COVERAGE
@@ -30,9 +31,20 @@ libexec_PROGRAMS = \
30 gnunet-daemon-exit \ 31 gnunet-daemon-exit \
31 $(EXITBIN) 32 $(EXITBIN)
32 33
33gnunet_helper_exit_SOURCES = \ 34if MINGW
34 gnunet-helper-exit.c 35 gnunet_helper_exit_LDFLAGS = \
35 36 -no-undefined -Wl,--export-all-symbols
37
38 gnunet_helper_exit_LDADD = \
39 -lsetupapi -lnewdev -lshell32 -liconv -lstdc++ \
40 -lcomdlg32 -lgdi32 -liphlpapi
41
42 gnunet_helper_exit_SOURCES = \
43 gnunet-helper-exit-windows.c
44else
45 gnunet_helper_exit_SOURCES = \
46 gnunet-helper-exit.c
47endif
36gnunet_daemon_exit_SOURCES = \ 48gnunet_daemon_exit_SOURCES = \
37 gnunet-daemon-exit.c exit.h 49 gnunet-daemon-exit.c exit.h
38gnunet_daemon_exit_LDADD = \ 50gnunet_daemon_exit_LDADD = \