aboutsummaryrefslogtreecommitdiff
path: root/src/fs/Makefile.am
diff options
context:
space:
mode:
authorDavid Barksdale <amatus.amongus@gmail.com>2013-06-27 06:11:55 +0000
committerDavid Barksdale <amatus.amongus@gmail.com>2013-06-27 06:11:55 +0000
commitea7eed529e12dcbed6a6775b818d8b93b9505f18 (patch)
tree521ba312e1268d1afb249db03c1b97d5a79181a1 /src/fs/Makefile.am
parent48e50f64d8c05b2a6dab327156ea86fc92f171cf (diff)
downloadgnunet-ea7eed529e12dcbed6a6775b818d8b93b9505f18.tar.gz
gnunet-ea7eed529e12dcbed6a6775b818d8b93b9505f18.zip
Make building gnunet-testing lib optional.
This is all because emscripten doesn't have getaddrinfo.
Diffstat (limited to 'src/fs/Makefile.am')
-rw-r--r--src/fs/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/fs/Makefile.am b/src/fs/Makefile.am
index f0fa73143..a0d88051a 100644
--- a/src/fs/Makefile.am
+++ b/src/fs/Makefile.am
@@ -24,7 +24,9 @@ lib_LTLIBRARIES = libgnunetfs.la
24plugin_LTLIBRARIES = \ 24plugin_LTLIBRARIES = \
25 libgnunet_plugin_block_fs.la 25 libgnunet_plugin_block_fs.la
26 26
27if HAVE_TESTING
27noinst_LIBRARIES = libgnunetfstest.a 28noinst_LIBRARIES = libgnunetfstest.a
29endif
28 30
29libgnunetfs_la_SOURCES = \ 31libgnunetfs_la_SOURCES = \
30 fs_api.c fs_api.h fs.h \ 32 fs_api.c fs_api.h fs.h \
@@ -66,9 +68,11 @@ libexec_PROGRAMS = \
66 gnunet-helper-fs-publish \ 68 gnunet-helper-fs-publish \
67 gnunet-service-fs 69 gnunet-service-fs
68 70
71if HAVE_TESTING
69noinst_PROGRAMS = \ 72noinst_PROGRAMS = \
70 gnunet-fs-profiler \ 73 gnunet-fs-profiler \
71 gnunet-daemon-fsprofiler 74 gnunet-daemon-fsprofiler
75endif
72 76
73bin_PROGRAMS = \ 77bin_PROGRAMS = \
74 gnunet-auto-share \ 78 gnunet-auto-share \
@@ -235,6 +239,7 @@ if HAVE_BENCHMARKS
235 perf_gnunet_service_fs_p2p_respect 239 perf_gnunet_service_fs_p2p_respect
236endif 240endif
237 241
242if HAVE_TESTING
238check_PROGRAMS = \ 243check_PROGRAMS = \
239 test_plugin_block_fs \ 244 test_plugin_block_fs \
240 test_fs_directory \ 245 test_fs_directory \
@@ -262,6 +267,7 @@ check_PROGRAMS = \
262 test_gnunet_service_fs_p2p \ 267 test_gnunet_service_fs_p2p \
263 test_gnunet_service_fs_p2p_mesh \ 268 test_gnunet_service_fs_p2p_mesh \
264 $(FS_BENCHMARKS) 269 $(FS_BENCHMARKS)
270endif
265 271
266test_plugin_block_fs_SOURCES = \ 272test_plugin_block_fs_SOURCES = \
267 test_plugin_block_fs.c 273 test_plugin_block_fs.c