aboutsummaryrefslogtreecommitdiff
path: root/src/gns/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2017-02-23 22:52:21 +0100
committerChristian Grothoff <christian@grothoff.org>2017-02-23 22:55:30 +0100
commit2309bb75f368da8c44a90d741d78b5e7b8a04f42 (patch)
tree054133d75d0893d4d95ebad42990131e38386c3e /src/gns/Makefile.am
parent0945dcf2c250dea65d520ef26f9917e9be3ac4ac (diff)
downloadgnunet-2309bb75f368da8c44a90d741d78b5e7b8a04f42.tar.gz
gnunet-2309bb75f368da8c44a90d741d78b5e7b8a04f42.zip
change default port to 53, use setcap to enable binding to low port
Diffstat (limited to 'src/gns/Makefile.am')
-rw-r--r--src/gns/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/gns/Makefile.am b/src/gns/Makefile.am
index 8c952be04..464bbbca1 100644
--- a/src/gns/Makefile.am
+++ b/src/gns/Makefile.am
@@ -69,8 +69,8 @@ endif
69 69
70libexec_PROGRAMS = \ 70libexec_PROGRAMS = \
71 gnunet-service-gns \ 71 gnunet-service-gns \
72 $(DO_W32_HELPER) \
73 gnunet-dns2gns \ 72 gnunet-dns2gns \
73 $(DO_W32_HELPER) \
74 $(DO_PROXY) 74 $(DO_PROXY)
75 75
76bin_PROGRAMS = \ 76bin_PROGRAMS = \
@@ -136,6 +136,14 @@ gnunet_dns2gns_LDADD = \
136 $(top_builddir)/src/dns/libgnunetdnsstub.la \ 136 $(top_builddir)/src/dns/libgnunetdnsstub.la \
137 $(GN_LIBINTL) 137 $(GN_LIBINTL)
138 138
139if LINUX
140HIJACKBIN = gnunet-dns2gns
141install-exec-hook:
142 $(SUDO_BINARY) setcap 'cap_net_bind_service=+ep' $(DESTDIR)$(libexecdir)/gnunet-dns2gns || true
143else
144install-exec-hook:
145endif
146
139gnunet_gns_proxy_SOURCES = \ 147gnunet_gns_proxy_SOURCES = \
140 gnunet-gns-proxy.c 148 gnunet-gns-proxy.c
141gnunet_gns_proxy_CPPFLAGS = $(AM_CPPFLAGS) $(CPP_GNURL) 149gnunet_gns_proxy_CPPFLAGS = $(AM_CPPFLAGS) $(CPP_GNURL)