aboutsummaryrefslogtreecommitdiff
path: root/src/gns/Makefile.am
diff options
context:
space:
mode:
authorLRN <lrn1986@gmail.com>2013-12-22 15:51:56 +0000
committerLRN <lrn1986@gmail.com>2013-12-22 15:51:56 +0000
commit52e5c4137c3950e09f462435a2db4179f62cba9e (patch)
treebd4cd0b94e1f90839b371f43237a1eed92c78ba9 /src/gns/Makefile.am
parent816907b6881e3f25a41e845ddd34cc01f79b1a2b (diff)
downloadgnunet-52e5c4137c3950e09f462435a2db4179f62cba9e.tar.gz
gnunet-52e5c4137c3950e09f462435a2db4179f62cba9e.zip
Add compilable gnunet-gns-import
Diffstat (limited to 'src/gns/Makefile.am')
-rw-r--r--src/gns/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/gns/Makefile.am b/src/gns/Makefile.am
index 79f5c0513..3b39755a4 100644
--- a/src/gns/Makefile.am
+++ b/src/gns/Makefile.am
@@ -28,6 +28,7 @@ if MINGW
28 DO_W32_NSP = libw32nsp.la 28 DO_W32_NSP = libw32nsp.la
29 DO_W32_NSPTOOLS = w32nsp-install w32nsp-uninstall w32nsp-resolve 29 DO_W32_NSPTOOLS = w32nsp-install w32nsp-uninstall w32nsp-resolve
30 DO_W32_HS_CONF = gns-helper-service-w32.conf 30 DO_W32_HS_CONF = gns-helper-service-w32.conf
31 DO_NONPOSIX_GNSIMPORT = gnunet-gns-import
31endif 32endif
32USE_VPN = $(top_builddir)/src/vpn/libgnunetvpn.la 33USE_VPN = $(top_builddir)/src/vpn/libgnunetvpn.la
33 34
@@ -66,6 +67,7 @@ libexec_PROGRAMS = \
66 67
67bin_PROGRAMS = \ 68bin_PROGRAMS = \
68 $(DO_W32_NSPTOOLS) \ 69 $(DO_W32_NSPTOOLS) \
70 $(DO_NONPOSIX_GNSIMPORT) \
69 gnunet-gns 71 gnunet-gns
70 72
71if HAVE_MHD 73if HAVE_MHD
@@ -163,6 +165,20 @@ gnunet_gns_helper_service_w32_DEPENDENCIES = \
163 $(top_builddir)/src/identity/libgnunetidentity.la \ 165 $(top_builddir)/src/identity/libgnunetidentity.la \
164 libgnunetgns.la 166 libgnunetgns.la
165 167
168gnunet_gns_import_SOURCES = \
169 gnunet-gns-import.c
170gnunet_gns_import_LDADD = \
171 $(top_builddir)/src/identity/libgnunetidentity.la \
172 $(top_builddir)/src/namestore/libgnunetnamestore.la \
173 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
174 $(top_builddir)/src/util/libgnunetutil.la \
175 $(GN_LIBINTL)
176gnunet_gns_import_DEPENDENCIES = \
177 $(top_builddir)/src/util/libgnunetutil.la \
178 $(top_builddir)/src/namestore/libgnunetnamestore.la \
179 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
180 $(top_builddir)/src/identity/libgnunetidentity.la
181
166w32nsp_install_SOURCES = \ 182w32nsp_install_SOURCES = \
167 w32nsp-install.c 183 w32nsp-install.c
168w32nsp_install_LDADD = -lws2_32 184w32nsp_install_LDADD = -lws2_32