aboutsummaryrefslogtreecommitdiff
path: root/src/gns/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <mschanzenbach@posteo.de>2015-03-11 12:54:22 +0000
committerMartin Schanzenbach <mschanzenbach@posteo.de>2015-03-11 12:54:22 +0000
commit86882d3e761fe639e833446ccfef8d31e0e42998 (patch)
tree0d7c054aed321dff8b3a0f469068e546bdfc7f2b /src/gns/Makefile.am
parent4bbe44b460db015f8c784d4b699f6d381d2d96c3 (diff)
downloadgnunet-86882d3e761fe639e833446ccfef8d31e0e42998.tar.gz
gnunet-86882d3e761fe639e833446ccfef8d31e0e42998.zip
REST Service
Diffstat (limited to 'src/gns/Makefile.am')
-rw-r--r--src/gns/Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/src/gns/Makefile.am b/src/gns/Makefile.am
index 687c5f43f..0d9ef5de5 100644
--- a/src/gns/Makefile.am
+++ b/src/gns/Makefile.am
@@ -85,12 +85,26 @@ bin_PROGRAMS += gnunet-bcd
85endif 85endif
86endif 86endif
87 87
88if HAVE_REST
89REST_PLUGIN = libgnunet_plugin_rest_gns.la
90endif
91
88bin_SCRIPTS = gnunet-gns-proxy-setup-ca 92bin_SCRIPTS = gnunet-gns-proxy-setup-ca
89 93
90plugin_LTLIBRARIES = \ 94plugin_LTLIBRARIES = \
91 libgnunet_plugin_block_gns.la \ 95 libgnunet_plugin_block_gns.la \
92 libgnunet_plugin_gnsrecord_gns.la 96 libgnunet_plugin_gnsrecord_gns.la \
97 $(REST_PLUGIN)
93 98
99libgnunet_plugin_rest_gns_la_SOURCES = \
100 plugin_rest_gns.c
101libgnunet_plugin_rest_gns_la_LIBADD = \
102 $(top_builddir)/src/gns/libgnunetgns.la \
103 $(top_builddir)/src/identity/libgnunetidentity.la \
104 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
105 $(LTLIBINTL) -ljansson
106libgnunet_plugin_rest_gns_la_LDFLAGS = \
107 $(GN_PLUGIN_LDFLAGS)
94 108
95libgnunet_plugin_gnsrecord_gns_la_SOURCES = \ 109libgnunet_plugin_gnsrecord_gns_la_SOURCES = \
96 plugin_gnsrecord_gns.c 110 plugin_gnsrecord_gns.c