aboutsummaryrefslogtreecommitdiff
path: root/src/gns/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-10-16 11:34:10 +0000
committerChristian Grothoff <christian@grothoff.org>2013-10-16 11:34:10 +0000
commitb6bfed8309e6b9b3286b8f608ad899bfb0a97205 (patch)
tree46cadaba7deadf7cb07dcc0b3d07f28fc147ffc2 /src/gns/Makefile.am
parent5ad45d439b900ea388b93aca8547ad03c53ddc68 (diff)
downloadgnunet-b6bfed8309e6b9b3286b8f608ad899bfb0a97205.tar.gz
gnunet-b6bfed8309e6b9b3286b8f608ad899bfb0a97205.zip
-moving code to new libgnunetgnsrecord in preparation for addressing #3052
Diffstat (limited to 'src/gns/Makefile.am')
-rw-r--r--src/gns/Makefile.am17
1 files changed, 9 insertions, 8 deletions
diff --git a/src/gns/Makefile.am b/src/gns/Makefile.am
index e18a99fad..a3222482c 100644
--- a/src/gns/Makefile.am
+++ b/src/gns/Makefile.am
@@ -58,12 +58,12 @@ endif
58libexec_PROGRAMS = \ 58libexec_PROGRAMS = \
59 gnunet-service-gns \ 59 gnunet-service-gns \
60 $(DO_W32_HELPER) \ 60 $(DO_W32_HELPER) \
61 gnunet-dns2gns 61 gnunet-dns2gns
62# $(DO_PROXY) 62# $(DO_PROXY)
63 63
64bin_PROGRAMS = \ 64bin_PROGRAMS = \
65 $(DO_W32_NSPTOOLS) \ 65 $(DO_W32_NSPTOOLS) \
66 gnunet-gns 66 gnunet-gns
67 67
68bin_SCRIPTS = gnunet-gns-proxy-setup-ca 68bin_SCRIPTS = gnunet-gns-proxy-setup-ca
69 69
@@ -74,6 +74,7 @@ gnunet_gns_SOURCES = \
74 gnunet-gns.c 74 gnunet-gns.c
75gnunet_gns_LDADD = \ 75gnunet_gns_LDADD = \
76 $(top_builddir)/src/gns/libgnunetgns.la \ 76 $(top_builddir)/src/gns/libgnunetgns.la \
77 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
77 $(top_builddir)/src/namestore/libgnunetnamestore.la \ 78 $(top_builddir)/src/namestore/libgnunetnamestore.la \
78 $(top_builddir)/src/identity/libgnunetidentity.la \ 79 $(top_builddir)/src/identity/libgnunetidentity.la \
79 $(top_builddir)/src/util/libgnunetutil.la \ 80 $(top_builddir)/src/util/libgnunetutil.la \
@@ -103,7 +104,7 @@ gnunet_dns2gns_DEPENDENCIES = \
103 libgnunetgns.la 104 libgnunetgns.la
104 105
105gnunet_gns_proxy_SOURCES = \ 106gnunet_gns_proxy_SOURCES = \
106 gnunet-gns-proxy.c 107 gnunet-gns-proxy.c
107gnunet_gns_proxy_LDADD = -lmicrohttpd -lcurl -lgnutls \ 108gnunet_gns_proxy_LDADD = -lmicrohttpd -lcurl -lgnutls \
108 $(top_builddir)/src/gns/libgnunetgns.la \ 109 $(top_builddir)/src/gns/libgnunetgns.la \
109 $(top_builddir)/src/identity/libgnunetidentity.la \ 110 $(top_builddir)/src/identity/libgnunetidentity.la \
@@ -140,7 +141,7 @@ gnunet_service_gns_SOURCES = \
140 gnunet-service-gns.c \ 141 gnunet-service-gns.c \
141 gnunet-service-gns_resolver.c gnunet-service-gns_resolver.h \ 142 gnunet-service-gns_resolver.c gnunet-service-gns_resolver.h \
142 gnunet-service-gns_shorten.c gnunet-service-gns_shorten.h \ 143 gnunet-service-gns_shorten.c gnunet-service-gns_shorten.h \
143 gnunet-service-gns_interceptor.c gnunet-service-gns_interceptor.h 144 gnunet-service-gns_interceptor.c gnunet-service-gns_interceptor.h
144gnunet_service_gns_LDADD = \ 145gnunet_service_gns_LDADD = \
145 -lm \ 146 -lm \
146 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 147 $(top_builddir)/src/statistics/libgnunetstatistics.la \
@@ -206,9 +207,9 @@ check_SCRIPTS = \
206 test_gns_ns_lookup.sh \ 207 test_gns_ns_lookup.sh \
207 test_gns_dht_lookup.sh\ 208 test_gns_dht_lookup.sh\
208 test_gns_pseu_shorten.sh\ 209 test_gns_pseu_shorten.sh\
209 test_gns_plus_lookup.sh\ 210 test_gns_plus_lookup.sh\
210 test_gns_zkey_lookup.sh\ 211 test_gns_zkey_lookup.sh\
211 test_gns_cname_lookup.sh 212 test_gns_cname_lookup.sh
212 213
213if ENABLE_TEST_RUN 214if ENABLE_TEST_RUN
214if HAVE_SQLITE 215if HAVE_SQLITE