aboutsummaryrefslogtreecommitdiff
path: root/src/gns/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <mschanzenbach@posteo.de>2015-09-11 15:56:39 +0000
committerMartin Schanzenbach <mschanzenbach@posteo.de>2015-09-11 15:56:39 +0000
commitc8aace43c41d50e03bd28b6e696b33c1da8b6c4c (patch)
tree375181e89bd4f099e0a2039ed0962bf7cfd48131 /src/gns/Makefile.am
parenta12f20bd4c621a7b5e88ca52830ad1bb74a8e2d8 (diff)
downloadgnunet-c8aace43c41d50e03bd28b6e696b33c1da8b6c4c.tar.gz
gnunet-c8aace43c41d50e03bd28b6e696b33c1da8b6c4c.zip
- move rest plugins into rest directory where they belong
Diffstat (limited to 'src/gns/Makefile.am')
-rw-r--r--src/gns/Makefile.am18
1 files changed, 1 insertions, 17 deletions
diff --git a/src/gns/Makefile.am b/src/gns/Makefile.am
index d4c65031e..728b5636c 100644
--- a/src/gns/Makefile.am
+++ b/src/gns/Makefile.am
@@ -85,27 +85,11 @@ bin_PROGRAMS += gnunet-bcd
85endif 85endif
86endif 86endif
87 87
88if HAVE_REST
89REST_PLUGIN = libgnunet_plugin_rest_gns.la
90endif
91
92bin_SCRIPTS = gnunet-gns-proxy-setup-ca 88bin_SCRIPTS = gnunet-gns-proxy-setup-ca
93 89
94plugin_LTLIBRARIES = \ 90plugin_LTLIBRARIES = \
95 libgnunet_plugin_block_gns.la \ 91 libgnunet_plugin_block_gns.la \
96 libgnunet_plugin_gnsrecord_gns.la \ 92 libgnunet_plugin_gnsrecord_gns.la
97 $(REST_PLUGIN)
98
99libgnunet_plugin_rest_gns_la_SOURCES = \
100 plugin_rest_gns.c
101libgnunet_plugin_rest_gns_la_LIBADD = \
102 $(top_builddir)/src/gns/libgnunetgns.la \
103 $(top_builddir)/src/identity/libgnunetidentity.la \
104 $(top_builddir)/src/rest/libgnunetrest.la \
105 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
106 $(LTLIBINTL) -ljansson -lmicrohttpd
107libgnunet_plugin_rest_gns_la_LDFLAGS = \
108 $(GN_PLUGIN_LDFLAGS)
109 93
110libgnunet_plugin_gnsrecord_gns_la_SOURCES = \ 94libgnunet_plugin_gnsrecord_gns_la_SOURCES = \
111 plugin_gnsrecord_gns.c 95 plugin_gnsrecord_gns.c