summaryrefslogtreecommitdiff
path: root/src/gns/nss/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <mschanzenbach@posteo.de>2012-05-08 12:02:49 +0000
committerMartin Schanzenbach <mschanzenbach@posteo.de>2012-05-08 12:02:49 +0000
commit2912ade365b2f3192f42af5aca9edd29256e0956 (patch)
tree6da4e4da16d377fe822283a075982e0303702b44 /src/gns/nss/Makefile.am
parent95c53a7451be0ede2a2bad5ee8f7160e85342a11 (diff)
downloadgnunet-2912ade365b2f3192f42af5aca9edd29256e0956.tar.gz
gnunet-2912ade365b2f3192f42af5aca9edd29256e0956.zip
-nss build files
Diffstat (limited to 'src/gns/nss/Makefile.am')
-rw-r--r--src/gns/nss/Makefile.am57
1 files changed, 57 insertions, 0 deletions
diff --git a/src/gns/nss/Makefile.am b/src/gns/nss/Makefile.am
new file mode 100644
index 000000000..f77743e5c
--- /dev/null
+++ b/src/gns/nss/Makefile.am
@@ -0,0 +1,57 @@
1# $Id$
2#
3# This file taken and modified from nss-gns.
4#
5# nss-gns is free software; you can redistribute it and/or modify it
6# under the terms of the GNU Lesser General Public License as
7# published by the Free Software Foundation; either version 2 of the
8# License, or (at your option) any later version.
9#
10# nss-gns is distributed in the hope that it will be useful, but
11# WITHOUT ANY WARRANTY; without even the implied warranty of
12# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
13# General Public License for more details.
14#
15# You should have received a copy of the GNU Lesser General Public
16# License along with nss-gns; if not, write to the Free Software
17# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
18# USA.
19
20EXTRA_DIST = map-file
21
22# This cool debug trap works on i386/gcc only
23AM_CFLAGS='-DDEBUG_TRAP=__asm__("int $$3")'
24
25AM_LDFLAGS=-avoid-version -module -export-dynamic
26
27lib_LTLIBRARIES =
28
29lib_LTLIBRARIES += \
30 libnss_gns.la \
31 libnss_gns4.la \
32 libnss_gns6.la
33
34sources = util.c util.h query.h
35
36# GNU Libc
37libnss_gns_la_SOURCES= $(sources) nss_gns.c
38libnss_gns_la_CFLAGS=$(AM_CFLAGS)
39libnss_gns_la_LDFLAGS=$(AM_LDFLAGS) -shrext .so.2 -Wl,-version-script=$(srcdir)/map-file
40
41libnss_gns4_la_SOURCES=$(libnss_gns_la_SOURCES)
42libnss_gns4_la_CFLAGS=$(libnss_gns_la_CFLAGS) -DNSS_IPV4_ONLY=1
43libnss_gns4_la_LDFLAGS=$(libnss_gns_la_LDFLAGS)
44
45libnss_gns6_la_SOURCES=$(libnss_gns_la_SOURCES)
46libnss_gns6_la_CFLAGS=$(libnss_gns_la_CFLAGS) -DNSS_IPV6_ONLY=1
47libnss_gns6_la_LDFLAGS=$(libnss_gns_la_LDFLAGS)
48
49install-exec-hook:
50 rm -f $(DESTDIR)$(libdir)/libnss_gns.la
51 rm -f $(DESTDIR)$(libdir)/libnss_gns4.la
52 rm -f $(DESTDIR)$(libdir)/libnss_gns6.la
53
54uninstall-hook:
55 rm -f $(DESTDIR)$(libdir)/libnss_gns.so.2
56 rm -f $(DESTDIR)$(libdir)/libnss_gns4.so.2
57 rm -f $(DESTDIR)$(libdir)/libnss_gns6.so.2