summaryrefslogtreecommitdiff
path: root/src/gns/nss/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-09-17 12:07:58 +0000
committerChristian Grothoff <christian@grothoff.org>2012-09-17 12:07:58 +0000
commit7e3313ce2b4797bde341340f4402ddc14cb63138 (patch)
treead5b6270bab4049e6de09de0595981473d13fd9f /src/gns/nss/Makefile.am
parent7376708ac7b99e80fb28e47b4acb305ef8069d3c (diff)
downloadgnunet-7e3313ce2b4797bde341340f4402ddc14cb63138.tar.gz
gnunet-7e3313ce2b4797bde341340f4402ddc14cb63138.zip
-adding GPLv3 license, adding uninstall script to fix #2534
Diffstat (limited to 'src/gns/nss/Makefile.am')
-rw-r--r--src/gns/nss/Makefile.am16
1 files changed, 5 insertions, 11 deletions
diff --git a/src/gns/nss/Makefile.am b/src/gns/nss/Makefile.am
index f658832b8..0569fce7d 100644
--- a/src/gns/nss/Makefile.am
+++ b/src/gns/nss/Makefile.am
@@ -3,8 +3,8 @@
3# This file taken and modified from nss-gns. 3# This file taken and modified from nss-gns.
4# 4#
5# nss-gns is free software; you can redistribute it and/or modify it 5# nss-gns is free software; you can redistribute it and/or modify it
6# under the terms of the GNU Lesser General Public License as 6# under the terms of the GNU General Public License as
7# published by the Free Software Foundation; either version 2 of the 7# published by the Free Software Foundation; either version 3 of the
8# License, or (at your option) any later version. 8# License, or (at your option) any later version.
9# 9#
10# nss-gns is distributed in the hope that it will be useful, but 10# nss-gns is distributed in the hope that it will be useful, but
@@ -52,17 +52,11 @@ libnss_gns6_la_CFLAGS=$(libnss_gns_la_CFLAGS) -DNSS_IPV6_ONLY=1
52libnss_gns6_la_LDFLAGS=$(libnss_gns_la_LDFLAGS) 52libnss_gns6_la_LDFLAGS=$(libnss_gns_la_LDFLAGS)
53 53
54if !MINGW 54if !MINGW
55if HAVE_SUDO
56install-data-hook: 55install-data-hook:
57 $(top_srcdir)/src/gns/nss/install-nss-plugin.sh $(SHELL) $(top_builddir) $(nssdir) $(SUDO_BINARY) 56 $(top_srcdir)/src/gns/nss/install-nss-plugin.sh $(SHELL) $(top_builddir) $(nssdir) $(SUDO_BINARY)
58 57
59uninstall-hook: 58uninstall-hook:
60 $(top_srcdir)/src/gns/nss/uninstall-nss-plugin.sh $(SUDO_BINARY) $(nssdir) 59 $(top_srcdir)/src/gns/nss/uninstall-nss-plugin.sh $(SHELL) $(top_builddir) "rm -f $(nssdir)/libnss_gns.so.2" $(SUDO_BINARY)
61 60 $(top_srcdir)/src/gns/nss/uninstall-nss-plugin.sh $(SHELL) $(top_builddir) "rm -f $(nssdir)/libnss_gns4.so.2" $(SUDO_BINARY)
62endif 61 $(top_srcdir)/src/gns/nss/uninstall-nss-plugin.sh $(SHELL) $(top_builddir) "rm -f $(nssdir)/libnss_gns6.so.2" $(SUDO_BINARY)
63else
64install-data-hook:
65
66uninstall-hook:
67
68endif 62endif