summaryrefslogtreecommitdiff
path: root/src/gns/nss/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-05-31 18:04:28 +0000
committerChristian Grothoff <christian@grothoff.org>2012-05-31 18:04:28 +0000
commitf3fa149e507bf5cca1f499d48c780a4853e7b2c5 (patch)
treefc446fdc671ff5cba0874bb000ab7f2c378a36be /src/gns/nss/Makefile.am
parentdc994999f6702effb64e5bfc3eb727ee0f3723ef (diff)
downloadgnunet-f3fa149e507bf5cca1f499d48c780a4853e7b2c5.tar.gz
gnunet-f3fa149e507bf5cca1f499d48c780a4853e7b2c5.zip
-allow installation even as non-root non-sudo user to succeed with new nss code
Diffstat (limited to 'src/gns/nss/Makefile.am')
-rw-r--r--src/gns/nss/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/gns/nss/Makefile.am b/src/gns/nss/Makefile.am
index c5e415dbf..582aa0696 100644
--- a/src/gns/nss/Makefile.am
+++ b/src/gns/nss/Makefile.am
@@ -21,15 +21,22 @@ EXTRA_DIST = map-file
21 21
22AM_LDFLAGS=-avoid-version -module -export-dynamic 22AM_LDFLAGS=-avoid-version -module -export-dynamic
23 23
24if HAVE_SUDO
24nssdir = /lib/ 25nssdir = /lib/
26else
27nssdir = $(libdir)
28endif
29
25LIBTOOL = $(SUDO_BINARY) $(SHELL) $(top_builddir)/libtool 30LIBTOOL = $(SUDO_BINARY) $(SHELL) $(top_builddir)/libtool
26 31
27if !MINGW 32if !MINGW
33if HAVE_SUDO
28nss_LTLIBRARIES = \ 34nss_LTLIBRARIES = \
29 libnss_gns.la \ 35 libnss_gns.la \
30 libnss_gns4.la \ 36 libnss_gns4.la \
31 libnss_gns6.la 37 libnss_gns6.la
32endif 38endif
39endif
33 40
34sources = util.c util.h query.h query.c 41sources = util.c util.h query.h query.c
35 42