aboutsummaryrefslogtreecommitdiff
path: root/src/gnsrecord/Makefile.am
diff options
context:
space:
mode:
authorTheJackiMonster <thejackimonster@gmail.com>2020-10-01 21:13:43 +0200
committerTheJackiMonster <thejackimonster@gmail.com>2020-11-12 16:57:45 +0100
commit8bf864c25bda97c1448b709a76a168834753ff86 (patch)
tree6ffccc18a3c112e035235c596006f8b13aca1be7 /src/gnsrecord/Makefile.am
parent8fd7531e5841c9d9f80f821a3490a05934fee933 (diff)
downloadgnunet-8bf864c25bda97c1448b709a76a168834753ff86.tar.gz
gnunet-8bf864c25bda97c1448b709a76a168834753ff86.zip
adding the messenger service and its client-side library
Signed-off-by: TheJackiMonster <thejackimonster@gmail.com>
Diffstat (limited to 'src/gnsrecord/Makefile.am')
-rw-r--r--src/gnsrecord/Makefile.am21
1 files changed, 19 insertions, 2 deletions
diff --git a/src/gnsrecord/Makefile.am b/src/gnsrecord/Makefile.am
index 2e6eca7ba..ab604eb92 100644
--- a/src/gnsrecord/Makefile.am
+++ b/src/gnsrecord/Makefile.am
@@ -1,5 +1,5 @@
1# This Makefile.am is in the public domain 1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include 2AM_CPPFLAGS = -I$(top_srcdir)/src/include ${MHD_CFLAGS}
3 3
4plugindir = $(libdir)/gnunet 4plugindir = $(libdir)/gnunet
5 5
@@ -30,12 +30,14 @@ TESTS = \
30endif 30endif
31 31
32lib_LTLIBRARIES = \ 32lib_LTLIBRARIES = \
33 libgnunetgnsrecord.la 33 libgnunetgnsrecord.la \
34 libgnunetgnsrecordjson.la
34 35
35gnunet_gnsrecord_tvg_SOURCES = \ 36gnunet_gnsrecord_tvg_SOURCES = \
36 gnunet-gnsrecord-tvg.c 37 gnunet-gnsrecord-tvg.c
37gnunet_gnsrecord_tvg_LDADD = \ 38gnunet_gnsrecord_tvg_LDADD = \
38 $(top_builddir)/src/util/libgnunetutil.la \ 39 $(top_builddir)/src/util/libgnunetutil.la \
40 $(top_builddir)/src/identity/libgnunetidentity.la \
39 libgnunetgnsrecord.la \ 41 libgnunetgnsrecord.la \
40 $(GN_LIBINTL) 42 $(GN_LIBINTL)
41 43
@@ -47,11 +49,26 @@ libgnunetgnsrecord_la_SOURCES = \
47 gnsrecord_misc.c 49 gnsrecord_misc.c
48libgnunetgnsrecord_la_LIBADD = \ 50libgnunetgnsrecord_la_LIBADD = \
49 $(top_builddir)/src/util/libgnunetutil.la \ 51 $(top_builddir)/src/util/libgnunetutil.la \
52 $(top_builddir)/src/identity/libgnunetidentity.la \
53 $(LIBGCRYPT_LIBS) \
50 $(GN_LIBINTL) 54 $(GN_LIBINTL)
55libgnunetgnsrecord_la_DEPENDENCIES = \
56 $(top_builddir)/src/identity/libgnunetidentity.la
51libgnunetgnsrecord_la_LDFLAGS = \ 57libgnunetgnsrecord_la_LDFLAGS = \
52 $(GN_LIB_LDFLAGS) \ 58 $(GN_LIB_LDFLAGS) \
53 -version-info 0:0:0 59 -version-info 0:0:0
54 60
61libgnunetgnsrecordjson_la_SOURCES = \
62 json_gnsrecord.c
63libgnunetgnsrecordjson_la_LIBADD = \
64 $(top_builddir)/src/util/libgnunetutil.la \
65 $(top_builddir)/src/identity/libgnunetidentity.la \
66 libgnunetgnsrecord.la \
67 -ljansson \
68 $(GN_LIBINTL)
69libgnunetgnsrecordjson_la_LDFLAGS = \
70 $(GN_LIB_LDFLAGS) \
71 -version-info 0:0:0
55 72
56plugin_LTLIBRARIES = \ 73plugin_LTLIBRARIES = \
57 libgnunet_plugin_gnsrecord_dns.la 74 libgnunet_plugin_gnsrecord_dns.la