aboutsummaryrefslogtreecommitdiff
path: root/src/identity/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <mschanzenbach@posteo.de>2015-07-10 16:17:30 +0000
committerMartin Schanzenbach <mschanzenbach@posteo.de>2015-07-10 16:17:30 +0000
commit9246b5973e3ae5eec1d51b35d942dd7e5e9f95d8 (patch)
tree45a4fad135ae25cb58be97e631e6116efce9e9f8 /src/identity/Makefile.am
parent57eb2ec3125dbbf60a9d1a2635ddc19345e2e5c1 (diff)
downloadgnunet-9246b5973e3ae5eec1d51b35d942dd7e5e9f95d8.tar.gz
gnunet-9246b5973e3ae5eec1d51b35d942dd7e5e9f95d8.zip
- Identity token support
Diffstat (limited to 'src/identity/Makefile.am')
-rw-r--r--src/identity/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/identity/Makefile.am b/src/identity/Makefile.am
index b0e7645b0..89f755fd9 100644
--- a/src/identity/Makefile.am
+++ b/src/identity/Makefile.am
@@ -56,7 +56,10 @@ bin_PROGRAMS = \
56 56
57libexec_PROGRAMS = \ 57libexec_PROGRAMS = \
58 gnunet-service-identity 58 gnunet-service-identity
59 59if HAVE_REST
60bin_PROGRAMS += \
61 gnunet-identity-token
62endif
60gnunet_service_identity_SOURCES = \ 63gnunet_service_identity_SOURCES = \
61 gnunet-service-identity.c 64 gnunet-service-identity.c
62gnunet_service_identity_LDADD = \ 65gnunet_service_identity_LDADD = \
@@ -72,6 +75,12 @@ gnunet_identity_LDADD = \
72 $(top_builddir)/src/util/libgnunetutil.la \ 75 $(top_builddir)/src/util/libgnunetutil.la \
73 $(GN_LIBINTL) 76 $(GN_LIBINTL)
74 77
78gnunet_identity_token_SOURCES = \
79 check_token.c
80gnunet_identity_token_LDADD = \
81 $(top_builddir)/src/util/libgnunetutil.la \
82 -ljansson -lmicrohttpd
83 $(GN_LIBINTL)
75 84
76if HAVE_TESTING 85if HAVE_TESTING
77check_PROGRAMS = \ 86check_PROGRAMS = \