aboutsummaryrefslogtreecommitdiff
path: root/src/identity/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <mschanzenbach@posteo.de>2015-09-11 15:56:39 +0000
committerMartin Schanzenbach <mschanzenbach@posteo.de>2015-09-11 15:56:39 +0000
commitc8aace43c41d50e03bd28b6e696b33c1da8b6c4c (patch)
tree375181e89bd4f099e0a2039ed0962bf7cfd48131 /src/identity/Makefile.am
parenta12f20bd4c621a7b5e88ca52830ad1bb74a8e2d8 (diff)
downloadgnunet-c8aace43c41d50e03bd28b6e696b33c1da8b6c4c.tar.gz
gnunet-c8aace43c41d50e03bd28b6e696b33c1da8b6c4c.zip
- move rest plugins into rest directory where they belong
Diffstat (limited to 'src/identity/Makefile.am')
-rw-r--r--src/identity/Makefile.am45
1 files changed, 13 insertions, 32 deletions
diff --git a/src/identity/Makefile.am b/src/identity/Makefile.am
index af4ad5821..f1f0c3851 100644
--- a/src/identity/Makefile.am
+++ b/src/identity/Makefile.am
@@ -19,39 +19,9 @@ libexecdir= $(pkglibdir)/libexec/
19pkgcfg_DATA = \ 19pkgcfg_DATA = \
20 identity.conf 20 identity.conf
21 21
22if HAVE_REST
23REST_PLUGIN = libgnunet_plugin_rest_identity.la
24plugin_LTLIBRARIES = ${REST_PLUGIN}
25endif
26
27lib_LTLIBRARIES = \ 22lib_LTLIBRARIES = \
28 libgnunetidentity.la 23 libgnunetidentity.la \
29 24 libgnunet_plugin_gnsrecord_identity.la
30if HAVE_REST
31plugin_LTLIBRARIES += \
32 libgnunet_plugin_gnsrecord_identity.la
33
34
35libgnunet_plugin_gnsrecord_identity_la_SOURCES = \
36 plugin_gnsrecord_identity.c
37libgnunet_plugin_gnsrecord_identity_la_LIBADD = \
38 $(top_builddir)/src/util/libgnunetutil.la \
39 $(LTLIBINTL)
40libgnunet_plugin_gnsrecord_identity_la_LDFLAGS = \
41 $(GN_PLUGIN_LDFLAGS)
42endif
43
44libgnunet_plugin_rest_identity_la_SOURCES = \
45 plugin_rest_identity.c
46libgnunet_plugin_rest_identity_la_LIBADD = \
47 $(top_builddir)/src/identity/libgnunetidentity.la \
48 $(top_builddir)/src/rest/libgnunetrest.la \
49 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
50 $(LTLIBINTL) -ljansson -lmicrohttpd
51libgnunet_plugin_rest_identity_la_LDFLAGS = \
52 $(GN_PLUGIN_LDFLAGS)
53
54
55 25
56libgnunetidentity_la_SOURCES = \ 26libgnunetidentity_la_SOURCES = \
57 identity_api.c \ 27 identity_api.c \
@@ -69,10 +39,12 @@ bin_PROGRAMS = \
69 39
70libexec_PROGRAMS = \ 40libexec_PROGRAMS = \
71 gnunet-service-identity 41 gnunet-service-identity
42
72if HAVE_REST 43if HAVE_REST
73bin_PROGRAMS += \ 44bin_PROGRAMS += \
74 gnunet-identity-token 45 gnunet-identity-token
75endif 46endif
47
76gnunet_service_identity_SOURCES = \ 48gnunet_service_identity_SOURCES = \
77 gnunet-service-identity.c 49 gnunet-service-identity.c
78gnunet_service_identity_LDADD = \ 50gnunet_service_identity_LDADD = \
@@ -80,6 +52,15 @@ gnunet_service_identity_LDADD = \
80 $(top_builddir)/src/util/libgnunetutil.la \ 52 $(top_builddir)/src/util/libgnunetutil.la \
81 $(GN_LIBINTL) 53 $(GN_LIBINTL)
82 54
55libgnunet_plugin_gnsrecord_identity_la_SOURCES = \
56 plugin_gnsrecord_identity.c
57libgnunet_plugin_gnsrecord_identity_la_LIBADD = \
58 $(top_builddir)/src/util/libgnunetutil.la \
59 $(LTLIBINTL)
60libgnunet_plugin_gnsrecord_identity_la_LDFLAGS = \
61 $(GN_PLUGIN_LDFLAGS)
62
63
83gnunet_identity_SOURCES = \ 64gnunet_identity_SOURCES = \
84 gnunet-identity.c 65 gnunet-identity.c
85gnunet_identity_LDADD = \ 66gnunet_identity_LDADD = \