aboutsummaryrefslogtreecommitdiff
path: root/src/identity/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-07-14 18:20:55 +0000
committerChristian Grothoff <christian@grothoff.org>2013-07-14 18:20:55 +0000
commite43155e9ea536991a489e0fe04890e0269869af1 (patch)
treeb6488239217f7c00d7dc109641292b4ba5092ded /src/identity/Makefile.am
parent206b8c58b7e6843ddb4832692b11032d4fe57541 (diff)
downloadgnunet-e43155e9ea536991a489e0fe04890e0269869af1.tar.gz
gnunet-e43155e9ea536991a489e0fe04890e0269869af1.zip
-skeleton for identity service
Diffstat (limited to 'src/identity/Makefile.am')
-rw-r--r--src/identity/Makefile.am77
1 files changed, 77 insertions, 0 deletions
diff --git a/src/identity/Makefile.am b/src/identity/Makefile.am
new file mode 100644
index 000000000..1b7767fe1
--- /dev/null
+++ b/src/identity/Makefile.am
@@ -0,0 +1,77 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
5endif
6
7if USE_COVERAGE
8 AM_CFLAGS = --coverage -O0
9 XLIB = -lgcov
10endif
11
12pkgcfgdir= $(pkgdatadir)/config.d/
13
14libexecdir= $(pkglibdir)/libexec/
15
16pkgcfg_DATA = \
17 identity.conf
18
19
20lib_LTLIBRARIES = libgnunetidentity.la
21
22libgnunetidentity_la_SOURCES = \
23 identity_api.c identity.h
24libgnunetidentity_la_LIBADD = \
25 $(top_builddir)/src/util/libgnunetutil.la \
26 $(GN_LIBINTL) $(XLIB)
27libgnunetidentity_la_LDFLAGS = \
28 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
29 -version-info 0:0:0
30
31bin_PROGRAMS = \
32 gnunet-identity
33
34libexec_PROGRAMS = \
35 gnunet-service-identity
36
37gnunet_service_identity_SOURCES = \
38 gnunet-service-identity.c
39gnunet_service_identity_LDADD = \
40 $(top_builddir)/src/util/libgnunetutil.la \
41 $(top_builddir)/src/statistics/libgnunetstatistics.la \
42 $(GN_LIBINTL)
43gnunet_service_identity_DEPENDENCIES = \
44 libgnunetidentity.la
45
46gnunet_identity_SOURCES = \
47 gnunet-identity.c
48gnunet_identity_LDADD = \
49 $(top_builddir)/src/identity/libgnunetidentity.la \
50 $(top_builddir)/src/util/libgnunetutil.la \
51 $(top_builddir)/src/statistics/libgnunetstatistics.la \
52 $(GN_LIBINTL)
53gnunet_service_identity_DEPENDENCIES = \
54 libgnunetidentity.la
55
56
57if HAVE_TESTING
58check_PROGRAMS = \
59 test_identity_api
60endif
61
62if ENABLE_TEST_RUN
63TESTS = $(check_PROGRAMS)
64endif
65
66test_identity_api_SOURCES = \
67 test_identity_api.c
68test_identity_api_LDADD = \
69 $(top_builddir)/src/identity/libgnunetidentity.la \
70 $(top_builddir)/src/testing/libgnunettesting.la \
71 $(top_builddir)/src/util/libgnunetutil.la
72
73
74EXTRA_DIST = \
75 test_identity.conf
76
77