aboutsummaryrefslogtreecommitdiff
path: root/src/json/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2019-05-03 15:10:26 +0200
committerChristian Grothoff <christian@grothoff.org>2019-05-03 15:10:46 +0200
commit4444fb80284aa86fe24f3640a0b1e4c841a98f9a (patch)
tree17ef4a5b51f2ff51b476e28f8aa6443b29f8b5ac /src/json/Makefile.am
parentafe1bb7673a350d86228e2d916e346e27e4fe7a6 (diff)
downloadgnunet-4444fb80284aa86fe24f3640a0b1e4c841a98f9a.tar.gz
gnunet-4444fb80284aa86fe24f3640a0b1e4c841a98f9a.zip
add test for json_mhd.c logic
Diffstat (limited to 'src/json/Makefile.am')
-rw-r--r--src/json/Makefile.am26
1 files changed, 25 insertions, 1 deletions
diff --git a/src/json/Makefile.am b/src/json/Makefile.am
index f3fa28d69..f030c3016 100644
--- a/src/json/Makefile.am
+++ b/src/json/Makefile.am
@@ -25,7 +25,8 @@ libgnunetjson_la_LIBADD = \
25 $(XLIB) 25 $(XLIB)
26 26
27check_PROGRAMS = \ 27check_PROGRAMS = \
28 test_json 28 test_json \
29 test_json_mhd
29 30
30TESTS = \ 31TESTS = \
31 $(check_PROGRAMS) 32 $(check_PROGRAMS)
@@ -36,3 +37,26 @@ test_json_LDADD = \
36 libgnunetjson.la \ 37 libgnunetjson.la \
37 $(top_builddir)/src/util/libgnunetutil.la \ 38 $(top_builddir)/src/util/libgnunetutil.la \
38 -ljansson 39 -ljansson
40
41
42if HAVE_LIBGNURL
43LIB_GNURL=@LIBGNURL@
44CPP_GNURL=@LIBGNURL_CPPFLAGS@
45else
46if HAVE_LIBCURL
47LIB_GNURL=@LIBCURL@
48CPP_GNURL=@LIBCURL_CPPFLAGS@
49endif
50endif
51
52
53test_json_mhd_SOURCES = \
54 test_json_mhd.c
55test_json_mhd_LDADD = \
56 libgnunetjson.la \
57 $(top_builddir)/src/util/libgnunetutil.la \
58 -ljansson \
59 -lmicrohttpd \
60 $(LIB_GNURL)
61test_json_mhd_CPPFLAGS = \
62 $(CPP_GNURL) $(AM_CPPFLAGS)