aboutsummaryrefslogtreecommitdiff
path: root/src/jsonapi/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <mschanzenbach@posteo.de>2016-05-02 16:32:36 +0000
committerMartin Schanzenbach <mschanzenbach@posteo.de>2016-05-02 16:32:36 +0000
commitbee208bcd6803829aa26c55a4c8e176a5f2c815f (patch)
tree6974bc9e94a1ec938b5376d2631233d2e75baf7d /src/jsonapi/Makefile.am
parentfc9b25be2dbe5392501dbc0b6659c1aa50809bc2 (diff)
downloadgnunet-bee208bcd6803829aa26c55a4c8e176a5f2c815f.tar.gz
gnunet-bee208bcd6803829aa26c55a4c8e176a5f2c815f.zip
- Refactor jsonapi into separate module
Diffstat (limited to 'src/jsonapi/Makefile.am')
-rw-r--r--src/jsonapi/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/jsonapi/Makefile.am b/src/jsonapi/Makefile.am
new file mode 100644
index 000000000..1d3fcc760
--- /dev/null
+++ b/src/jsonapi/Makefile.am
@@ -0,0 +1,34 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage -O0
6 XLIB = -lgcov
7endif
8
9lib_LTLIBRARIES = \
10 libgnunetjsonapi.la
11
12libgnunetjsonapi_la_LDFLAGS = \
13 -version-info 0:0:0 \
14 -no-undefined
15libgnunetjsonapi_la_SOURCES = \
16 jsonapi.c
17libgnunetjsonapi_la_LIBADD = \
18 $(top_builddir)/src/util/libgnunetutil.la \
19 $(top_builddir)/src/json/libgnunetjson.la \
20 -ljansson \
21 $(XLIB)
22
23#check_PROGRAMS = \
24# test_json
25
26#TESTS = \
27# $(check_PROGRAMS)
28
29#test_json_SOURCES = \
30# test_json.c
31#test_json_LDADD = \
32# libgnunetjson.la \
33# $(top_builddir)/src/util/libgnunetutil.la \
34# -ljansson