aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <mschanzenbach@posteo.de>2015-08-11 14:41:03 +0000
committerMartin Schanzenbach <mschanzenbach@posteo.de>2015-08-11 14:41:03 +0000
commit7fe8782a2beffafb0fa3fadae43d4498335f4472 (patch)
tree1d5982382d50b31e3434f74df1c61fae9d8bb573 /src/namestore/Makefile.am
parent7226997d96e7c2724d912553d1c7e613ee4cdd04 (diff)
downloadgnunet-7fe8782a2beffafb0fa3fadae43d4498335f4472.tar.gz
gnunet-7fe8782a2beffafb0fa3fadae43d4498335f4472.zip
- flat namestore plugin (experimental)
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index 2f8c81425..221e88a91 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -20,6 +20,13 @@ if USE_COVERAGE
20 XLIBS = -lgcov 20 XLIBS = -lgcov
21endif 21endif
22 22
23if HAVE_EXPERIMENTAL
24FLAT_PLUGIN = libgnunet_plugin_namestore_flat.la
25if HAVE_TESTING
26FLAT_TESTS = test_plugin_namestore_flat
27endif
28endif
29
23if HAVE_SQLITE 30if HAVE_SQLITE
24SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la 31SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la
25if HAVE_TESTING 32if HAVE_TESTING
@@ -60,6 +67,7 @@ if HAVE_SQLITE
60check_PROGRAMS = \ 67check_PROGRAMS = \
61 $(SQLITE_TESTS) \ 68 $(SQLITE_TESTS) \
62 $(POSTGRES_TESTS) \ 69 $(POSTGRES_TESTS) \
70 $(FLAT_TESTS) \
63 $(TESTING_TESTS) 71 $(TESTING_TESTS)
64endif 72endif
65 73
@@ -150,8 +158,20 @@ gnunet_service_namestore_LDADD = \
150plugin_LTLIBRARIES = \ 158plugin_LTLIBRARIES = \
151 $(SQLITE_PLUGIN) \ 159 $(SQLITE_PLUGIN) \
152 $(POSTGRES_PLUGIN) \ 160 $(POSTGRES_PLUGIN) \
161 $(FLAT_PLUGIN) \
153 $(REST_PLUGIN) 162 $(REST_PLUGIN)
154 163
164libgnunet_plugin_namestore_flat_la_SOURCES = \
165 plugin_namestore_flat.c
166libgnunet_plugin_namestore_flat_la_LIBADD = \
167 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
168 $(top_builddir)/src/statistics/libgnunetstatistics.la \
169 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
170 $(LTLIBINTL)
171libgnunet_plugin_namestore_flat_la_LDFLAGS = \
172 $(GN_PLUGIN_LDFLAGS)
173
174
155libgnunet_plugin_namestore_sqlite_la_SOURCES = \ 175libgnunet_plugin_namestore_sqlite_la_SOURCES = \
156 plugin_namestore_sqlite.c 176 plugin_namestore_sqlite.c
157libgnunet_plugin_namestore_sqlite_la_LIBADD = \ 177libgnunet_plugin_namestore_sqlite_la_LIBADD = \
@@ -307,6 +327,12 @@ test_namestore_api_zone_iteration_stop_LDADD = \
307 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 327 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
308 libgnunetnamestore.la 328 libgnunetnamestore.la
309 329
330test_plugin_namestore_flat_SOURCES = \
331 test_plugin_namestore.c
332test_plugin_namestore_flat_LDADD = \
333 $(top_builddir)/src/testing/libgnunettesting.la \
334 $(top_builddir)/src/util/libgnunetutil.la
335
310test_plugin_namestore_sqlite_SOURCES = \ 336test_plugin_namestore_sqlite_SOURCES = \
311 test_plugin_namestore.c 337 test_plugin_namestore.c
312test_plugin_namestore_sqlite_LDADD = \ 338test_plugin_namestore_sqlite_LDADD = \
@@ -328,6 +354,7 @@ EXTRA_DIST = \
328 test_namestore_api.conf \ 354 test_namestore_api.conf \
329 test_plugin_namestore_sqlite.conf \ 355 test_plugin_namestore_sqlite.conf \
330 test_plugin_namestore_postgres.conf \ 356 test_plugin_namestore_postgres.conf \
357 test_plugin_namestore_flat.conf \
331 test_hostkey \ 358 test_hostkey \
332 zonefiles/S5I9DSGQVAB5FVV16T3B3CC5H1B2JGL3Q412JBKURME8EKU0600G.zkey \ 359 zonefiles/S5I9DSGQVAB5FVV16T3B3CC5H1B2JGL3Q412JBKURME8EKU0600G.zkey \
333 zonefiles/AQ835GVL939H4O8QJQ7GBLPTQC0QAAO91BN7QK01BA63MDSK6I4G.zkey \ 360 zonefiles/AQ835GVL939H4O8QJQ7GBLPTQC0QAAO91BN7QK01BA63MDSK6I4G.zkey \