aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2022-03-16 18:53:22 +0100
committerMartin Schanzenbach <schanzen@gnunet.org>2022-03-16 18:53:22 +0100
commit68ac68b70cf7fac5367421badade9febbaea7bf2 (patch)
treef6987aedad35faf7ef7e951bfa802511f270f70e /src/namestore/Makefile.am
parenta3343861db6a9e55707c1a55f7c5d2a4738f4ea0 (diff)
downloadgnunet-68ac68b70cf7fac5367421badade9febbaea7bf2.tar.gz
gnunet-68ac68b70cf7fac5367421badade9febbaea7bf2.zip
NAMESTORE: Add record set blocking API
New API that allows the caller to reserve the mofification of a record set under a label. The record set cannot be modified by other clients until released.
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index 51708dd67..2441b864a 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -39,6 +39,7 @@ if HAVE_SQLITE
39SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la 39SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la
40SQLITE_TESTS = test_plugin_namestore_sqlite \ 40SQLITE_TESTS = test_plugin_namestore_sqlite \
41 test_namestore_api_store_sqlite \ 41 test_namestore_api_store_sqlite \
42 test_namestore_api_store_locking_sqlite \
42 test_namestore_api_store_update_sqlite \ 43 test_namestore_api_store_update_sqlite \
43 test_namestore_api_zone_iteration_sqlite \ 44 test_namestore_api_zone_iteration_sqlite \
44 test_namestore_api_remove_sqlite \ 45 test_namestore_api_remove_sqlite \
@@ -249,6 +250,16 @@ test_namestore_api_store_sqlite_LDADD = \
249 $(top_builddir)/src/identity/libgnunetidentity.la \ 250 $(top_builddir)/src/identity/libgnunetidentity.la \
250 libgnunetnamestore.la 251 libgnunetnamestore.la
251 252
253test_namestore_api_store_locking_sqlite_SOURCES = \
254 test_namestore_api_store_locking.c
255test_namestore_api_store_locking_sqlite_LDADD = \
256 $(top_builddir)/src/testing/libgnunettesting.la \
257 $(top_builddir)/src/util/libgnunetutil.la \
258 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
259 $(top_builddir)/src/identity/libgnunetidentity.la \
260 libgnunetnamestore.la
261
262
252test_namestore_api_store_postgres_SOURCES = \ 263test_namestore_api_store_postgres_SOURCES = \
253 test_namestore_api_store.c 264 test_namestore_api_store.c
254test_namestore_api_store_postgres_LDADD = \ 265test_namestore_api_store_postgres_LDADD = \