aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2023-10-19 09:37:26 +0200
committerMartin Schanzenbach <schanzen@gnunet.org>2023-10-19 09:37:26 +0200
commitb7a1d4379ebcff1c878d068cbd8df34fd16d81d4 (patch)
treef7f1c37fb5f106ca165a79a5c5fb4f3e13abbdc2 /src/namestore/Makefile.am
parent54a37c4239d34fc3b681df78a5a8b4d6a7bde902 (diff)
downloadgnunet-b7a1d4379ebcff1c878d068cbd8df34fd16d81d4.tar.gz
gnunet-b7a1d4379ebcff1c878d068cbd8df34fd16d81d4.zip
BUILD: Move namestore to service
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am543
1 files changed, 0 insertions, 543 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
deleted file mode 100644
index 685829cc2..000000000
--- a/src/namestore/Makefile.am
+++ /dev/null
@@ -1,543 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include $(POSTGRESQL_CPPFLAGS)
3
4plugindir = $(libdir)/gnunet
5
6pkgcfgdir= $(pkgdatadir)/config.d/
7
8libexecdir= $(pkglibdir)/libexec/
9
10sqldir = $(prefix)/share/gnunet/sql/
11
12sql_DATA = \
13 namestore-0001.sql \
14 namestore-drop.sql
15
16pkgcfg_DATA = \
17 namestore.conf
18
19if USE_COVERAGE
20 AM_CFLAGS = --coverage -O0
21 XLIBS = -lgcov
22endif
23
24
25if HAVE_SQLITE
26SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la
27SQLITE_TESTS = test_plugin_namestore_sqlite \
28 test_namestore_api_store_sqlite \
29 test_namestore_api_store_update_sqlite \
30 test_namestore_api_zone_iteration_sqlite \
31 test_namestore_api_remove_sqlite \
32 test_namestore_api_lookup_nick_sqlite \
33 test_namestore_api_monitoring_sqlite \
34 test_namestore_api_remove_not_existing_record_sqlite \
35 test_namestore_api_zone_iteration_nick_sqlite \
36 test_namestore_api_zone_iteration_specific_zone_sqlite \
37 test_namestore_api_zone_iteration_stop_sqlite \
38 test_namestore_api_monitoring_existing_sqlite \
39 test_namestore_api_zone_to_name_sqlite \
40 perf_namestore_api_zone_iteration_sqlite \
41 perf_namestore_api_import_sqlite \
42 perf_namestore_api_import_postgres \
43 test_namestore_api_tx_rollback_sqlite
44endif
45
46
47if HAVE_POSTGRESQL
48POSTGRES_PLUGIN = libgnunet_plugin_namestore_postgres.la
49POSTGRES_TESTS = test_plugin_namestore_postgres \
50 test_namestore_api_store_postgres \
51 test_namestore_api_store_update_postgres \
52 test_namestore_api_remove_postgres \
53 test_namestore_api_zone_iteration_postgres \
54 test_namestore_api_lookup_nick_postgres \
55 test_namestore_api_monitoring_postgres \
56 test_namestore_api_remove_not_existing_record_postgres \
57 test_namestore_api_zone_iteration_nick_postgres \
58 test_namestore_api_zone_iteration_specific_zone_postgres \
59 test_namestore_api_zone_iteration_stop_postgres \
60 test_namestore_api_monitoring_existing_postgres \
61 test_namestore_api_zone_to_name_postgres \
62 perf_namestore_api_zone_iteration_postgres \
63 test_namestore_api_tx_rollback_postgres
64if HAVE_EXPERIMENTAL
65POSTGRES_TESTS += test_namestore_api_edit_records_postgres
66endif
67endif
68
69if HAVE_SQLITE
70check_PROGRAMS = \
71 $(SQLITE_TESTS) \
72 $(POSTGRES_TESTS)
73endif
74
75if ENABLE_TEST_RUN
76AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
77TESTS = \
78 $(check_PROGRAMS) \
79 $(check_SCRIPTS)
80endif
81
82REST_PLUGIN = libgnunet_plugin_rest_namestore.la
83
84lib_LTLIBRARIES = \
85 libgnunetnamestore.la
86
87
88libexec_PROGRAMS = \
89 gnunet-service-namestore
90
91bin_PROGRAMS = \
92 gnunet-namestore \
93 gnunet-namestore-dbtool \
94 gnunet-namestore-zonefile \
95 gnunet-zoneimport
96
97libexec_PROGRAMS += \
98 gnunet-namestore-fcfsd
99
100
101plugin_LTLIBRARIES = \
102 $(SQLITE_PLUGIN) \
103 $(POSTGRES_PLUGIN) \
104 $(REST_PLUGIN)
105
106
107libgnunet_plugin_rest_namestore_la_SOURCES = \
108 plugin_rest_namestore.c
109libgnunet_plugin_rest_namestore_la_LIBADD = \
110 libgnunetnamestore.la \
111 $(top_builddir)/src/service/rest/libgnunetrest.la \
112 $(top_builddir)/src/service/identity/libgnunetidentity.la \
113 $(top_builddir)/src/lib/json/libgnunetjson.la \
114 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
115 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecordjson.la \
116 $(top_builddir)/src/lib/util/libgnunetutil.la $(XLIBS) \
117 $(LTLIBINTL) -ljansson $(MHD_LIBS)
118libgnunet_plugin_rest_namestore_la_LDFLAGS = \
119 $(GN_PLUGIN_LDFLAGS)
120libgnunet_plugin_rest_namestore_la_CFLAGS = $(MHD_CFLAGS) $(AM_CFLAGS)
121
122
123libgnunetnamestore_la_SOURCES = \
124 namestore_api.c \
125 namestore_api_monitor.c \
126 namestore.h
127libgnunetnamestore_la_LIBADD = \
128 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
129 $(top_builddir)/src/service/identity/libgnunetidentity.la \
130 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
131 $(top_builddir)/src/lib/util/libgnunetutil.la \
132 $(GN_LIBINTL)
133libgnunetnamestore_la_LDFLAGS = \
134 $(GN_LIB_LDFLAGS) \
135 -version-info 0:1:0
136
137gnunet_namestore_zonefile_SOURCES = \
138 gnunet-namestore-zonefile.c
139gnunet_namestore_zonefile_LDADD = \
140 libgnunetnamestore.la \
141 $(top_builddir)/src/service/identity/libgnunetidentity.la \
142 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
143 $(top_builddir)/src/lib/util/libgnunetutil.la \
144 $(GN_LIBINTL)
145
146gnunet_zoneimport_SOURCES = \
147 gnunet-zoneimport.c
148gnunet_zoneimport_LDADD = \
149 libgnunetnamestore.la \
150 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
151 $(top_builddir)/src/service/identity/libgnunetidentity.la \
152 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
153 $(top_builddir)/src/lib/util/libgnunetutil.la \
154 $(GN_LIBINTL)
155
156gnunet_namestore_SOURCES = \
157 gnunet-namestore.c
158gnunet_namestore_LDADD = \
159 $(top_builddir)/src/service/identity/libgnunetidentity.la \
160 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
161 $(top_builddir)/src/lib/util/libgnunetutil.la \
162 libgnunetnamestore.la \
163 $(GN_LIBINTL)
164
165gnunet_namestore_dbtool_SOURCES = \
166 gnunet-namestore-dbtool.c
167gnunet_namestore_dbtool_LDADD = \
168 $(top_builddir)/src/lib/util/libgnunetutil.la \
169 libgnunetnamestore.la \
170 $(GN_LIBINTL)
171
172
173
174gnunet_namestore_fcfsd_SOURCES = \
175 gnunet-namestore-fcfsd.c
176gnunet_namestore_fcfsd_LDADD = $(MHD_LIBS) \
177 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
178 $(top_builddir)/src/service/identity/libgnunetidentity.la \
179 libgnunetnamestore.la \
180 $(top_builddir)/src/lib/util/libgnunetutil.la \
181 $(top_builddir)/src/lib/json/libgnunetjson.la \
182 $(GN_LIBINTL) -ljansson
183gnunet_namestore_fcfsd_CFLAGS = $(MHD_CFLAGS) $(AM_CFLAGS)
184
185
186gnunet_service_namestore_SOURCES = \
187 gnunet-service-namestore.c
188gnunet_service_namestore_LDADD = \
189 $(top_builddir)/src/service/namecache/libgnunetnamecache.la \
190 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
191 $(top_builddir)/src/service/identity/libgnunetidentity.la \
192 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
193 $(top_builddir)/src/lib/util/libgnunetutil.la \
194 libgnunetnamestore.la \
195 $(GN_LIBINTL)
196
197
198
199libgnunet_plugin_namestore_sqlite_la_SOURCES = \
200 plugin_namestore_sqlite.c
201libgnunet_plugin_namestore_sqlite_la_LIBADD = \
202 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
203 $(top_builddir)/src/service/identity/libgnunetidentity.la \
204 $(top_builddir)/src/lib/sq/libgnunetsq.la \
205 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
206 $(top_builddir)/src/lib/util/libgnunetutil.la $(XLIBS) -lsqlite3 \
207 $(LTLIBINTL)
208libgnunet_plugin_namestore_sqlite_la_LDFLAGS = \
209 $(GN_PLUGIN_LDFLAGS)
210
211libgnunet_plugin_namestore_postgres_la_SOURCES = \
212 plugin_namestore_postgres.c
213libgnunet_plugin_namestore_postgres_la_LIBADD = \
214 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
215 $(top_builddir)/src/service/identity/libgnunetidentity.la \
216 $(top_builddir)/src/lib/pq/libgnunetpq.la \
217 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
218 $(top_builddir)/src/lib/util/libgnunetutil.la $(XLIBS) -lpq \
219 $(LTLIBINTL)
220libgnunet_plugin_namestore_postgres_la_LDFLAGS = \
221 $(GN_PLUGIN_LDFLAGS) $(POSTGRESQL_LDFLAGS)
222
223test_namestore_api_store_sqlite_SOURCES = \
224 test_namestore_api_store.c
225test_namestore_api_store_sqlite_LDADD = \
226 $(top_builddir)/src/service/testing/libgnunettesting.la \
227 $(top_builddir)/src/lib/util/libgnunetutil.la \
228 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
229 $(top_builddir)/src/service/identity/libgnunetidentity.la \
230 libgnunetnamestore.la
231
232test_namestore_api_store_postgres_SOURCES = \
233 test_namestore_api_store.c
234test_namestore_api_store_postgres_LDADD = \
235 $(top_builddir)/src/service/testing/libgnunettesting.la \
236 $(top_builddir)/src/lib/util/libgnunetutil.la \
237 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
238 $(top_builddir)/src/service/identity/libgnunetidentity.la \
239 libgnunetnamestore.la
240
241test_namestore_api_store_update_sqlite_SOURCES = \
242 test_namestore_api_store_update.c
243test_namestore_api_store_update_sqlite_LDADD = \
244 $(top_builddir)/src/service/testing/libgnunettesting.la \
245 $(top_builddir)/src/lib/util/libgnunetutil.la \
246 $(top_builddir)/src/service/identity/libgnunetidentity.la \
247 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
248 $(top_builddir)/src/service/namecache/libgnunetnamecache.la \
249 libgnunetnamestore.la
250
251test_namestore_api_store_update_postgres_SOURCES = \
252 test_namestore_api_store_update.c
253test_namestore_api_store_update_postgres_LDADD = \
254 $(top_builddir)/src/service/testing/libgnunettesting.la \
255 $(top_builddir)/src/lib/util/libgnunetutil.la \
256 $(top_builddir)/src/service/identity/libgnunetidentity.la \
257 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
258 $(top_builddir)/src/service/namecache/libgnunetnamecache.la \
259 libgnunetnamestore.la
260
261test_namestore_api_lookup_nick_sqlite_SOURCES = \
262 test_namestore_api_lookup_nick.c
263test_namestore_api_lookup_nick_sqlite_LDADD = \
264 $(top_builddir)/src/service/testing/libgnunettesting.la \
265 $(top_builddir)/src/lib/util/libgnunetutil.la \
266 $(top_builddir)/src/service/identity/libgnunetidentity.la \
267 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
268 $(top_builddir)/src/service/namecache/libgnunetnamecache.la \
269 libgnunetnamestore.la
270
271test_namestore_api_lookup_nick_postgres_SOURCES = \
272 test_namestore_api_lookup_nick.c
273test_namestore_api_lookup_nick_postgres_LDADD = \
274 $(top_builddir)/src/service/testing/libgnunettesting.la \
275 $(top_builddir)/src/lib/util/libgnunetutil.la \
276 $(top_builddir)/src/service/identity/libgnunetidentity.la \
277 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
278 $(top_builddir)/src/service/namecache/libgnunetnamecache.la \
279 libgnunetnamestore.la
280
281test_namestore_api_remove_sqlite_SOURCES = \
282 test_namestore_api_remove.c
283test_namestore_api_remove_sqlite_LDADD = \
284 $(top_builddir)/src/service/identity/libgnunetidentity.la \
285 $(top_builddir)/src/service/testing/libgnunettesting.la \
286 $(top_builddir)/src/lib/util/libgnunetutil.la \
287 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
288 libgnunetnamestore.la
289
290test_namestore_api_remove_postgres_SOURCES = \
291 test_namestore_api_remove.c
292test_namestore_api_remove_postgres_LDADD = \
293 $(top_builddir)/src/service/identity/libgnunetidentity.la \
294 $(top_builddir)/src/service/testing/libgnunettesting.la \
295 $(top_builddir)/src/lib/util/libgnunetutil.la \
296 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
297 libgnunetnamestore.la
298
299test_namestore_api_remove_not_existing_record_sqlite_SOURCES = \
300 test_namestore_api_remove_not_existing_record.c
301test_namestore_api_remove_not_existing_record_sqlite_LDADD = \
302 $(top_builddir)/src/service/testing/libgnunettesting.la \
303 $(top_builddir)/src/lib/util/libgnunetutil.la \
304 $(top_builddir)/src/service/identity/libgnunetidentity.la \
305 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
306 libgnunetnamestore.la
307
308test_namestore_api_remove_not_existing_record_postgres_SOURCES = \
309 test_namestore_api_remove_not_existing_record.c
310test_namestore_api_remove_not_existing_record_postgres_LDADD = \
311 $(top_builddir)/src/service/testing/libgnunettesting.la \
312 $(top_builddir)/src/service/identity/libgnunetidentity.la \
313 $(top_builddir)/src/lib/util/libgnunetutil.la \
314 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
315 libgnunetnamestore.la
316
317test_namestore_api_zone_to_name_sqlite_SOURCES = \
318 test_namestore_api_zone_to_name.c
319test_namestore_api_zone_to_name_sqlite_LDADD = \
320 $(top_builddir)/src/service/identity/libgnunetidentity.la \
321 $(top_builddir)/src/service/testing/libgnunettesting.la \
322 $(top_builddir)/src/lib/util/libgnunetutil.la \
323 libgnunetnamestore.la
324
325test_namestore_api_zone_to_name_postgres_SOURCES = \
326 test_namestore_api_zone_to_name.c
327test_namestore_api_zone_to_name_postgres_LDADD = \
328 $(top_builddir)/src/service/identity/libgnunetidentity.la \
329 $(top_builddir)/src/service/testing/libgnunettesting.la \
330 $(top_builddir)/src/lib/util/libgnunetutil.la \
331 libgnunetnamestore.la
332
333test_namestore_api_monitoring_sqlite_SOURCES = \
334 test_namestore_api_monitoring.c
335test_namestore_api_monitoring_sqlite_LDADD = \
336 $(top_builddir)/src/service/identity/libgnunetidentity.la \
337 $(top_builddir)/src/service/testing/libgnunettesting.la \
338 libgnunetnamestore.la \
339 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
340 $(top_builddir)/src/lib/util/libgnunetutil.la
341
342test_namestore_api_monitoring_postgres_SOURCES = \
343 test_namestore_api_monitoring.c
344test_namestore_api_monitoring_postgres_LDADD = \
345 $(top_builddir)/src/service/testing/libgnunettesting.la \
346 $(top_builddir)/src/service/identity/libgnunetidentity.la \
347 libgnunetnamestore.la \
348 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
349 $(top_builddir)/src/lib/util/libgnunetutil.la
350
351test_namestore_api_monitoring_existing_sqlite_SOURCES = \
352 test_namestore_api_monitoring_existing.c
353test_namestore_api_monitoring_existing_sqlite_LDADD = \
354 $(top_builddir)/src/service/testing/libgnunettesting.la \
355 $(top_builddir)/src/service/identity/libgnunetidentity.la \
356 libgnunetnamestore.la \
357 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
358 $(top_builddir)/src/lib/util/libgnunetutil.la
359
360test_namestore_api_monitoring_existing_postgres_SOURCES = \
361 test_namestore_api_monitoring_existing.c
362test_namestore_api_monitoring_existing_postgres_LDADD = \
363 $(top_builddir)/src/service/testing/libgnunettesting.la \
364 libgnunetnamestore.la \
365 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
366 $(top_builddir)/src/service/identity/libgnunetidentity.la \
367 $(top_builddir)/src/lib/util/libgnunetutil.la
368
369test_namestore_api_tx_rollback_sqlite_SOURCES = \
370 test_namestore_api_tx_rollback.c
371test_namestore_api_tx_rollback_sqlite_LDADD = \
372 $(top_builddir)/src/service/testing/libgnunettesting.la \
373 $(top_builddir)/src/service/identity/libgnunetidentity.la \
374 libgnunetnamestore.la \
375 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
376 $(top_builddir)/src/lib/util/libgnunetutil.la
377
378test_namestore_api_tx_rollback_postgres_SOURCES = \
379 test_namestore_api_tx_rollback.c
380test_namestore_api_tx_rollback_postgres_LDADD = \
381 $(top_builddir)/src/service/testing/libgnunettesting.la \
382 $(top_builddir)/src/service/identity/libgnunetidentity.la \
383 libgnunetnamestore.la \
384 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
385 $(top_builddir)/src/lib/util/libgnunetutil.la
386
387if HAVE_EXPERIMENTAL
388test_namestore_api_edit_records_postgres_SOURCES = \
389 test_namestore_api_edit_records.c
390test_namestore_api_edit_records_postgres_LDADD = \
391 $(top_builddir)/src/service/testing/libgnunettesting.la \
392 $(top_builddir)/src/service/identity/libgnunetidentity.la \
393 libgnunetnamestore.la \
394 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
395 $(top_builddir)/src/lib/util/libgnunetutil.la
396endif
397
398test_namestore_api_zone_iteration_sqlite_SOURCES = \
399 test_namestore_api_zone_iteration.c
400test_namestore_api_zone_iteration_sqlite_LDADD = \
401 $(top_builddir)/src/service/testing/libgnunettesting.la \
402 $(top_builddir)/src/service/identity/libgnunetidentity.la \
403 $(top_builddir)/src/lib/util/libgnunetutil.la \
404 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
405 libgnunetnamestore.la
406
407test_namestore_api_zone_iteration_postgres_SOURCES = \
408 test_namestore_api_zone_iteration.c
409test_namestore_api_zone_iteration_postgres_LDADD = \
410 $(top_builddir)/src/service/testing/libgnunettesting.la \
411 $(top_builddir)/src/service/identity/libgnunetidentity.la \
412 $(top_builddir)/src/lib/util/libgnunetutil.la \
413 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
414 libgnunetnamestore.la
415
416perf_namestore_api_zone_iteration_postgres_SOURCES = \
417 perf_namestore_api_zone_iteration.c
418perf_namestore_api_zone_iteration_postgres_LDADD = \
419 $(top_builddir)/src/service/testing/libgnunettesting.la \
420 $(top_builddir)/src/lib/util/libgnunetutil.la \
421 $(top_builddir)/src/service/identity/libgnunetidentity.la \
422 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
423 libgnunetnamestore.la
424
425perf_namestore_api_import_sqlite_SOURCES = \
426 perf_namestore_api_import.c
427perf_namestore_api_import_sqlite_LDADD = \
428 $(top_builddir)/src/service/testing/libgnunettesting.la \
429 $(top_builddir)/src/lib/util/libgnunetutil.la \
430 $(top_builddir)/src/service/identity/libgnunetidentity.la \
431 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
432 libgnunetnamestore.la
433
434perf_namestore_api_import_postgres_SOURCES = \
435 perf_namestore_api_import.c
436perf_namestore_api_import_postgres_LDADD = \
437 $(top_builddir)/src/service/testing/libgnunettesting.la \
438 $(top_builddir)/src/lib/util/libgnunetutil.la \
439 $(top_builddir)/src/service/identity/libgnunetidentity.la \
440 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
441 libgnunetnamestore.la
442
443
444perf_namestore_api_zone_iteration_sqlite_SOURCES = \
445 perf_namestore_api_zone_iteration.c
446perf_namestore_api_zone_iteration_sqlite_LDADD = \
447 $(top_builddir)/src/service/testing/libgnunettesting.la \
448 $(top_builddir)/src/service/identity/libgnunetidentity.la \
449 $(top_builddir)/src/lib/util/libgnunetutil.la \
450 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
451 libgnunetnamestore.la
452
453test_namestore_api_zone_iteration_nick_sqlite_SOURCES = \
454 test_namestore_api_zone_iteration_nick.c
455test_namestore_api_zone_iteration_nick_sqlite_LDADD = \
456 $(top_builddir)/src/service/testing/libgnunettesting.la \
457 $(top_builddir)/src/service/identity/libgnunetidentity.la \
458 $(top_builddir)/src/lib/util/libgnunetutil.la \
459 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
460 libgnunetnamestore.la
461
462test_namestore_api_zone_iteration_nick_postgres_SOURCES = \
463 test_namestore_api_zone_iteration_nick.c
464test_namestore_api_zone_iteration_nick_postgres_LDADD = \
465 $(top_builddir)/src/service/testing/libgnunettesting.la \
466 $(top_builddir)/src/service/identity/libgnunetidentity.la \
467 $(top_builddir)/src/lib/util/libgnunetutil.la \
468 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
469 libgnunetnamestore.la
470
471test_namestore_api_zone_iteration_specific_zone_sqlite_SOURCES = \
472 test_namestore_api_zone_iteration_specific_zone.c
473test_namestore_api_zone_iteration_specific_zone_sqlite_LDADD = \
474 $(top_builddir)/src/service/testing/libgnunettesting.la \
475 $(top_builddir)/src/service/identity/libgnunetidentity.la \
476 $(top_builddir)/src/lib/util/libgnunetutil.la \
477 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
478 libgnunetnamestore.la
479
480test_namestore_api_zone_iteration_specific_zone_postgres_SOURCES = \
481 test_namestore_api_zone_iteration_specific_zone.c
482test_namestore_api_zone_iteration_specific_zone_postgres_LDADD = \
483 $(top_builddir)/src/service/testing/libgnunettesting.la \
484 $(top_builddir)/src/service/identity/libgnunetidentity.la \
485 $(top_builddir)/src/lib/util/libgnunetutil.la \
486 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
487 libgnunetnamestore.la
488
489test_namestore_api_zone_iteration_stop_sqlite_SOURCES = \
490 test_namestore_api_zone_iteration_stop.c
491test_namestore_api_zone_iteration_stop_sqlite_LDADD = \
492 $(top_builddir)/src/service/testing/libgnunettesting.la \
493 $(top_builddir)/src/service/identity/libgnunetidentity.la \
494 $(top_builddir)/src/lib/util/libgnunetutil.la \
495 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
496 libgnunetnamestore.la
497
498test_namestore_api_zone_iteration_stop_postgres_SOURCES = \
499 test_namestore_api_zone_iteration_stop.c
500test_namestore_api_zone_iteration_stop_postgres_LDADD = \
501 $(top_builddir)/src/service/testing/libgnunettesting.la \
502 $(top_builddir)/src/service/identity/libgnunetidentity.la \
503 $(top_builddir)/src/lib/util/libgnunetutil.la \
504 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
505 libgnunetnamestore.la
506
507test_plugin_namestore_sqlite_SOURCES = \
508 test_plugin_namestore.c
509test_plugin_namestore_sqlite_LDADD = \
510 $(top_builddir)/src/service/testing/libgnunettesting.la \
511 $(top_builddir)/src/service/identity/libgnunetidentity.la \
512 $(top_builddir)/src/lib/util/libgnunetutil.la
513
514test_plugin_namestore_postgres_SOURCES = \
515 test_plugin_namestore.c
516test_plugin_namestore_postgres_LDADD = \
517 $(top_builddir)/src/service/identity/libgnunetidentity.la \
518 $(top_builddir)/src/service/testing/libgnunettesting.la \
519 $(top_builddir)/src/lib/util/libgnunetutil.la
520
521check_SCRIPTS = \
522 test_namestore_put.sh \
523 test_namestore_put_stdin.sh \
524 test_namestore_lookup.sh \
525 test_namestore_delete.sh \
526 test_namestore_zonefile_import.sh
527
528check_SCRIPTS += \
529 test_plugin_rest_namestore.sh
530
531EXTRA_DIST = \
532 test_common.c \
533 test_namestore_api.conf \
534 test_namestore_api_postgres.conf \
535 test_namestore_api_sqlite.conf \
536 perf_namestore_api_postgres.conf \
537 perf_namestore_api_sqlite.conf \
538 test_plugin_namestore_sqlite.conf \
539 test_plugin_namestore_postgres.conf \
540 test_hostkey \
541 example_zonefile \
542 $(check_SCRIPTS) \
543 $(sql_DATA)