aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2022-09-23 12:59:28 +0900
committerMartin Schanzenbach <schanzen@gnunet.org>2022-09-23 12:59:28 +0900
commite238c132f9e9d75437c465d8641b45427c622df5 (patch)
tree2ee821d0f52a8bada8b1d8cdc39a05dbe2c877dc /src/namestore/Makefile.am
parent764871dcbec1f4bbd846d79b8bd34f5b56d435f2 (diff)
downloadgnunet-e238c132f9e9d75437c465d8641b45427c622df5.tar.gz
gnunet-e238c132f9e9d75437c465d8641b45427c622df5.zip
NAMESTORE: Add tx API for postgres
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index 2d2c8ac3c..32f2605ca 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -57,7 +57,8 @@ POSTGRES_TESTS = test_plugin_namestore_postgres \
57 test_namestore_api_zone_iteration_stop_postgres \ 57 test_namestore_api_zone_iteration_stop_postgres \
58 test_namestore_api_monitoring_existing_postgres \ 58 test_namestore_api_monitoring_existing_postgres \
59 test_namestore_api_zone_to_name_postgres \ 59 test_namestore_api_zone_to_name_postgres \
60 perf_namestore_api_zone_iteration_postgres 60 perf_namestore_api_zone_iteration_postgres \
61 test_namestore_api_tx_rollback_postgres
61endif 62endif
62 63
63if HAVE_SQLITE 64if HAVE_SQLITE
@@ -432,6 +433,16 @@ test_namestore_api_tx_rollback_sqlite_LDADD = \
432 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 433 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
433 $(top_builddir)/src/util/libgnunetutil.la 434 $(top_builddir)/src/util/libgnunetutil.la
434 435
436test_namestore_api_tx_rollback_postgres_SOURCES = \
437 test_namestore_api_tx_rollback.c
438test_namestore_api_tx_rollback_postgres_LDADD = \
439 $(top_builddir)/src/testing/libgnunettesting.la \
440 $(top_builddir)/src/identity/libgnunetidentity.la \
441 libgnunetnamestore.la \
442 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
443 $(top_builddir)/src/util/libgnunetutil.la
444
445
435 446
436test_namestore_api_zone_iteration_sqlite_SOURCES = \ 447test_namestore_api_zone_iteration_sqlite_SOURCES = \
437 test_namestore_api_zone_iteration.c 448 test_namestore_api_zone_iteration.c