aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
authorDavid Barksdale <amatus.amongus@gmail.com>2013-06-27 06:11:55 +0000
committerDavid Barksdale <amatus.amongus@gmail.com>2013-06-27 06:11:55 +0000
commitea7eed529e12dcbed6a6775b818d8b93b9505f18 (patch)
tree521ba312e1268d1afb249db03c1b97d5a79181a1 /src/namestore/Makefile.am
parent48e50f64d8c05b2a6dab327156ea86fc92f171cf (diff)
downloadgnunet-ea7eed529e12dcbed6a6775b818d8b93b9505f18.tar.gz
gnunet-ea7eed529e12dcbed6a6775b818d8b93b9505f18.zip
Make building gnunet-testing lib optional.
This is all because emscripten doesn't have getaddrinfo.
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am26
1 files changed, 17 insertions, 9 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index 1d36fe792..df16e04bd 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -21,19 +21,18 @@ endif
21 21
22if HAVE_SQLITE 22if HAVE_SQLITE
23SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la 23SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la
24if HAVE_TESTING
24SQLITE_TESTS = test_plugin_namestore_sqlite 25SQLITE_TESTS = test_plugin_namestore_sqlite
25endif 26endif
27endif
26if HAVE_POSTGRES 28if HAVE_POSTGRES
27POSTGRES_TESTS = test_plugin_namestore_postgres
28POSTGRES_PLUGIN = libgnunet_plugin_namestore_postgres.la 29POSTGRES_PLUGIN = libgnunet_plugin_namestore_postgres.la
30if HAVE_TESTING
31POSTGRES_TESTS = test_plugin_namestore_postgres
29endif 32endif
30 33endif
31if HAVE_SQLITE 34if HAVE_TESTING
32check_PROGRAMS = \ 35TESTING_TESTS = \
33 $(SQLITE_TESTS) \
34 $(POSTGRES_TESTS) \
35 test_namestore_record_serialization \
36 test_namestore_api_sign_verify \
37 test_namestore_api \ 36 test_namestore_api \
38 test_namestore_api_put \ 37 test_namestore_api_put \
39 test_namestore_api_lookup \ 38 test_namestore_api_lookup \
@@ -45,7 +44,16 @@ check_PROGRAMS = \
45 test_namestore_api_zone_to_name \ 44 test_namestore_api_zone_to_name \
46 test_namestore_api_zone_iteration \ 45 test_namestore_api_zone_iteration \
47 test_namestore_api_zone_iteration_specific_zone \ 46 test_namestore_api_zone_iteration_specific_zone \
48 test_namestore_api_zone_iteration_stop 47 test_namestore_api_zone_iteration_stop
48endif
49
50if HAVE_SQLITE
51check_PROGRAMS = \
52 $(SQLITE_TESTS) \
53 $(POSTGRES_TESTS) \
54 $(TESTING_TESTS) \
55 test_namestore_record_serialization \
56 test_namestore_api_sign_verify
49endif 57endif
50 58
51if ENABLE_TEST_RUN 59if ENABLE_TEST_RUN