aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-06-30 19:21:05 +0000
committerChristian Grothoff <christian@grothoff.org>2013-06-30 19:21:05 +0000
commit17de5c9d798109f55059190c886609ba377e4eb6 (patch)
tree07f2b4241f433b18baf02d5bf189307ad2308166 /src/namestore/Makefile.am
parentfd87b25438487e1215c68bdb9f1bcac2d7012bc2 (diff)
downloadgnunet-17de5c9d798109f55059190c886609ba377e4eb6.tar.gz
gnunet-17de5c9d798109f55059190c886609ba377e4eb6.zip
-towards implementing improved namestore API
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index df16e04bd..b920c43c4 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -64,7 +64,10 @@ lib_LTLIBRARIES = \
64 libgnunetnamestore.la 64 libgnunetnamestore.la
65 65
66libgnunetnamestore_la_SOURCES = \ 66libgnunetnamestore_la_SOURCES = \
67 namestore_api.c namestore_common.c namestore.h 67 namestore_api.c \
68 namestore_api_monitor.c \
69 namestore_api_common.c \
70 namestore.h
68libgnunetnamestore_la_LIBADD = \ 71libgnunetnamestore_la_LIBADD = \
69 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 72 $(top_builddir)/src/statistics/libgnunetstatistics.la \
70 $(top_builddir)/src/util/libgnunetutil.la \ 73 $(top_builddir)/src/util/libgnunetutil.la \
@@ -111,7 +114,7 @@ plugin_LTLIBRARIES = \
111 $(POSTGRES_PLUGIN) 114 $(POSTGRES_PLUGIN)
112 115
113libgnunet_plugin_namestore_sqlite_la_SOURCES = \ 116libgnunet_plugin_namestore_sqlite_la_SOURCES = \
114 plugin_namestore_sqlite.c namestore_common.c 117 plugin_namestore_sqlite.c
115libgnunet_plugin_namestore_sqlite_la_LIBADD = \ 118libgnunet_plugin_namestore_sqlite_la_LIBADD = \
116 $(top_builddir)/src/namestore/libgnunetnamestore.la \ 119 $(top_builddir)/src/namestore/libgnunetnamestore.la \
117 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 120 $(top_builddir)/src/statistics/libgnunetstatistics.la \
@@ -126,7 +129,7 @@ libgnunet_plugin_namestore_sqlite_la_DEPENDENCIES = \
126 129
127 130
128libgnunet_plugin_namestore_postgres_la_SOURCES = \ 131libgnunet_plugin_namestore_postgres_la_SOURCES = \
129 plugin_namestore_postgres.c namestore_common.c 132 plugin_namestore_postgres.c
130libgnunet_plugin_namestore_postgres_la_LIBADD = \ 133libgnunet_plugin_namestore_postgres_la_LIBADD = \
131 $(top_builddir)/src/namestore/libgnunetnamestore.la \ 134 $(top_builddir)/src/namestore/libgnunetnamestore.la \
132 $(top_builddir)/src/postgres/libgnunetpostgres.la \ 135 $(top_builddir)/src/postgres/libgnunetpostgres.la \