aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-06-10 13:25:53 +0000
committerChristian Grothoff <christian@grothoff.org>2012-06-10 13:25:53 +0000
commit2f73cafe6ad49fbed8aa3c0991fd3512f5fe3971 (patch)
tree34aa7b9e306e3812e36509f1e227889cb199628e /src/namestore/Makefile.am
parentdbde4bf3121a02a8d2694fcccb0f293dc05eb767 (diff)
downloadgnunet-2f73cafe6ad49fbed8aa3c0991fd3512f5fe3971.tar.gz
gnunet-2f73cafe6ad49fbed8aa3c0991fd3512f5fe3971.zip
-more testcase cleanup
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index fce9838c6..aea857d74 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -112,29 +112,34 @@ test_namestore_api_sign_verify_SOURCES = \
112 test_namestore_api_sign_verify.c 112 test_namestore_api_sign_verify.c
113test_namestore_api_sign_verify_LDADD = \ 113test_namestore_api_sign_verify_LDADD = \
114 $(top_builddir)/src/util/libgnunetutil.la \ 114 $(top_builddir)/src/util/libgnunetutil.la \
115 $(top_builddir)/src/testing/libgnunettesting.la \
115 $(top_builddir)/src/namestore/libgnunetnamestore.la 116 $(top_builddir)/src/namestore/libgnunetnamestore.la
116 117
117test_namestore_api_SOURCES = \ 118test_namestore_api_SOURCES = \
118 test_namestore_api.c 119 test_namestore_api.c
119test_namestore_api_LDADD = \ 120test_namestore_api_LDADD = \
121 $(top_builddir)/src/testing/libgnunettesting.la \
120 $(top_builddir)/src/util/libgnunetutil.la \ 122 $(top_builddir)/src/util/libgnunetutil.la \
121 $(top_builddir)/src/namestore/libgnunetnamestore.la 123 $(top_builddir)/src/namestore/libgnunetnamestore.la
122 124
123test_namestore_api_put_SOURCES = \ 125test_namestore_api_put_SOURCES = \
124 test_namestore_api_put.c 126 test_namestore_api_put.c
125test_namestore_api_put_LDADD = \ 127test_namestore_api_put_LDADD = \
128 $(top_builddir)/src/testing/libgnunettesting.la \
126 $(top_builddir)/src/util/libgnunetutil.la \ 129 $(top_builddir)/src/util/libgnunetutil.la \
127 $(top_builddir)/src/namestore/libgnunetnamestore.la 130 $(top_builddir)/src/namestore/libgnunetnamestore.la
128 131
129test_namestore_api_lookup_SOURCES = \ 132test_namestore_api_lookup_SOURCES = \
130 test_namestore_api_lookup.c 133 test_namestore_api_lookup.c
131test_namestore_api_lookup_LDADD = \ 134test_namestore_api_lookup_LDADD = \
135 $(top_builddir)/src/testing/libgnunettesting.la \
132 $(top_builddir)/src/util/libgnunetutil.la \ 136 $(top_builddir)/src/util/libgnunetutil.la \
133 $(top_builddir)/src/namestore/libgnunetnamestore.la 137 $(top_builddir)/src/namestore/libgnunetnamestore.la
134 138
135test_namestore_api_lookup_specific_type_SOURCES = \ 139test_namestore_api_lookup_specific_type_SOURCES = \
136 test_namestore_api_lookup_specific_type.c 140 test_namestore_api_lookup_specific_type.c
137test_namestore_api_lookup_specific_type_LDADD = \ 141test_namestore_api_lookup_specific_type_LDADD = \
142 $(top_builddir)/src/testing/libgnunettesting.la \
138 $(top_builddir)/src/util/libgnunetutil.la \ 143 $(top_builddir)/src/util/libgnunetutil.la \
139 $(top_builddir)/src/namestore/libgnunetnamestore.la 144 $(top_builddir)/src/namestore/libgnunetnamestore.la
140 145
@@ -142,12 +147,14 @@ test_namestore_api_lookup_specific_type_LDADD = \
142test_namestore_api_create_SOURCES = \ 147test_namestore_api_create_SOURCES = \
143 test_namestore_api_create.c 148 test_namestore_api_create.c
144test_namestore_api_create_LDADD = \ 149test_namestore_api_create_LDADD = \
150 $(top_builddir)/src/testing/libgnunettesting.la \
145 $(top_builddir)/src/util/libgnunetutil.la \ 151 $(top_builddir)/src/util/libgnunetutil.la \
146 $(top_builddir)/src/namestore/libgnunetnamestore.la 152 $(top_builddir)/src/namestore/libgnunetnamestore.la
147 153
148test_namestore_api_create_update_SOURCES = \ 154test_namestore_api_create_update_SOURCES = \
149 test_namestore_api_create_update.c 155 test_namestore_api_create_update.c
150test_namestore_api_create_update_LDADD = \ 156test_namestore_api_create_update_LDADD = \
157 $(top_builddir)/src/testing/libgnunettesting.la \
151 $(top_builddir)/src/util/libgnunetutil.la \ 158 $(top_builddir)/src/util/libgnunetutil.la \
152 $(top_builddir)/src/namestore/libgnunetnamestore.la 159 $(top_builddir)/src/namestore/libgnunetnamestore.la
153 160
@@ -155,42 +162,49 @@ test_namestore_api_create_update_LDADD = \
155test_namestore_api_remove_SOURCES = \ 162test_namestore_api_remove_SOURCES = \
156 test_namestore_api_remove.c 163 test_namestore_api_remove.c
157test_namestore_api_remove_LDADD = \ 164test_namestore_api_remove_LDADD = \
165 $(top_builddir)/src/testing/libgnunettesting.la \
158 $(top_builddir)/src/util/libgnunetutil.la \ 166 $(top_builddir)/src/util/libgnunetutil.la \
159 $(top_builddir)/src/namestore/libgnunetnamestore.la 167 $(top_builddir)/src/namestore/libgnunetnamestore.la
160 168
161test_namestore_api_remove_not_existing_record_SOURCES = \ 169test_namestore_api_remove_not_existing_record_SOURCES = \
162 test_namestore_api_remove_not_existing_record.c 170 test_namestore_api_remove_not_existing_record.c
163test_namestore_api_remove_not_existing_record_LDADD = \ 171test_namestore_api_remove_not_existing_record_LDADD = \
172 $(top_builddir)/src/testing/libgnunettesting.la \
164 $(top_builddir)/src/util/libgnunetutil.la \ 173 $(top_builddir)/src/util/libgnunetutil.la \
165 $(top_builddir)/src/namestore/libgnunetnamestore.la 174 $(top_builddir)/src/namestore/libgnunetnamestore.la
166 175
167test_namestore_api_zone_to_name_SOURCES = \ 176test_namestore_api_zone_to_name_SOURCES = \
168 test_namestore_api_zone_to_name.c 177 test_namestore_api_zone_to_name.c
169test_namestore_api_zone_to_name_LDADD = \ 178test_namestore_api_zone_to_name_LDADD = \
179 $(top_builddir)/src/testing/libgnunettesting.la \
170 $(top_builddir)/src/util/libgnunetutil.la \ 180 $(top_builddir)/src/util/libgnunetutil.la \
171 $(top_builddir)/src/namestore/libgnunetnamestore.la 181 $(top_builddir)/src/namestore/libgnunetnamestore.la
172 182
173test_namestore_api_zone_iteration_SOURCES = \ 183test_namestore_api_zone_iteration_SOURCES = \
174 test_namestore_api_zone_iteration.c 184 test_namestore_api_zone_iteration.c
175test_namestore_api_zone_iteration_LDADD = \ 185test_namestore_api_zone_iteration_LDADD = \
186 $(top_builddir)/src/testing/libgnunettesting.la \
176 $(top_builddir)/src/util/libgnunetutil.la \ 187 $(top_builddir)/src/util/libgnunetutil.la \
177 $(top_builddir)/src/namestore/libgnunetnamestore.la 188 $(top_builddir)/src/namestore/libgnunetnamestore.la
178 189
179test_namestore_api_zone_iteration_specific_zone_SOURCES = \ 190test_namestore_api_zone_iteration_specific_zone_SOURCES = \
180 test_namestore_api_zone_iteration_specific_zone.c 191 test_namestore_api_zone_iteration_specific_zone.c
181test_namestore_api_zone_iteration_specific_zone_LDADD = \ 192test_namestore_api_zone_iteration_specific_zone_LDADD = \
193 $(top_builddir)/src/testing/libgnunettesting.la \
182 $(top_builddir)/src/util/libgnunetutil.la \ 194 $(top_builddir)/src/util/libgnunetutil.la \
183 $(top_builddir)/src/namestore/libgnunetnamestore.la 195 $(top_builddir)/src/namestore/libgnunetnamestore.la
184 196
185test_namestore_api_zone_iteration_stop_SOURCES = \ 197test_namestore_api_zone_iteration_stop_SOURCES = \
186 test_namestore_api_zone_iteration_stop.c 198 test_namestore_api_zone_iteration_stop.c
187test_namestore_api_zone_iteration_stop_LDADD = \ 199test_namestore_api_zone_iteration_stop_LDADD = \
200 $(top_builddir)/src/testing/libgnunettesting.la \
188 $(top_builddir)/src/util/libgnunetutil.la \ 201 $(top_builddir)/src/util/libgnunetutil.la \
189 $(top_builddir)/src/namestore/libgnunetnamestore.la 202 $(top_builddir)/src/namestore/libgnunetnamestore.la
190 203
191test_namestore_record_serialization_SOURCES = \ 204test_namestore_record_serialization_SOURCES = \
192 test_namestore_record_serialization.c 205 test_namestore_record_serialization.c
193test_namestore_record_serialization_LDADD = \ 206test_namestore_record_serialization_LDADD = \
207 $(top_builddir)/src/testing/libgnunettesting.la \
194 $(top_builddir)/src/util/libgnunetutil.la \ 208 $(top_builddir)/src/util/libgnunetutil.la \
195 $(top_builddir)/src/namestore/libgnunetnamestore.la 209 $(top_builddir)/src/namestore/libgnunetnamestore.la
196 210