aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2013-08-21 09:53:53 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2013-08-21 09:53:53 +0000
commit35093e17511203a0924a1c64017e3abd1e72fc91 (patch)
tree25d45962fac712855c10fd3a9ca47ef7268d3fe9 /src/namestore/Makefile.am
parent8414aa3d3a3eb463f3cadda5fb31dfc24c01f53b (diff)
downloadgnunet-35093e17511203a0924a1c64017e3abd1e72fc91.tar.gz
gnunet-35093e17511203a0924a1c64017e3abd1e72fc91.zip
reorder tests: namestore_common -> plugins -> api
block test
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am37
1 files changed, 18 insertions, 19 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index 2413005ab..8a5fa70a6 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -41,28 +41,27 @@ if HAVE_EXPERIMENTAL
41 41
42if HAVE_TESTING 42if HAVE_TESTING
43TESTING_TESTS = \ 43TESTING_TESTS = \
44 test_namestore_api \ 44 test_namestore_api
45 test_namestore_api_put \ 45 #test_namestore_api_lookup \
46 test_namestore_api_lookup \ 46 #test_namestore_api_lookup_specific_type \
47 test_namestore_api_lookup_specific_type \ 47 #test_namestore_api_create \
48 test_namestore_api_create \ 48 #test_namestore_api_create_update \
49 test_namestore_api_create_update \ 49 #test_namestore_api_remove \
50 test_namestore_api_remove \ 50 #test_namestore_api_remove_not_existing_record \
51 test_namestore_api_remove_not_existing_record \ 51 #test_namestore_api_zone_to_name \
52 test_namestore_api_zone_to_name \ 52 #test_namestore_api_monitoring \
53 test_namestore_api_monitoring \ 53 #test_namestore_api_zone_iteration \
54 test_namestore_api_zone_iteration \ 54 #test_namestore_api_zone_iteration_specific_zone \
55 test_namestore_api_zone_iteration_specific_zone \ 55 #test_namestore_api_zone_iteration_stop
56 test_namestore_api_zone_iteration_stop
57endif 56endif
58 57
59if HAVE_SQLITE 58if HAVE_SQLITE
60check_PROGRAMS = \ 59check_PROGRAMS = \
60 test_namestore_record_serialization \
61 test_namestore_api_blocks \
61 $(SQLITE_TESTS) \ 62 $(SQLITE_TESTS) \
62 $(POSTGRES_TESTS) \ 63 $(POSTGRES_TESTS) \
63 $(TESTING_TESTS) \ 64 $(TESTING_TESTS)
64 test_namestore_record_serialization \
65 test_namestore_api_sign_verify
66endif 65endif
67 66
68# end of 'HAVE_EXPERIMENTAL' for testcases 67# end of 'HAVE_EXPERIMENTAL' for testcases
@@ -173,9 +172,9 @@ libgnunet_plugin_namestore_postgres_la_DEPENDENCIES = \
173 $(top_builddir)/src/util/libgnunetutil.la \ 172 $(top_builddir)/src/util/libgnunetutil.la \
174 libgnunetnamestore.la 173 libgnunetnamestore.la
175 174
176test_namestore_api_sign_verify_SOURCES = \ 175test_namestore_api_blocks_SOURCES = \
177 test_namestore_api_sign_verify.c 176 test_namestore_api_blocks.c
178test_namestore_api_sign_verify_LDADD = \ 177test_namestore_api_blocks_LDADD = \
179 $(top_builddir)/src/util/libgnunetutil.la \ 178 $(top_builddir)/src/util/libgnunetutil.la \
180 $(top_builddir)/src/testing/libgnunettesting.la \ 179 $(top_builddir)/src/testing/libgnunettesting.la \
181 $(top_builddir)/src/namestore/libgnunetnamestore.la 180 $(top_builddir)/src/namestore/libgnunetnamestore.la