aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-06-11 21:02:30 +0000
committerChristian Grothoff <christian@grothoff.org>2012-06-11 21:02:30 +0000
commit589448a17afcc95ef157678d4e1b2eba0f0c9d7a (patch)
treed9e6c3802d6203680b7b956a60aa0c19dc50a9ff /src/namestore/Makefile.am
parentd63b9b5f38df2300777e7983af7b0ae210fce626 (diff)
downloadgnunet-589448a17afcc95ef157678d4e1b2eba0f0c9d7a.tar.gz
gnunet-589448a17afcc95ef157678d4e1b2eba0f0c9d7a.zip
-first draft of postgres namestore plugin (#2157)
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am34
1 files changed, 28 insertions, 6 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index aea857d74..2106ccf76 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -18,13 +18,18 @@ if USE_COVERAGE
18endif 18endif
19 19
20if HAVE_SQLITE 20if HAVE_SQLITE
21SQLITE_TESTS = \ 21SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la
22 test_plugin_namestore_sqlite 22SQLITE_TESTS = test_plugin_namestore_sqlite
23endif
24if HAVE_POSTGRES
25POSTGRES_TESTS = test_plugin_namestore_postgres
26POSTGRES_PLUGIN = libgnunet_plugin_namestore_postgres.la
23endif 27endif
24 28
25 29
26check_PROGRAMS = \ 30check_PROGRAMS = \
27 $(SQLITE_TESTS) \ 31 $(SQLITE_TESTS) \
32 $(POSTGRES_TESTS) \
28 test_namestore_record_serialization \ 33 test_namestore_record_serialization \
29 test_namestore_api_sign_verify \ 34 test_namestore_api_sign_verify \
30 test_namestore_api \ 35 test_namestore_api \
@@ -87,12 +92,10 @@ gnunet_service_namestore_DEPENDENCIES = \
87 $(top_builddir)/src/util/libgnunetutil.la \ 92 $(top_builddir)/src/util/libgnunetutil.la \
88 libgnunetnamestore.la 93 libgnunetnamestore.la
89 94
90if HAVE_SQLITE
91 SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la
92endif
93 95
94plugin_LTLIBRARIES = \ 96plugin_LTLIBRARIES = \
95 $(SQLITE_PLUGIN) 97 $(SQLITE_PLUGIN) \
98 $(POSTGRES_PLUGIN)
96 99
97libgnunet_plugin_namestore_sqlite_la_SOURCES = \ 100libgnunet_plugin_namestore_sqlite_la_SOURCES = \
98 plugin_namestore_sqlite.c namestore_common.c 101 plugin_namestore_sqlite.c namestore_common.c
@@ -104,6 +107,25 @@ libgnunet_plugin_namestore_sqlite_la_LIBADD = \
104libgnunet_plugin_namestore_sqlite_la_LDFLAGS = \ 107libgnunet_plugin_namestore_sqlite_la_LDFLAGS = \
105 $(GN_PLUGIN_LDFLAGS) 108 $(GN_PLUGIN_LDFLAGS)
106libgnunet_plugin_namestore_sqlite_la_DEPENDENCIES = \ 109libgnunet_plugin_namestore_sqlite_la_DEPENDENCIES = \
110 $(top_builddir)/src/namestore/libgnunetnamestore.la \
111 $(top_builddir)/src/statistics/libgnunetstatistics.la \
112 $(top_builddir)/src/util/libgnunetutil.la \
113 libgnunetnamestore.la
114
115
116libgnunet_plugin_namestore_postgres_la_SOURCES = \
117 plugin_namestore_postgres.c namestore_common.c
118libgnunet_plugin_namestore_postgres_la_LIBADD = \
119 $(top_builddir)/src/namestore/libgnunetnamestore.la \
120 $(top_builddir)/src/postgres/libgnunetpostgres.la \
121 $(top_builddir)/src/statistics/libgnunetstatistics.la \
122 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lpq \
123 $(LTLIBINTL)
124libgnunet_plugin_namestore_postgres_la_LDFLAGS = \
125 $(GN_PLUGIN_LDFLAGS)
126libgnunet_plugin_namestore_postgres_la_DEPENDENCIES = \
127 $(top_builddir)/src/namestore/libgnunetnamestore.la \
128 $(top_builddir)/src/postgres/libgnunetpostgres.la \
107 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 129 $(top_builddir)/src/statistics/libgnunetstatistics.la \
108 $(top_builddir)/src/util/libgnunetutil.la \ 130 $(top_builddir)/src/util/libgnunetutil.la \
109 libgnunetnamestore.la 131 libgnunetnamestore.la