aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2013-11-04 14:32:05 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2013-11-04 14:32:05 +0000
commit60e24213901d8b7948067e7100706d1efdac28b6 (patch)
tree3d1b0a3b5594d3aad51cb27dc0fa47800ebca734 /src/namestore/Makefile.am
parent26593ac2b9aaaae80b86fb07a64289fde1de8410 (diff)
downloadgnunet-60e24213901d8b7948067e7100706d1efdac28b6.tar.gz
gnunet-60e24213901d8b7948067e7100706d1efdac28b6.zip
new test to lookup shadow record
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index bd0754fc3..45d51a0b5 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -41,6 +41,7 @@ TESTING_TESTS = \
41 test_namestore_api_store_update \ 41 test_namestore_api_store_update \
42 test_namestore_api_lookup_public \ 42 test_namestore_api_lookup_public \
43 test_namestore_api_lookup_private \ 43 test_namestore_api_lookup_private \
44 test_namestore_api_lookup_shadow \
44 test_namestore_api_remove \ 45 test_namestore_api_remove \
45 test_namestore_api_remove_not_existing_record \ 46 test_namestore_api_remove_not_existing_record \
46 test_namestore_api_zone_iteration \ 47 test_namestore_api_zone_iteration \
@@ -206,6 +207,15 @@ test_namestore_api_lookup_private_LDADD = \
206 $(top_builddir)/src/namecache/libgnunetnamecache.la \ 207 $(top_builddir)/src/namecache/libgnunetnamecache.la \
207 $(top_builddir)/src/namestore/libgnunetnamestore.la 208 $(top_builddir)/src/namestore/libgnunetnamestore.la
208 209
210test_namestore_api_lookup_shadow_SOURCES = \
211 test_namestore_api_lookup_shadow.c
212test_namestore_api_lookup_shadow_LDADD = \
213 $(top_builddir)/src/testing/libgnunettesting.la \
214 $(top_builddir)/src/util/libgnunetutil.la \
215 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
216 $(top_builddir)/src/namecache/libgnunetnamecache.la \
217 $(top_builddir)/src/namestore/libgnunetnamestore.la
218
209test_namestore_api_put_SOURCES = \ 219test_namestore_api_put_SOURCES = \
210 test_namestore_api_put.c 220 test_namestore_api_put.c
211test_namestore_api_put_LDADD = \ 221test_namestore_api_put_LDADD = \