aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2013-11-04 16:27:48 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2013-11-04 16:27:48 +0000
commita5328c2a96b9582585511c1ce1aee08509eb0c0a (patch)
treeec56747e03a362c9efd857a7123714c993a64aac /src/namestore/Makefile.am
parent90d532b2a3770ba8e34135484d303c6f53dbb820 (diff)
downloadgnunet-a5328c2a96b9582585511c1ce1aee08509eb0c0a.tar.gz
gnunet-a5328c2a96b9582585511c1ce1aee08509eb0c0a.zip
minor fixes + test for shadows record filtering and usage
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index 45d51a0b5..7656e646c 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -42,6 +42,7 @@ TESTING_TESTS = \
42 test_namestore_api_lookup_public \ 42 test_namestore_api_lookup_public \
43 test_namestore_api_lookup_private \ 43 test_namestore_api_lookup_private \
44 test_namestore_api_lookup_shadow \ 44 test_namestore_api_lookup_shadow \
45 test_namestore_api_lookup_shadow_filter \
45 test_namestore_api_remove \ 46 test_namestore_api_remove \
46 test_namestore_api_remove_not_existing_record \ 47 test_namestore_api_remove_not_existing_record \
47 test_namestore_api_zone_iteration \ 48 test_namestore_api_zone_iteration \
@@ -216,6 +217,15 @@ test_namestore_api_lookup_shadow_LDADD = \
216 $(top_builddir)/src/namecache/libgnunetnamecache.la \ 217 $(top_builddir)/src/namecache/libgnunetnamecache.la \
217 $(top_builddir)/src/namestore/libgnunetnamestore.la 218 $(top_builddir)/src/namestore/libgnunetnamestore.la
218 219
220test_namestore_api_lookup_shadow_filter_SOURCES = \
221 test_namestore_api_lookup_shadow_filter.c
222test_namestore_api_lookup_shadow_filter_LDADD = \
223 $(top_builddir)/src/testing/libgnunettesting.la \
224 $(top_builddir)/src/util/libgnunetutil.la \
225 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
226 $(top_builddir)/src/namecache/libgnunetnamecache.la \
227 $(top_builddir)/src/namestore/libgnunetnamestore.la
228
219test_namestore_api_put_SOURCES = \ 229test_namestore_api_put_SOURCES = \
220 test_namestore_api_put.c 230 test_namestore_api_put.c
221test_namestore_api_put_LDADD = \ 231test_namestore_api_put_LDADD = \