aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <mschanzenbach@posteo.de>2015-09-11 15:56:39 +0000
committerMartin Schanzenbach <mschanzenbach@posteo.de>2015-09-11 15:56:39 +0000
commitc8aace43c41d50e03bd28b6e696b33c1da8b6c4c (patch)
tree375181e89bd4f099e0a2039ed0962bf7cfd48131 /src/namestore/Makefile.am
parenta12f20bd4c621a7b5e88ca52830ad1bb74a8e2d8 (diff)
downloadgnunet-c8aace43c41d50e03bd28b6e696b33c1da8b6c4c.tar.gz
gnunet-c8aace43c41d50e03bd28b6e696b33c1da8b6c4c.zip
- move rest plugins into rest directory where they belong
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am18
1 files changed, 1 insertions, 17 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index 221e88a91..8ebcac0a1 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -106,21 +106,6 @@ libexec_PROGRAMS += \
106 gnunet-namestore-fcfsd 106 gnunet-namestore-fcfsd
107endif 107endif
108 108
109if HAVE_REST
110REST_PLUGIN = libgnunet_plugin_rest_namestore.la
111endif
112
113libgnunet_plugin_rest_namestore_la_SOURCES = \
114 plugin_rest_namestore.c
115libgnunet_plugin_rest_namestore_la_LIBADD = \
116 $(top_builddir)/src/namestore/libgnunetnamestore.la \
117 $(top_builddir)/src/identity/libgnunetidentity.la \
118 $(top_builddir)/src/rest/libgnunetrest.la \
119 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
120 $(LTLIBINTL) -ljansson -lmicrohttpd
121libgnunet_plugin_rest_namestore_la_LDFLAGS = \
122 $(GN_PLUGIN_LDFLAGS)
123
124 109
125gnunet_namestore_SOURCES = \ 110gnunet_namestore_SOURCES = \
126 gnunet-namestore.c 111 gnunet-namestore.c
@@ -158,8 +143,7 @@ gnunet_service_namestore_LDADD = \
158plugin_LTLIBRARIES = \ 143plugin_LTLIBRARIES = \
159 $(SQLITE_PLUGIN) \ 144 $(SQLITE_PLUGIN) \
160 $(POSTGRES_PLUGIN) \ 145 $(POSTGRES_PLUGIN) \
161 $(FLAT_PLUGIN) \ 146 $(FLAT_PLUGIN)
162 $(REST_PLUGIN)
163 147
164libgnunet_plugin_namestore_flat_la_SOURCES = \ 148libgnunet_plugin_namestore_flat_la_SOURCES = \
165 plugin_namestore_flat.c 149 plugin_namestore_flat.c