aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-10-16 20:14:02 +0000
committerChristian Grothoff <christian@grothoff.org>2013-10-16 20:14:02 +0000
commit3d670727232e79b7e49a1df7ba9260db4e5798a0 (patch)
tree093f7b5aec28134dc6c5fe34cd2d8bfb1e1445ad /src/namestore/Makefile.am
parent2de26776993a5e591e487321a5dc1d62b86d9cd4 (diff)
downloadgnunet-3d670727232e79b7e49a1df7ba9260db4e5798a0.tar.gz
gnunet-3d670727232e79b7e49a1df7ba9260db4e5798a0.zip
-moving namestore_common functions to gnsrecord library
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am30
1 files changed, 13 insertions, 17 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index 1c9b297ae..11e23a790 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -53,8 +53,6 @@ endif
53 53
54if HAVE_SQLITE 54if HAVE_SQLITE
55check_PROGRAMS = \ 55check_PROGRAMS = \
56 test_namestore_record_serialization \
57 test_namestore_api_blocks \
58 $(SQLITE_TESTS) \ 56 $(SQLITE_TESTS) \
59 $(POSTGRES_TESTS) \ 57 $(POSTGRES_TESTS) \
60 $(TESTING_TESTS) 58 $(TESTING_TESTS)
@@ -72,7 +70,6 @@ lib_LTLIBRARIES = \
72libgnunetnamestore_la_SOURCES = \ 70libgnunetnamestore_la_SOURCES = \
73 namestore_api.c \ 71 namestore_api.c \
74 namestore_api_monitor.c \ 72 namestore_api_monitor.c \
75 namestore_api_common.c \
76 namestore.h 73 namestore.h
77libgnunetnamestore_la_LIBADD = \ 74libgnunetnamestore_la_LIBADD = \
78 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 75 $(top_builddir)/src/statistics/libgnunetstatistics.la \
@@ -126,6 +123,7 @@ gnunet_service_namestore_SOURCES = \
126 gnunet-service-namestore.c 123 gnunet-service-namestore.c
127 124
128gnunet_service_namestore_LDADD = \ 125gnunet_service_namestore_LDADD = \
126 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
129 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 127 $(top_builddir)/src/statistics/libgnunetstatistics.la \
130 $(top_builddir)/src/util/libgnunetutil.la \ 128 $(top_builddir)/src/util/libgnunetutil.la \
131 libgnunetnamestore.la \ 129 libgnunetnamestore.la \
@@ -171,18 +169,12 @@ libgnunet_plugin_namestore_postgres_la_DEPENDENCIES = \
171 $(top_builddir)/src/util/libgnunetutil.la \ 169 $(top_builddir)/src/util/libgnunetutil.la \
172 libgnunetnamestore.la 170 libgnunetnamestore.la
173 171
174test_namestore_api_blocks_SOURCES = \
175 test_namestore_api_blocks.c
176test_namestore_api_blocks_LDADD = \
177 $(top_builddir)/src/util/libgnunetutil.la \
178 $(top_builddir)/src/testing/libgnunettesting.la \
179 $(top_builddir)/src/namestore/libgnunetnamestore.la
180
181test_namestore_api_store_SOURCES = \ 172test_namestore_api_store_SOURCES = \
182 test_namestore_api_store.c 173 test_namestore_api_store.c
183test_namestore_api_store_LDADD = \ 174test_namestore_api_store_LDADD = \
184 $(top_builddir)/src/testing/libgnunettesting.la \ 175 $(top_builddir)/src/testing/libgnunettesting.la \
185 $(top_builddir)/src/util/libgnunetutil.la \ 176 $(top_builddir)/src/util/libgnunetutil.la \
177 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
186 $(top_builddir)/src/namestore/libgnunetnamestore.la 178 $(top_builddir)/src/namestore/libgnunetnamestore.la
187 179
188test_namestore_api_store_update_SOURCES = \ 180test_namestore_api_store_update_SOURCES = \
@@ -190,6 +182,7 @@ test_namestore_api_store_update_SOURCES = \
190test_namestore_api_store_update_LDADD = \ 182test_namestore_api_store_update_LDADD = \
191 $(top_builddir)/src/testing/libgnunettesting.la \ 183 $(top_builddir)/src/testing/libgnunettesting.la \
192 $(top_builddir)/src/util/libgnunetutil.la \ 184 $(top_builddir)/src/util/libgnunetutil.la \
185 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
193 $(top_builddir)/src/namestore/libgnunetnamestore.la 186 $(top_builddir)/src/namestore/libgnunetnamestore.la
194 187
195test_namestore_api_cache_block_SOURCES = \ 188test_namestore_api_cache_block_SOURCES = \
@@ -197,6 +190,7 @@ test_namestore_api_cache_block_SOURCES = \
197test_namestore_api_cache_block_LDADD = \ 190test_namestore_api_cache_block_LDADD = \
198 $(top_builddir)/src/testing/libgnunettesting.la \ 191 $(top_builddir)/src/testing/libgnunettesting.la \
199 $(top_builddir)/src/util/libgnunetutil.la \ 192 $(top_builddir)/src/util/libgnunetutil.la \
193 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
200 $(top_builddir)/src/namestore/libgnunetnamestore.la 194 $(top_builddir)/src/namestore/libgnunetnamestore.la
201 195
202test_namestore_api_lookup_public_SOURCES = \ 196test_namestore_api_lookup_public_SOURCES = \
@@ -204,6 +198,7 @@ test_namestore_api_lookup_public_SOURCES = \
204test_namestore_api_lookup_public_LDADD = \ 198test_namestore_api_lookup_public_LDADD = \
205 $(top_builddir)/src/testing/libgnunettesting.la \ 199 $(top_builddir)/src/testing/libgnunettesting.la \
206 $(top_builddir)/src/util/libgnunetutil.la \ 200 $(top_builddir)/src/util/libgnunetutil.la \
201 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
207 $(top_builddir)/src/namestore/libgnunetnamestore.la 202 $(top_builddir)/src/namestore/libgnunetnamestore.la
208 203
209test_namestore_api_put_SOURCES = \ 204test_namestore_api_put_SOURCES = \
@@ -211,6 +206,7 @@ test_namestore_api_put_SOURCES = \
211test_namestore_api_put_LDADD = \ 206test_namestore_api_put_LDADD = \
212 $(top_builddir)/src/testing/libgnunettesting.la \ 207 $(top_builddir)/src/testing/libgnunettesting.la \
213 $(top_builddir)/src/util/libgnunetutil.la \ 208 $(top_builddir)/src/util/libgnunetutil.la \
209 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
214 $(top_builddir)/src/namestore/libgnunetnamestore.la 210 $(top_builddir)/src/namestore/libgnunetnamestore.la
215 211
216test_namestore_api_remove_SOURCES = \ 212test_namestore_api_remove_SOURCES = \
@@ -218,6 +214,7 @@ test_namestore_api_remove_SOURCES = \
218test_namestore_api_remove_LDADD = \ 214test_namestore_api_remove_LDADD = \
219 $(top_builddir)/src/testing/libgnunettesting.la \ 215 $(top_builddir)/src/testing/libgnunettesting.la \
220 $(top_builddir)/src/util/libgnunetutil.la \ 216 $(top_builddir)/src/util/libgnunetutil.la \
217 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
221 $(top_builddir)/src/namestore/libgnunetnamestore.la 218 $(top_builddir)/src/namestore/libgnunetnamestore.la
222 219
223test_namestore_api_remove_not_existing_record_SOURCES = \ 220test_namestore_api_remove_not_existing_record_SOURCES = \
@@ -225,6 +222,7 @@ test_namestore_api_remove_not_existing_record_SOURCES = \
225test_namestore_api_remove_not_existing_record_LDADD = \ 222test_namestore_api_remove_not_existing_record_LDADD = \
226 $(top_builddir)/src/testing/libgnunettesting.la \ 223 $(top_builddir)/src/testing/libgnunettesting.la \
227 $(top_builddir)/src/util/libgnunetutil.la \ 224 $(top_builddir)/src/util/libgnunetutil.la \
225 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
228 $(top_builddir)/src/namestore/libgnunetnamestore.la 226 $(top_builddir)/src/namestore/libgnunetnamestore.la
229 227
230test_namestore_api_zone_to_name_SOURCES = \ 228test_namestore_api_zone_to_name_SOURCES = \
@@ -239,6 +237,7 @@ test_namestore_api_monitoring_SOURCES = \
239test_namestore_api_monitoring_LDADD = \ 237test_namestore_api_monitoring_LDADD = \
240 $(top_builddir)/src/testing/libgnunettesting.la \ 238 $(top_builddir)/src/testing/libgnunettesting.la \
241 $(top_builddir)/src/namestore/libgnunetnamestore.la \ 239 $(top_builddir)/src/namestore/libgnunetnamestore.la \
240 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
242 $(top_builddir)/src/util/libgnunetutil.la 241 $(top_builddir)/src/util/libgnunetutil.la
243 242
244test_namestore_api_monitoring_existing_SOURCES = \ 243test_namestore_api_monitoring_existing_SOURCES = \
@@ -246,6 +245,7 @@ test_namestore_api_monitoring_existing_SOURCES = \
246test_namestore_api_monitoring_existing_LDADD = \ 245test_namestore_api_monitoring_existing_LDADD = \
247 $(top_builddir)/src/testing/libgnunettesting.la \ 246 $(top_builddir)/src/testing/libgnunettesting.la \
248 $(top_builddir)/src/namestore/libgnunetnamestore.la \ 247 $(top_builddir)/src/namestore/libgnunetnamestore.la \
248 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
249 $(top_builddir)/src/util/libgnunetutil.la 249 $(top_builddir)/src/util/libgnunetutil.la
250 250
251test_namestore_api_zone_iteration_SOURCES = \ 251test_namestore_api_zone_iteration_SOURCES = \
@@ -253,6 +253,7 @@ test_namestore_api_zone_iteration_SOURCES = \
253test_namestore_api_zone_iteration_LDADD = \ 253test_namestore_api_zone_iteration_LDADD = \
254 $(top_builddir)/src/testing/libgnunettesting.la \ 254 $(top_builddir)/src/testing/libgnunettesting.la \
255 $(top_builddir)/src/util/libgnunetutil.la \ 255 $(top_builddir)/src/util/libgnunetutil.la \
256 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
256 $(top_builddir)/src/namestore/libgnunetnamestore.la 257 $(top_builddir)/src/namestore/libgnunetnamestore.la
257 258
258test_namestore_api_zone_iteration_specific_zone_SOURCES = \ 259test_namestore_api_zone_iteration_specific_zone_SOURCES = \
@@ -260,6 +261,7 @@ test_namestore_api_zone_iteration_specific_zone_SOURCES = \
260test_namestore_api_zone_iteration_specific_zone_LDADD = \ 261test_namestore_api_zone_iteration_specific_zone_LDADD = \
261 $(top_builddir)/src/testing/libgnunettesting.la \ 262 $(top_builddir)/src/testing/libgnunettesting.la \
262 $(top_builddir)/src/util/libgnunetutil.la \ 263 $(top_builddir)/src/util/libgnunetutil.la \
264 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
263 $(top_builddir)/src/namestore/libgnunetnamestore.la 265 $(top_builddir)/src/namestore/libgnunetnamestore.la
264 266
265test_namestore_api_zone_iteration_stop_SOURCES = \ 267test_namestore_api_zone_iteration_stop_SOURCES = \
@@ -267,13 +269,7 @@ test_namestore_api_zone_iteration_stop_SOURCES = \
267test_namestore_api_zone_iteration_stop_LDADD = \ 269test_namestore_api_zone_iteration_stop_LDADD = \
268 $(top_builddir)/src/testing/libgnunettesting.la \ 270 $(top_builddir)/src/testing/libgnunettesting.la \
269 $(top_builddir)/src/util/libgnunetutil.la \ 271 $(top_builddir)/src/util/libgnunetutil.la \
270 $(top_builddir)/src/namestore/libgnunetnamestore.la 272 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
271
272test_namestore_record_serialization_SOURCES = \
273 test_namestore_record_serialization.c
274test_namestore_record_serialization_LDADD = \
275 $(top_builddir)/src/testing/libgnunettesting.la \
276 $(top_builddir)/src/util/libgnunetutil.la \
277 $(top_builddir)/src/namestore/libgnunetnamestore.la 273 $(top_builddir)/src/namestore/libgnunetnamestore.la
278 274
279test_plugin_namestore_sqlite_SOURCES = \ 275test_plugin_namestore_sqlite_SOURCES = \