aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <mschanzenbach@posteo.de>2015-04-01 14:02:35 +0000
committerMartin Schanzenbach <mschanzenbach@posteo.de>2015-04-01 14:02:35 +0000
commit7f2c9fde223cf7734fec8cdfb913b16579af41a3 (patch)
tree6fedf4aa5a856bf51eeaba2128f368756daf1214 /src/namestore/Makefile.am
parent0be69c24d931816c063e89409ff09a605afbcbad (diff)
downloadgnunet-7f2c9fde223cf7734fec8cdfb913b16579af41a3.tar.gz
gnunet-7f2c9fde223cf7734fec8cdfb913b16579af41a3.zip
- namestore rest
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index 98043373d..2f8c81425 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -98,6 +98,22 @@ libexec_PROGRAMS += \
98 gnunet-namestore-fcfsd 98 gnunet-namestore-fcfsd
99endif 99endif
100 100
101if HAVE_REST
102REST_PLUGIN = libgnunet_plugin_rest_namestore.la
103endif
104
105libgnunet_plugin_rest_namestore_la_SOURCES = \
106 plugin_rest_namestore.c
107libgnunet_plugin_rest_namestore_la_LIBADD = \
108 $(top_builddir)/src/namestore/libgnunetnamestore.la \
109 $(top_builddir)/src/identity/libgnunetidentity.la \
110 $(top_builddir)/src/rest/libgnunetrest.la \
111 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
112 $(LTLIBINTL) -ljansson -lmicrohttpd
113libgnunet_plugin_rest_namestore_la_LDFLAGS = \
114 $(GN_PLUGIN_LDFLAGS)
115
116
101gnunet_namestore_SOURCES = \ 117gnunet_namestore_SOURCES = \
102 gnunet-namestore.c 118 gnunet-namestore.c
103gnunet_namestore_LDADD = \ 119gnunet_namestore_LDADD = \
@@ -133,7 +149,8 @@ gnunet_service_namestore_LDADD = \
133 149
134plugin_LTLIBRARIES = \ 150plugin_LTLIBRARIES = \
135 $(SQLITE_PLUGIN) \ 151 $(SQLITE_PLUGIN) \
136 $(POSTGRES_PLUGIN) 152 $(POSTGRES_PLUGIN) \
153 $(REST_PLUGIN)
137 154
138libgnunet_plugin_namestore_sqlite_la_SOURCES = \ 155libgnunet_plugin_namestore_sqlite_la_SOURCES = \
139 plugin_namestore_sqlite.c 156 plugin_namestore_sqlite.c