aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2018-05-01 12:44:39 +0200
committerChristian Grothoff <christian@grothoff.org>2018-05-01 12:44:39 +0200
commita5e3e870f27c8ef3a3cd5d59a686a3050f9c64fb (patch)
tree6eec8a07a9a932d3c7b36f196ad01428e4f0ed63 /src/namestore/Makefile.am
parent8f2f5bc2ee8ebf9b059b7b7e3104f25c5c363458 (diff)
downloadgnunet-a5e3e870f27c8ef3a3cd5d59a686a3050f9c64fb.tar.gz
gnunet-a5e3e870f27c8ef3a3cd5d59a686a3050f9c64fb.zip
more extensive namestore tests for the non-sqlite plugins, with bugfixes
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am420
1 files changed, 348 insertions, 72 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index b925261b7..b1faae862 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -23,6 +23,22 @@ endif
23FLAT_PLUGIN = libgnunet_plugin_namestore_flat.la 23FLAT_PLUGIN = libgnunet_plugin_namestore_flat.la
24if HAVE_TESTING 24if HAVE_TESTING
25FLAT_TESTS = test_plugin_namestore_flat \ 25FLAT_TESTS = test_plugin_namestore_flat \
26 test_namestore_api_store_flat \
27 test_namestore_api_store_update_flat \
28 test_namestore_api_remove_flat \
29 test_namestore_api_zone_iteration_flat \
30 test_namestore_api_lookup_nick_flat \
31 test_namestore_api_monitoring_flat \
32 test_namestore_api_lookup_public_flat \
33 test_namestore_api_lookup_private_flat \
34 test_namestore_api_lookup_shadow_flat \
35 test_namestore_api_lookup_shadow_filter_flat \
36 test_namestore_api_remove_not_existing_record_flat \
37 test_namestore_api_zone_iteration_nick_flat \
38 test_namestore_api_zone_iteration_specific_zone_flat \
39 test_namestore_api_zone_iteration_stop_flat \
40 test_namestore_api_monitoring_existing_flat \
41 test_namestore_api_zone_to_name_flat \
26 perf_namestore_api_zone_iteration_flat 42 perf_namestore_api_zone_iteration_flat
27endif 43endif
28 44
@@ -30,6 +46,22 @@ if HAVE_SQLITE
30SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la 46SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la
31if HAVE_TESTING 47if HAVE_TESTING
32SQLITE_TESTS = test_plugin_namestore_sqlite \ 48SQLITE_TESTS = test_plugin_namestore_sqlite \
49 test_namestore_api_store_sqlite \
50 test_namestore_api_store_update_sqlite \
51 test_namestore_api_zone_iteration_sqlite \
52 test_namestore_api_remove_sqlite \
53 test_namestore_api_lookup_nick_sqlite \
54 test_namestore_api_monitoring_sqlite \
55 test_namestore_api_lookup_public_sqlite \
56 test_namestore_api_lookup_private_sqlite \
57 test_namestore_api_lookup_shadow_sqlite \
58 test_namestore_api_lookup_shadow_filter_sqlite \
59 test_namestore_api_remove_not_existing_record_sqlite \
60 test_namestore_api_zone_iteration_nick_sqlite \
61 test_namestore_api_zone_iteration_specific_zone_sqlite \
62 test_namestore_api_zone_iteration_stop_sqlite \
63 test_namestore_api_monitoring_existing_sqlite \
64 test_namestore_api_zone_to_name_sqlite \
33 perf_namestore_api_zone_iteration_sqlite 65 perf_namestore_api_zone_iteration_sqlite
34endif 66endif
35endif 67endif
@@ -38,54 +70,31 @@ if HAVE_POSTGRESQL
38POSTGRES_PLUGIN = libgnunet_plugin_namestore_postgres.la 70POSTGRES_PLUGIN = libgnunet_plugin_namestore_postgres.la
39if HAVE_TESTING 71if HAVE_TESTING
40POSTGRES_TESTS = test_plugin_namestore_postgres \ 72POSTGRES_TESTS = test_plugin_namestore_postgres \
73 test_namestore_api_store_postgres \
74 test_namestore_api_store_update_postgres \
75 test_namestore_api_remove_postgres \
76 test_namestore_api_zone_iteration_postgres \
77 test_namestore_api_lookup_nick_postgres \
78 test_namestore_api_monitoring_postgres \
79 test_namestore_api_lookup_public_postgres \
80 test_namestore_api_lookup_private_postgres \
81 test_namestore_api_lookup_shadow_postgres \
82 test_namestore_api_lookup_shadow_filter_postgres \
83 test_namestore_api_remove_not_existing_record_postgres \
84 test_namestore_api_zone_iteration_nick_postgres \
85 test_namestore_api_zone_iteration_specific_zone_postgres \
86 test_namestore_api_zone_iteration_stop_postgres \
87 test_namestore_api_monitoring_existing_postgres \
88 test_namestore_api_zone_to_name_postgres \
41 perf_namestore_api_zone_iteration_postgres 89 perf_namestore_api_zone_iteration_postgres
42endif 90endif
43endif 91endif
44 92
45if HAVE_TESTING
46TESTING_TESTS = \
47 test_namestore_api_store.nc \
48 test_namestore_api_store_update.nc \
49 test_namestore_api_lookup_public.nc \
50 test_namestore_api_lookup_private.nc \
51 test_namestore_api_lookup_nick.nc \
52 test_namestore_api_lookup_shadow.nc \
53 test_namestore_api_lookup_shadow_filter.nc \
54 test_namestore_api_remove.nc \
55 test_namestore_api_remove_not_existing_record.nc \
56 test_namestore_api_zone_iteration.nc \
57 test_namestore_api_zone_iteration_nick.nc \
58 test_namestore_api_zone_iteration_specific_zone.nc \
59 test_namestore_api_zone_iteration_stop.nc \
60 test_namestore_api_monitoring.nc \
61 test_namestore_api_monitoring_existing.nc \
62 test_namestore_api_zone_to_name
63endif
64
65# Declare .nc (NO-CONCURRENCY) as a test extension so that we can impart
66# sequential execution order for them
67TEST_EXTENSIONS = .nc
68test_namestore_api_store.log: test_namestore_api_store_update.log
69test_namestore_api_store_update.log: test_namestore_api_lookup_public.log
70test_namestore_api_lookup_public.log: test_namestore_api_lookup_private.log
71test_namestore_api_lookup_private.log: test_namestore_api_lookup_nick.log
72test_namestore_api_lookup_nick.log: test_namestore_api_lookup_shadow.log
73test_namestore_api_lookup_shadow.log: test_namestore_api_lookup_shadow_filter.log
74test_namestore_api_lookup_shadow_filter.log: test_namestore_api_remove.log
75test_namestore_api_remove.log: test_namestore_api_remove_not_existing_record.log
76test_namestore_api_remove_not_existing_record.log: test_namestore_api_zone_iteration.log
77test_namestore_api_zone_iteration.log: test_namestore_api_zone_iteration_nick.log
78test_namestore_api_zone_iteration_nick.log: test_namestore_api_zone_iteration_specific_zone.log
79test_namestore_api_zone_iteration_specific_zone.log: test_namestore_api_zone_iteration_stop.log
80test_namestore_api_zone_iteration_stop.log: test_namestore_api_monitoring.log
81test_namestore_api_monitoring.log: test_namestore_api_monitoring_existing.log
82
83if HAVE_SQLITE 93if HAVE_SQLITE
84check_PROGRAMS = \ 94check_PROGRAMS = \
85 $(SQLITE_TESTS) \ 95 $(SQLITE_TESTS) \
86 $(POSTGRES_TESTS) \ 96 $(POSTGRES_TESTS) \
87 $(FLAT_TESTS) \ 97 $(FLAT_TESTS)
88 $(TESTING_TESTS)
89endif 98endif
90 99
91if HAVE_MHD 100if HAVE_MHD
@@ -230,110 +239,327 @@ libgnunet_plugin_rest_namestore_la_LDFLAGS = \
230 $(GN_PLUGIN_LDFLAGS) 239 $(GN_PLUGIN_LDFLAGS)
231 240
232 241
233test_namestore_api_store_nc_SOURCES = \ 242test_namestore_api_store_flat_SOURCES = \
243 test_namestore_api_store.c
244test_namestore_api_store_flat_LDADD = \
245 $(top_builddir)/src/testing/libgnunettesting.la \
246 $(top_builddir)/src/util/libgnunetutil.la \
247 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
248 libgnunetnamestore.la
249
250test_namestore_api_store_sqlite_SOURCES = \
251 test_namestore_api_store.c
252test_namestore_api_store_sqlite_LDADD = \
253 $(top_builddir)/src/testing/libgnunettesting.la \
254 $(top_builddir)/src/util/libgnunetutil.la \
255 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
256 libgnunetnamestore.la
257
258test_namestore_api_store_postgres_SOURCES = \
234 test_namestore_api_store.c 259 test_namestore_api_store.c
235test_namestore_api_store_nc_LDADD = \ 260test_namestore_api_store_postgres_LDADD = \
236 $(top_builddir)/src/testing/libgnunettesting.la \ 261 $(top_builddir)/src/testing/libgnunettesting.la \
237 $(top_builddir)/src/util/libgnunetutil.la \ 262 $(top_builddir)/src/util/libgnunetutil.la \
238 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 263 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
239 libgnunetnamestore.la 264 libgnunetnamestore.la
240 265
241test_namestore_api_store_update_nc_SOURCES = \ 266test_namestore_api_store_update_flat_SOURCES = \
242 test_namestore_api_store_update.c 267 test_namestore_api_store_update.c
243test_namestore_api_store_update_nc_LDADD = \ 268test_namestore_api_store_update_flat_LDADD = \
244 $(top_builddir)/src/testing/libgnunettesting.la \ 269 $(top_builddir)/src/testing/libgnunettesting.la \
245 $(top_builddir)/src/util/libgnunetutil.la \ 270 $(top_builddir)/src/util/libgnunetutil.la \
246 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 271 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
247 $(top_builddir)/src/namecache/libgnunetnamecache.la \ 272 $(top_builddir)/src/namecache/libgnunetnamecache.la \
248 libgnunetnamestore.la 273 libgnunetnamestore.la
249 274
250test_namestore_api_lookup_public_nc_SOURCES = \ 275test_namestore_api_store_update_sqlite_SOURCES = \
276 test_namestore_api_store_update.c
277test_namestore_api_store_update_sqlite_LDADD = \
278 $(top_builddir)/src/testing/libgnunettesting.la \
279 $(top_builddir)/src/util/libgnunetutil.la \
280 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
281 $(top_builddir)/src/namecache/libgnunetnamecache.la \
282 libgnunetnamestore.la
283
284test_namestore_api_store_update_postgres_SOURCES = \
285 test_namestore_api_store_update.c
286test_namestore_api_store_update_postgres_LDADD = \
287 $(top_builddir)/src/testing/libgnunettesting.la \
288 $(top_builddir)/src/util/libgnunetutil.la \
289 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
290 $(top_builddir)/src/namecache/libgnunetnamecache.la \
291 libgnunetnamestore.la
292
293test_namestore_api_lookup_public_flat_SOURCES = \
251 test_namestore_api_lookup_public.c 294 test_namestore_api_lookup_public.c
252test_namestore_api_lookup_public_nc_LDADD = \ 295test_namestore_api_lookup_public_flat_LDADD = \
296 $(top_builddir)/src/testing/libgnunettesting.la \
297 $(top_builddir)/src/util/libgnunetutil.la \
298 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
299 $(top_builddir)/src/namecache/libgnunetnamecache.la \
300 libgnunetnamestore.la
301
302test_namestore_api_lookup_public_sqlite_SOURCES = \
303 test_namestore_api_lookup_public.c
304test_namestore_api_lookup_public_sqlite_LDADD = \
305 $(top_builddir)/src/testing/libgnunettesting.la \
306 $(top_builddir)/src/util/libgnunetutil.la \
307 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
308 $(top_builddir)/src/namecache/libgnunetnamecache.la \
309 libgnunetnamestore.la
310
311test_namestore_api_lookup_public_postgres_SOURCES = \
312 test_namestore_api_lookup_public.c
313test_namestore_api_lookup_public_postgres_LDADD = \
314 $(top_builddir)/src/testing/libgnunettesting.la \
315 $(top_builddir)/src/util/libgnunetutil.la \
316 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
317 $(top_builddir)/src/namecache/libgnunetnamecache.la \
318 libgnunetnamestore.la
319
320test_namestore_api_lookup_nick_sqlite_SOURCES = \
321 test_namestore_api_lookup_nick.c
322test_namestore_api_lookup_nick_sqlite_LDADD = \
253 $(top_builddir)/src/testing/libgnunettesting.la \ 323 $(top_builddir)/src/testing/libgnunettesting.la \
254 $(top_builddir)/src/util/libgnunetutil.la \ 324 $(top_builddir)/src/util/libgnunetutil.la \
255 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 325 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
256 $(top_builddir)/src/namecache/libgnunetnamecache.la \ 326 $(top_builddir)/src/namecache/libgnunetnamecache.la \
257 libgnunetnamestore.la 327 libgnunetnamestore.la
258 328
259test_namestore_api_lookup_nick_nc_SOURCES = \ 329test_namestore_api_lookup_nick_postgres_SOURCES = \
260 test_namestore_api_lookup_nick.c 330 test_namestore_api_lookup_nick.c
261test_namestore_api_lookup_nick_nc_LDADD = \ 331test_namestore_api_lookup_nick_postgres_LDADD = \
262 $(top_builddir)/src/testing/libgnunettesting.la \ 332 $(top_builddir)/src/testing/libgnunettesting.la \
263 $(top_builddir)/src/util/libgnunetutil.la \ 333 $(top_builddir)/src/util/libgnunetutil.la \
264 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 334 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
265 $(top_builddir)/src/namecache/libgnunetnamecache.la \ 335 $(top_builddir)/src/namecache/libgnunetnamecache.la \
266 libgnunetnamestore.la 336 libgnunetnamestore.la
267 337
268test_namestore_api_lookup_private_nc_SOURCES = \ 338test_namestore_api_lookup_nick_flat_SOURCES = \
339 test_namestore_api_lookup_nick.c
340test_namestore_api_lookup_nick_flat_LDADD = \
341 $(top_builddir)/src/testing/libgnunettesting.la \
342 $(top_builddir)/src/util/libgnunetutil.la \
343 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
344 $(top_builddir)/src/namecache/libgnunetnamecache.la \
345 libgnunetnamestore.la
346
347test_namestore_api_lookup_private_flat_SOURCES = \
348 test_namestore_api_lookup_private.c
349test_namestore_api_lookup_private_flat_LDADD = \
350 $(top_builddir)/src/testing/libgnunettesting.la \
351 $(top_builddir)/src/util/libgnunetutil.la \
352 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
353 $(top_builddir)/src/namecache/libgnunetnamecache.la \
354 libgnunetnamestore.la
355
356test_namestore_api_lookup_private_sqlite_SOURCES = \
269 test_namestore_api_lookup_private.c 357 test_namestore_api_lookup_private.c
270test_namestore_api_lookup_private_nc_LDADD = \ 358test_namestore_api_lookup_private_sqlite_LDADD = \
271 $(top_builddir)/src/testing/libgnunettesting.la \ 359 $(top_builddir)/src/testing/libgnunettesting.la \
272 $(top_builddir)/src/util/libgnunetutil.la \ 360 $(top_builddir)/src/util/libgnunetutil.la \
273 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 361 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
274 $(top_builddir)/src/namecache/libgnunetnamecache.la \ 362 $(top_builddir)/src/namecache/libgnunetnamecache.la \
275 libgnunetnamestore.la 363 libgnunetnamestore.la
276 364
277test_namestore_api_lookup_shadow_nc_SOURCES = \ 365test_namestore_api_lookup_private_postgres_SOURCES = \
366 test_namestore_api_lookup_private.c
367test_namestore_api_lookup_private_postgres_LDADD = \
368 $(top_builddir)/src/testing/libgnunettesting.la \
369 $(top_builddir)/src/util/libgnunetutil.la \
370 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
371 $(top_builddir)/src/namecache/libgnunetnamecache.la \
372 libgnunetnamestore.la
373
374test_namestore_api_lookup_shadow_flat_SOURCES = \
278 test_namestore_api_lookup_shadow.c 375 test_namestore_api_lookup_shadow.c
279test_namestore_api_lookup_shadow_nc_LDADD = \ 376test_namestore_api_lookup_shadow_flat_LDADD = \
280 $(top_builddir)/src/testing/libgnunettesting.la \ 377 $(top_builddir)/src/testing/libgnunettesting.la \
281 $(top_builddir)/src/util/libgnunetutil.la \ 378 $(top_builddir)/src/util/libgnunetutil.la \
282 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 379 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
283 $(top_builddir)/src/namecache/libgnunetnamecache.la \ 380 $(top_builddir)/src/namecache/libgnunetnamecache.la \
284 libgnunetnamestore.la 381 libgnunetnamestore.la
285 382
286test_namestore_api_lookup_shadow_filter_nc_SOURCES = \ 383test_namestore_api_lookup_shadow_sqlite_SOURCES = \
384 test_namestore_api_lookup_shadow.c
385test_namestore_api_lookup_shadow_sqlite_LDADD = \
386 $(top_builddir)/src/testing/libgnunettesting.la \
387 $(top_builddir)/src/util/libgnunetutil.la \
388 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
389 $(top_builddir)/src/namecache/libgnunetnamecache.la \
390 libgnunetnamestore.la
391
392test_namestore_api_lookup_shadow_postgres_SOURCES = \
393 test_namestore_api_lookup_shadow.c
394test_namestore_api_lookup_shadow_postgres_LDADD = \
395 $(top_builddir)/src/testing/libgnunettesting.la \
396 $(top_builddir)/src/util/libgnunetutil.la \
397 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
398 $(top_builddir)/src/namecache/libgnunetnamecache.la \
399 libgnunetnamestore.la
400
401test_namestore_api_lookup_shadow_filter_flat_SOURCES = \
287 test_namestore_api_lookup_shadow_filter.c 402 test_namestore_api_lookup_shadow_filter.c
288test_namestore_api_lookup_shadow_filter_nc_LDADD = \ 403test_namestore_api_lookup_shadow_filter_flat_LDADD = \
289 $(top_builddir)/src/testing/libgnunettesting.la \ 404 $(top_builddir)/src/testing/libgnunettesting.la \
290 $(top_builddir)/src/util/libgnunetutil.la \ 405 $(top_builddir)/src/util/libgnunetutil.la \
291 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 406 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
292 $(top_builddir)/src/namecache/libgnunetnamecache.la \ 407 $(top_builddir)/src/namecache/libgnunetnamecache.la \
293 libgnunetnamestore.la 408 libgnunetnamestore.la
294 409
295test_namestore_api_remove_nc_SOURCES = \ 410test_namestore_api_lookup_shadow_filter_sqlite_SOURCES = \
411 test_namestore_api_lookup_shadow_filter.c
412test_namestore_api_lookup_shadow_filter_sqlite_LDADD = \
413 $(top_builddir)/src/testing/libgnunettesting.la \
414 $(top_builddir)/src/util/libgnunetutil.la \
415 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
416 $(top_builddir)/src/namecache/libgnunetnamecache.la \
417 libgnunetnamestore.la
418test_namestore_api_lookup_shadow_filter_postgres_SOURCES = \
419 test_namestore_api_lookup_shadow_filter.c
420test_namestore_api_lookup_shadow_filter_postgres_LDADD = \
421 $(top_builddir)/src/testing/libgnunettesting.la \
422 $(top_builddir)/src/util/libgnunetutil.la \
423 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
424 $(top_builddir)/src/namecache/libgnunetnamecache.la \
425 libgnunetnamestore.la
426
427test_namestore_api_remove_sqlite_SOURCES = \
428 test_namestore_api_remove.c
429test_namestore_api_remove_sqlite_LDADD = \
430 $(top_builddir)/src/testing/libgnunettesting.la \
431 $(top_builddir)/src/util/libgnunetutil.la \
432 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
433 libgnunetnamestore.la
434
435test_namestore_api_remove_postgres_SOURCES = \
296 test_namestore_api_remove.c 436 test_namestore_api_remove.c
297test_namestore_api_remove_nc_LDADD = \ 437test_namestore_api_remove_postgres_LDADD = \
438 $(top_builddir)/src/testing/libgnunettesting.la \
439 $(top_builddir)/src/util/libgnunetutil.la \
440 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
441 libgnunetnamestore.la
442
443test_namestore_api_remove_flat_SOURCES = \
444 test_namestore_api_remove.c
445test_namestore_api_remove_flat_LDADD = \
446 $(top_builddir)/src/testing/libgnunettesting.la \
447 $(top_builddir)/src/util/libgnunetutil.la \
448 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
449 libgnunetnamestore.la
450
451test_namestore_api_remove_not_existing_record_flat_SOURCES = \
452 test_namestore_api_remove_not_existing_record.c
453test_namestore_api_remove_not_existing_record_flat_LDADD = \
298 $(top_builddir)/src/testing/libgnunettesting.la \ 454 $(top_builddir)/src/testing/libgnunettesting.la \
299 $(top_builddir)/src/util/libgnunetutil.la \ 455 $(top_builddir)/src/util/libgnunetutil.la \
300 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 456 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
301 libgnunetnamestore.la 457 libgnunetnamestore.la
302 458
303test_namestore_api_remove_not_existing_record_nc_SOURCES = \ 459test_namestore_api_remove_not_existing_record_sqlite_SOURCES = \
304 test_namestore_api_remove_not_existing_record.c 460 test_namestore_api_remove_not_existing_record.c
305test_namestore_api_remove_not_existing_record_nc_LDADD = \ 461test_namestore_api_remove_not_existing_record_sqlite_LDADD = \
306 $(top_builddir)/src/testing/libgnunettesting.la \ 462 $(top_builddir)/src/testing/libgnunettesting.la \
307 $(top_builddir)/src/util/libgnunetutil.la \ 463 $(top_builddir)/src/util/libgnunetutil.la \
308 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 464 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
309 libgnunetnamestore.la 465 libgnunetnamestore.la
310 466
311test_namestore_api_zone_to_name_SOURCES = \ 467test_namestore_api_remove_not_existing_record_postgres_SOURCES = \
468 test_namestore_api_remove_not_existing_record.c
469test_namestore_api_remove_not_existing_record_postgres_LDADD = \
470 $(top_builddir)/src/testing/libgnunettesting.la \
471 $(top_builddir)/src/util/libgnunetutil.la \
472 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
473 libgnunetnamestore.la
474
475test_namestore_api_zone_to_name_flat_SOURCES = \
476 test_namestore_api_zone_to_name.c
477test_namestore_api_zone_to_name_flat_LDADD = \
478 $(top_builddir)/src/testing/libgnunettesting.la \
479 $(top_builddir)/src/util/libgnunetutil.la \
480 libgnunetnamestore.la
481
482test_namestore_api_zone_to_name_sqlite_SOURCES = \
312 test_namestore_api_zone_to_name.c 483 test_namestore_api_zone_to_name.c
313test_namestore_api_zone_to_name_LDADD = \ 484test_namestore_api_zone_to_name_sqlite_LDADD = \
314 $(top_builddir)/src/testing/libgnunettesting.la \ 485 $(top_builddir)/src/testing/libgnunettesting.la \
315 $(top_builddir)/src/util/libgnunetutil.la \ 486 $(top_builddir)/src/util/libgnunetutil.la \
316 libgnunetnamestore.la 487 libgnunetnamestore.la
317 488
318test_namestore_api_monitoring_nc_SOURCES = \ 489test_namestore_api_zone_to_name_postgres_SOURCES = \
490 test_namestore_api_zone_to_name.c
491test_namestore_api_zone_to_name_postgres_LDADD = \
492 $(top_builddir)/src/testing/libgnunettesting.la \
493 $(top_builddir)/src/util/libgnunetutil.la \
494 libgnunetnamestore.la
495
496test_namestore_api_monitoring_flat_SOURCES = \
319 test_namestore_api_monitoring.c 497 test_namestore_api_monitoring.c
320test_namestore_api_monitoring_nc_LDADD = \ 498test_namestore_api_monitoring_flat_LDADD = \
499 $(top_builddir)/src/testing/libgnunettesting.la \
500 libgnunetnamestore.la \
501 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
502 $(top_builddir)/src/util/libgnunetutil.la
503
504test_namestore_api_monitoring_sqlite_SOURCES = \
505 test_namestore_api_monitoring.c
506test_namestore_api_monitoring_sqlite_LDADD = \
507 $(top_builddir)/src/testing/libgnunettesting.la \
508 libgnunetnamestore.la \
509 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
510 $(top_builddir)/src/util/libgnunetutil.la
511
512test_namestore_api_monitoring_postgres_SOURCES = \
513 test_namestore_api_monitoring.c
514test_namestore_api_monitoring_postgres_LDADD = \
515 $(top_builddir)/src/testing/libgnunettesting.la \
516 libgnunetnamestore.la \
517 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
518 $(top_builddir)/src/util/libgnunetutil.la
519
520test_namestore_api_monitoring_existing_flat_SOURCES = \
521 test_namestore_api_monitoring_existing.c
522test_namestore_api_monitoring_existing_flat_LDADD = \
523 $(top_builddir)/src/testing/libgnunettesting.la \
524 libgnunetnamestore.la \
525 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
526 $(top_builddir)/src/util/libgnunetutil.la
527
528test_namestore_api_monitoring_existing_sqlite_SOURCES = \
529 test_namestore_api_monitoring_existing.c
530test_namestore_api_monitoring_existing_sqlite_LDADD = \
321 $(top_builddir)/src/testing/libgnunettesting.la \ 531 $(top_builddir)/src/testing/libgnunettesting.la \
322 libgnunetnamestore.la \ 532 libgnunetnamestore.la \
323 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 533 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
324 $(top_builddir)/src/util/libgnunetutil.la 534 $(top_builddir)/src/util/libgnunetutil.la
325 535
326test_namestore_api_monitoring_existing_nc_SOURCES = \ 536test_namestore_api_monitoring_existing_postgres_SOURCES = \
327 test_namestore_api_monitoring_existing.c 537 test_namestore_api_monitoring_existing.c
328test_namestore_api_monitoring_existing_nc_LDADD = \ 538test_namestore_api_monitoring_existing_postgres_LDADD = \
329 $(top_builddir)/src/testing/libgnunettesting.la \ 539 $(top_builddir)/src/testing/libgnunettesting.la \
330 libgnunetnamestore.la \ 540 libgnunetnamestore.la \
331 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 541 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
332 $(top_builddir)/src/util/libgnunetutil.la 542 $(top_builddir)/src/util/libgnunetutil.la
333 543
334test_namestore_api_zone_iteration_nc_SOURCES = \ 544test_namestore_api_zone_iteration_flat_SOURCES = \
545 test_namestore_api_zone_iteration.c
546test_namestore_api_zone_iteration_flat_LDADD = \
547 $(top_builddir)/src/testing/libgnunettesting.la \
548 $(top_builddir)/src/util/libgnunetutil.la \
549 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
550 libgnunetnamestore.la
551
552test_namestore_api_zone_iteration_sqlite_SOURCES = \
553 test_namestore_api_zone_iteration.c
554test_namestore_api_zone_iteration_sqlite_LDADD = \
555 $(top_builddir)/src/testing/libgnunettesting.la \
556 $(top_builddir)/src/util/libgnunetutil.la \
557 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
558 libgnunetnamestore.la
559
560test_namestore_api_zone_iteration_postgres_SOURCES = \
335 test_namestore_api_zone_iteration.c 561 test_namestore_api_zone_iteration.c
336test_namestore_api_zone_iteration_nc_LDADD = \ 562test_namestore_api_zone_iteration_postgres_LDADD = \
337 $(top_builddir)/src/testing/libgnunettesting.la \ 563 $(top_builddir)/src/testing/libgnunettesting.la \
338 $(top_builddir)/src/util/libgnunetutil.la \ 564 $(top_builddir)/src/util/libgnunetutil.la \
339 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 565 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
@@ -363,26 +589,73 @@ perf_namestore_api_zone_iteration_flat_LDADD = \
363 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 589 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
364 libgnunetnamestore.la 590 libgnunetnamestore.la
365 591
366test_namestore_api_zone_iteration_nick_nc_SOURCES = \ 592test_namestore_api_zone_iteration_nick_flat_SOURCES = \
367 test_namestore_api_zone_iteration_nick.c 593 test_namestore_api_zone_iteration_nick.c
368test_namestore_api_zone_iteration_nick_nc_LDADD = \ 594test_namestore_api_zone_iteration_nick_flat_LDADD = \
369 $(top_builddir)/src/testing/libgnunettesting.la \ 595 $(top_builddir)/src/testing/libgnunettesting.la \
370 $(top_builddir)/src/util/libgnunetutil.la \ 596 $(top_builddir)/src/util/libgnunetutil.la \
371 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 597 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
372 libgnunetnamestore.la 598 libgnunetnamestore.la
373 599
600test_namestore_api_zone_iteration_nick_sqlite_SOURCES = \
601 test_namestore_api_zone_iteration_nick.c
602test_namestore_api_zone_iteration_nick_sqlite_LDADD = \
603 $(top_builddir)/src/testing/libgnunettesting.la \
604 $(top_builddir)/src/util/libgnunetutil.la \
605 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
606 libgnunetnamestore.la
374 607
375test_namestore_api_zone_iteration_specific_zone_nc_SOURCES = \ 608test_namestore_api_zone_iteration_nick_postgres_SOURCES = \
609 test_namestore_api_zone_iteration_nick.c
610test_namestore_api_zone_iteration_nick_postgres_LDADD = \
611 $(top_builddir)/src/testing/libgnunettesting.la \
612 $(top_builddir)/src/util/libgnunetutil.la \
613 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
614 libgnunetnamestore.la
615
616test_namestore_api_zone_iteration_specific_zone_flat_SOURCES = \
617 test_namestore_api_zone_iteration_specific_zone.c
618test_namestore_api_zone_iteration_specific_zone_flat_LDADD = \
619 $(top_builddir)/src/testing/libgnunettesting.la \
620 $(top_builddir)/src/util/libgnunetutil.la \
621 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
622 libgnunetnamestore.la
623
624test_namestore_api_zone_iteration_specific_zone_sqlite_SOURCES = \
625 test_namestore_api_zone_iteration_specific_zone.c
626test_namestore_api_zone_iteration_specific_zone_sqlite_LDADD = \
627 $(top_builddir)/src/testing/libgnunettesting.la \
628 $(top_builddir)/src/util/libgnunetutil.la \
629 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
630 libgnunetnamestore.la
631
632test_namestore_api_zone_iteration_specific_zone_postgres_SOURCES = \
376 test_namestore_api_zone_iteration_specific_zone.c 633 test_namestore_api_zone_iteration_specific_zone.c
377test_namestore_api_zone_iteration_specific_zone_nc_LDADD = \ 634test_namestore_api_zone_iteration_specific_zone_postgres_LDADD = \
635 $(top_builddir)/src/testing/libgnunettesting.la \
636 $(top_builddir)/src/util/libgnunetutil.la \
637 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
638 libgnunetnamestore.la
639
640test_namestore_api_zone_iteration_stop_flat_SOURCES = \
641 test_namestore_api_zone_iteration_stop.c
642test_namestore_api_zone_iteration_stop_flat_LDADD = \
643 $(top_builddir)/src/testing/libgnunettesting.la \
644 $(top_builddir)/src/util/libgnunetutil.la \
645 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
646 libgnunetnamestore.la
647
648test_namestore_api_zone_iteration_stop_sqlite_SOURCES = \
649 test_namestore_api_zone_iteration_stop.c
650test_namestore_api_zone_iteration_stop_sqlite_LDADD = \
378 $(top_builddir)/src/testing/libgnunettesting.la \ 651 $(top_builddir)/src/testing/libgnunettesting.la \
379 $(top_builddir)/src/util/libgnunetutil.la \ 652 $(top_builddir)/src/util/libgnunetutil.la \
380 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 653 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
381 libgnunetnamestore.la 654 libgnunetnamestore.la
382 655
383test_namestore_api_zone_iteration_stop_nc_SOURCES = \ 656test_namestore_api_zone_iteration_stop_postgres_SOURCES = \
384 test_namestore_api_zone_iteration_stop.c 657 test_namestore_api_zone_iteration_stop.c
385test_namestore_api_zone_iteration_stop_nc_LDADD = \ 658test_namestore_api_zone_iteration_stop_postgres_LDADD = \
386 $(top_builddir)/src/testing/libgnunettesting.la \ 659 $(top_builddir)/src/testing/libgnunettesting.la \
387 $(top_builddir)/src/util/libgnunetutil.la \ 660 $(top_builddir)/src/util/libgnunetutil.la \
388 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 661 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
@@ -416,6 +689,9 @@ EXTRA_DIST = \
416 test_namestore_api_postgres.conf \ 689 test_namestore_api_postgres.conf \
417 test_namestore_api_sqlite.conf \ 690 test_namestore_api_sqlite.conf \
418 test_namestore_api_flat.conf \ 691 test_namestore_api_flat.conf \
692 perf_namestore_api_postgres.conf \
693 perf_namestore_api_sqlite.conf \
694 perf_namestore_api_flat.conf \
419 test_plugin_namestore_sqlite.conf \ 695 test_plugin_namestore_sqlite.conf \
420 test_plugin_namestore_postgres.conf \ 696 test_plugin_namestore_postgres.conf \
421 test_plugin_namestore_flat.conf \ 697 test_plugin_namestore_flat.conf \