aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <mschanzenbach@posteo.de>2015-09-14 11:10:11 +0000
committerMartin Schanzenbach <mschanzenbach@posteo.de>2015-09-14 11:10:11 +0000
commitb0a03eeebfdedbb7b0070ef00514f321aafa49db (patch)
tree06233b8dc0c1bf8ee580367e772c9951a3d7cee6 /src/namestore/Makefile.am
parent134da182130592c78bdb5d348826825665a2ffab (diff)
downloadgnunet-b0a03eeebfdedbb7b0070ef00514f321aafa49db.tar.gz
gnunet-b0a03eeebfdedbb7b0070ef00514f321aafa49db.zip
- revert plugin move. Add new identity-token
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index 8ebcac0a1..2233b5cad 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -81,6 +81,11 @@ endif
81lib_LTLIBRARIES = \ 81lib_LTLIBRARIES = \
82 libgnunetnamestore.la 82 libgnunetnamestore.la
83 83
84if HAVE_REST
85lib_LTLIBRARIES += libgnunet_plugin_rest_namestore.la
86endif
87
88
84libgnunetnamestore_la_SOURCES = \ 89libgnunetnamestore_la_SOURCES = \
85 namestore_api.c \ 90 namestore_api.c \
86 namestore_api_monitor.c \ 91 namestore_api_monitor.c \
@@ -177,6 +182,17 @@ libgnunet_plugin_namestore_postgres_la_LIBADD = \
177libgnunet_plugin_namestore_postgres_la_LDFLAGS = \ 182libgnunet_plugin_namestore_postgres_la_LDFLAGS = \
178 $(GN_PLUGIN_LDFLAGS) $(POSTGRESQL_LDFLAGS) 183 $(GN_PLUGIN_LDFLAGS) $(POSTGRESQL_LDFLAGS)
179 184
185libgnunet_plugin_rest_namestore_la_SOURCES = \
186 plugin_rest_namestore.c
187libgnunet_plugin_rest_namestore_la_LIBADD = \
188 libgnunetnamestore.la \
189 $(top_builddir)/src/identity/libgnunetidentity.la \
190 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
191 $(LTLIBINTL) -ljansson -lmicrohttpd
192libgnunet_plugin_rest_namestore_la_LDFLAGS = \
193 $(GN_PLUGIN_LDFLAGS)
194
195
180test_namestore_api_store_SOURCES = \ 196test_namestore_api_store_SOURCES = \
181 test_namestore_api_store.c 197 test_namestore_api_store.c
182test_namestore_api_store_LDADD = \ 198test_namestore_api_store_LDADD = \