summaryrefslogtreecommitdiff
path: root/src/nat/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2016-10-23 19:53:59 +0000
committerChristian Grothoff <christian@grothoff.org>2016-10-23 19:53:59 +0000
commit10f9bc91ab9d758d0d60dd672206027cd136342a (patch)
treecb8c09ffe145ae925d5a51d4bd85029bb61f7df2 /src/nat/Makefile.am
parent588f820301bf298496e7bf0e6dea7b2c60ab3936 (diff)
downloadgnunet-10f9bc91ab9d758d0d60dd672206027cd136342a.tar.gz
gnunet-10f9bc91ab9d758d0d60dd672206027cd136342a.zip
new NAT lib client api skeleton
Diffstat (limited to 'src/nat/Makefile.am')
-rw-r--r--src/nat/Makefile.am17
1 files changed, 13 insertions, 4 deletions
diff --git a/src/nat/Makefile.am b/src/nat/Makefile.am
index 5e89ac24d..e4b013916 100644
--- a/src/nat/Makefile.am
+++ b/src/nat/Makefile.am
@@ -52,7 +52,7 @@ gnunet_helper_nat_server_SOURCES = \
52gnunet_helper_nat_client_SOURCES = \ 52gnunet_helper_nat_client_SOURCES = \
53 $(NATCLIENT) 53 $(NATCLIENT)
54 54
55 55
56gnunet_nat_SOURCES = \ 56gnunet_nat_SOURCES = \
57gnunet-nat.c nat.h 57gnunet-nat.c nat.h
58gnunet_nat_LDADD = \ 58gnunet_nat_LDADD = \
@@ -64,7 +64,9 @@ if USE_COVERAGE
64 AM_CFLAGS = -fprofile-arcs -ftest-coverage 64 AM_CFLAGS = -fprofile-arcs -ftest-coverage
65endif 65endif
66 66
67lib_LTLIBRARIES = libgnunetnat.la 67lib_LTLIBRARIES = \
68 libgnunetnat.la \
69 libgnunetnatnew.la
68 70
69libgnunetnat_la_SOURCES = \ 71libgnunetnat_la_SOURCES = \
70 nat.c nat.h \ 72 nat.c nat.h \
@@ -72,15 +74,22 @@ libgnunetnat_la_SOURCES = \
72 nat_test.c \ 74 nat_test.c \
73 nat_mini.c \ 75 nat_mini.c \
74 nat_stun.c 76 nat_stun.c
75
76libgnunetnat_la_LIBADD = \ 77libgnunetnat_la_LIBADD = \
77 $(top_builddir)/src/util/libgnunetutil.la \ 78 $(top_builddir)/src/util/libgnunetutil.la \
78 $(GN_LIBINTL) @EXT_LIBS@ 79 $(GN_LIBINTL) @EXT_LIBS@
79
80libgnunetnat_la_LDFLAGS = \ 80libgnunetnat_la_LDFLAGS = \
81 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 81 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
82 -version-info 1:1:1 82 -version-info 1:1:1
83 83
84libgnunetnatnew_la_SOURCES = \
85 nat_api.c nat.h
86libgnunetnatnew_la_LIBADD = \
87 $(top_builddir)/src/util/libgnunetutil.la \
88 $(GN_LIBINTL) @EXT_LIBS@
89libgnunetnatnew_la_LDFLAGS = \
90 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
91 -version-info 2:0:0
92
84check_PROGRAMS = \ 93check_PROGRAMS = \
85 test_nat \ 94 test_nat \
86 test_nat_mini \ 95 test_nat_mini \