summaryrefslogtreecommitdiff
path: root/src/nat/Makefile.am
diff options
context:
space:
mode:
authorBruno Cabral <bcabral@uw.edu>2015-06-15 05:46:13 +0000
committerBruno Cabral <bcabral@uw.edu>2015-06-15 05:46:13 +0000
commit1ed484dfdf1676d92e95b9ed262abc28ca7b3aee (patch)
treecc76406ab7f0a3484cd9aa66fca168d864aa246d /src/nat/Makefile.am
parentfa7754fd510260ffb8850feb5d6559e55f75d4e9 (diff)
downloadgnunet-1ed484dfdf1676d92e95b9ed262abc28ca7b3aee.tar.gz
gnunet-1ed484dfdf1676d92e95b9ed262abc28ca7b3aee.zip
Initial import of STUN support
Diffstat (limited to 'src/nat/Makefile.am')
-rw-r--r--src/nat/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/src/nat/Makefile.am b/src/nat/Makefile.am
index 72ac0a1f0..063b8e3ab 100644
--- a/src/nat/Makefile.am
+++ b/src/nat/Makefile.am
@@ -63,7 +63,8 @@ libgnunetnat_la_SOURCES = \
63 nat.c nat.h \ 63 nat.c nat.h \
64 nat_auto.c \ 64 nat_auto.c \
65 nat_test.c \ 65 nat_test.c \
66 nat_mini.c 66 nat_mini.c \
67 nat_stun.c
67 68
68libgnunetnat_la_LIBADD = \ 69libgnunetnat_la_LIBADD = \
69 $(top_builddir)/src/util/libgnunetutil.la \ 70 $(top_builddir)/src/util/libgnunetutil.la \
@@ -76,7 +77,8 @@ libgnunetnat_la_LDFLAGS = \
76check_PROGRAMS = \ 77check_PROGRAMS = \
77 test_nat \ 78 test_nat \
78 test_nat_mini \ 79 test_nat_mini \
79 test_nat_test 80 test_nat_test \
81 test_stun
80 82
81if ENABLE_TEST_RUN 83if ENABLE_TEST_RUN
82 AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH; 84 AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;
@@ -102,6 +104,11 @@ test_nat_test_LDADD = \
102 libgnunetnat.la \ 104 libgnunetnat.la \
103 $(top_builddir)/src/util/libgnunetutil.la 105 $(top_builddir)/src/util/libgnunetutil.la
104 106
107test_stun_SOURCES = \
108 test_stun.c
109test_stun_LDADD = \
110 libgnunetnat.la \
111 $(top_builddir)/src/util/libgnunetutil.la
105 112
106EXTRA_DIST = \ 113EXTRA_DIST = \
107 test_nat_data.conf \ 114 test_nat_data.conf \