summaryrefslogtreecommitdiff
path: root/src/nat/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2016-10-31 10:30:38 +0000
committerChristian Grothoff <christian@grothoff.org>2016-10-31 10:30:38 +0000
commit331e0e66df283db2d305bd6b80ac2b1896271d4f (patch)
tree42603cbda83cafbdec753da6f1d346ef66f223de /src/nat/Makefile.am
parentf7f26f6ca1b76d2734463d4989b9541df48a6773 (diff)
downloadgnunet-331e0e66df283db2d305bd6b80ac2b1896271d4f.tar.gz
gnunet-331e0e66df283db2d305bd6b80ac2b1896271d4f.zip
add template for NAT service
Diffstat (limited to 'src/nat/Makefile.am')
-rw-r--r--src/nat/Makefile.am16
1 files changed, 13 insertions, 3 deletions
diff --git a/src/nat/Makefile.am b/src/nat/Makefile.am
index e4b013916..d8d50e1a4 100644
--- a/src/nat/Makefile.am
+++ b/src/nat/Makefile.am
@@ -38,7 +38,9 @@ bin_PROGRAMS = \
38 gnunet-nat 38 gnunet-nat
39 39
40libexec_PROGRAMS = \ 40libexec_PROGRAMS = \
41 $(NATBIN) 41 $(NATBIN) \
42 gnunet-service-nat
43
42 44
43gnunet_nat_server_SOURCES = \ 45gnunet_nat_server_SOURCES = \
44 gnunet-nat-server.c nat.h 46 gnunet-nat-server.c nat.h
@@ -54,7 +56,7 @@ gnunet_helper_nat_client_SOURCES = \
54 56
55 57
56gnunet_nat_SOURCES = \ 58gnunet_nat_SOURCES = \
57gnunet-nat.c nat.h 59 gnunet-nat.c nat.h
58gnunet_nat_LDADD = \ 60gnunet_nat_LDADD = \
59 libgnunetnat.la \ 61 libgnunetnat.la \
60 $(top_builddir)/src/util/libgnunetutil.la 62 $(top_builddir)/src/util/libgnunetutil.la
@@ -90,6 +92,15 @@ libgnunetnatnew_la_LDFLAGS = \
90 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 92 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
91 -version-info 2:0:0 93 -version-info 2:0:0
92 94
95gnunet_service_nat_SOURCES = \
96 gnunet-service-nat.c
97gnunet_service_nat_LDADD = \
98 $(top_builddir)/src/util/libgnunetutil.la \
99 $(top_builddir)/src/statistics/libgnunetstatistics.la \
100 $(LIBGCRYPT_LIBS) \
101 -lgcrypt \
102 $(GN_LIBINTL)
103
93check_PROGRAMS = \ 104check_PROGRAMS = \
94 test_nat \ 105 test_nat \
95 test_nat_mini \ 106 test_nat_mini \
@@ -113,7 +124,6 @@ test_nat_mini_LDADD = \
113 libgnunetnat.la \ 124 libgnunetnat.la \
114 $(top_builddir)/src/util/libgnunetutil.la 125 $(top_builddir)/src/util/libgnunetutil.la
115 126
116
117test_nat_test_SOURCES = \ 127test_nat_test_SOURCES = \
118 test_nat_test.c 128 test_nat_test.c
119test_nat_test_LDADD = \ 129test_nat_test_LDADD = \