summaryrefslogtreecommitdiff
path: root/src/nat/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-11-30 00:02:26 +0000
committerChristian Grothoff <christian@grothoff.org>2013-11-30 00:02:26 +0000
commitb2f1bcafa32963ef1bbb9c00ea7b75c933c2016e (patch)
tree213cf86c269c6f61cfae3cb8e350d5ee1eb7f136 /src/nat/Makefile.am
parentd3ab6b114ef933c3810919f8bdb9f8c3ceb13774 (diff)
downloadgnunet-b2f1bcafa32963ef1bbb9c00ea7b75c933c2016e.tar.gz
gnunet-b2f1bcafa32963ef1bbb9c00ea7b75c933c2016e.zip
applying patch from #3148 (by shedatc) to make gnunet-helper-nat-client compile on FreeBSD
Diffstat (limited to 'src/nat/Makefile.am')
-rw-r--r--src/nat/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/nat/Makefile.am b/src/nat/Makefile.am
index 6690026d2..e5630519c 100644
--- a/src/nat/Makefile.am
+++ b/src/nat/Makefile.am
@@ -21,6 +21,14 @@ if LINUX
21install-exec-hook: 21install-exec-hook:
22 $(top_srcdir)/src/nat/install-nat-helper.sh $(libexecdir) $(SUDO_BINARY) || true 22 $(top_srcdir)/src/nat/install-nat-helper.sh $(libexecdir) $(SUDO_BINARY) || true
23else 23else
24if XFREEBSD
25 NATBIN = gnunet-helper-nat-server gnunet-helper-nat-client
26 NATSERVER = gnunet-helper-nat-server.c
27 NATCLIENT = gnunet-helper-nat-client.c
28install-exec-hook:
29 $(top_srcdir)/src/nat/install-nat-helper.sh $(libexecdir) $(SUDO_BINARY) || true
30endif
31else
24install-exec-hook: 32install-exec-hook:
25endif 33endif
26 34
@@ -97,4 +105,4 @@ test_nat_test_LDADD = \
97 105
98EXTRA_DIST = \ 106EXTRA_DIST = \
99 test_nat_data.conf \ 107 test_nat_data.conf \
100 test_nat_test_data.conf \ No newline at end of file 108 test_nat_test_data.conf