summaryrefslogtreecommitdiff
path: root/src/nat/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2014-09-13 13:54:57 +0000
committerChristian Grothoff <christian@grothoff.org>2014-09-13 13:54:57 +0000
commitd94c5185fcdf47c6a57d3233b946fa7e621f7ad9 (patch)
tree1ded577285183d6457bde8787b9bccaa01f12143 /src/nat/Makefile.am
parente184df6030ab5c5374fe3b8a94482ff5a30c1580 (diff)
downloadgnunet-d94c5185fcdf47c6a57d3233b946fa7e621f7ad9.tar.gz
gnunet-d94c5185fcdf47c6a57d3233b946fa7e621f7ad9.zip
fixing parallel build, getting rid of useless _DEPENDENCIES declarations
Diffstat (limited to 'src/nat/Makefile.am')
-rw-r--r--src/nat/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/src/nat/Makefile.am b/src/nat/Makefile.am
index 7d772ab31..b762c74f4 100644
--- a/src/nat/Makefile.am
+++ b/src/nat/Makefile.am
@@ -41,10 +41,8 @@ libexec_PROGRAMS = \
41gnunet_nat_server_SOURCES = \ 41gnunet_nat_server_SOURCES = \
42 gnunet-nat-server.c nat.h 42 gnunet-nat-server.c nat.h
43gnunet_nat_server_LDADD = \ 43gnunet_nat_server_LDADD = \
44 $(top_builddir)/src/nat/libgnunetnat.la \ 44 libgnunetnat.la \
45 $(top_builddir)/src/util/libgnunetutil.la 45 $(top_builddir)/src/util/libgnunetutil.la
46gnunet_nat_server_DEPENDENCIES = \
47 libgnunetnat.la
48 46
49gnunet_helper_nat_server_SOURCES = \ 47gnunet_helper_nat_server_SOURCES = \
50 $(NATSERVER) 48 $(NATSERVER)
@@ -87,20 +85,20 @@ endif
87test_nat_SOURCES = \ 85test_nat_SOURCES = \
88 test_nat.c 86 test_nat.c
89test_nat_LDADD = \ 87test_nat_LDADD = \
90 $(top_builddir)/src/nat/libgnunetnat.la \ 88 libgnunetnat.la \
91 $(top_builddir)/src/util/libgnunetutil.la 89 $(top_builddir)/src/util/libgnunetutil.la
92 90
93test_nat_mini_SOURCES = \ 91test_nat_mini_SOURCES = \
94 test_nat_mini.c 92 test_nat_mini.c
95test_nat_mini_LDADD = \ 93test_nat_mini_LDADD = \
96 $(top_builddir)/src/nat/libgnunetnat.la \ 94 libgnunetnat.la \
97 $(top_builddir)/src/util/libgnunetutil.la 95 $(top_builddir)/src/util/libgnunetutil.la
98 96
99 97
100test_nat_test_SOURCES = \ 98test_nat_test_SOURCES = \
101 test_nat_test.c 99 test_nat_test.c
102test_nat_test_LDADD = \ 100test_nat_test_LDADD = \
103 $(top_builddir)/src/nat/libgnunetnat.la \ 101 libgnunetnat.la \
104 $(top_builddir)/src/util/libgnunetutil.la 102 $(top_builddir)/src/util/libgnunetutil.la
105 103
106 104