aboutsummaryrefslogtreecommitdiff
path: root/src/peerinfo/Makefile.am
diff options
context:
space:
mode:
authorSchanzenbach, Martin <mschanzenbach@posteo.de>2019-03-12 09:43:56 +0100
committerSchanzenbach, Martin <mschanzenbach@posteo.de>2019-03-12 09:43:56 +0100
commit60aff9e596e988954d3f50d57442744b1e20f576 (patch)
treea7e1351516bc2ac0a725bb5ab19398f3bace0482 /src/peerinfo/Makefile.am
parenta649dcbd9b204c7ec807d711e4c1bf7cb2edf5ae (diff)
downloadgnunet-60aff9e596e988954d3f50d57442744b1e20f576.tar.gz
gnunet-60aff9e596e988954d3f50d57442744b1e20f576.zip
move peerinfo rest
Diffstat (limited to 'src/peerinfo/Makefile.am')
-rw-r--r--src/peerinfo/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/peerinfo/Makefile.am b/src/peerinfo/Makefile.am
index ef79d6720..deb3fcf6c 100644
--- a/src/peerinfo/Makefile.am
+++ b/src/peerinfo/Makefile.am
@@ -17,8 +17,30 @@ if USE_COVERAGE
17 XLIB = -lgcov 17 XLIB = -lgcov
18endif 18endif
19 19
20if HAVE_MHD
21if HAVE_JSON
22REST_PLUGIN = libgnunet_plugin_rest_peerinfo.la
23endif
24endif
25
20lib_LTLIBRARIES = libgnunetpeerinfo.la 26lib_LTLIBRARIES = libgnunetpeerinfo.la
21 27
28plugin_LTLIBRARIES = $(REST_PLUGIN)
29
30libgnunet_plugin_rest_peerinfo_la_SOURCES = \
31 plugin_rest_peerinfo.c
32libgnunet_plugin_rest_peerinfo_la_LIBADD = \
33 $(top_builddir)/src/hello/libgnunethello.la \
34 libgnunetpeerinfo.la \
35 $(top_builddir)/src/rest/libgnunetrest.la \
36 $(top_builddir)/src/json/libgnunetjson.la \
37 $(top_builddir)/src/transport/libgnunettransport.la \
38 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
39 $(LTLIBINTL) -ljansson -lmicrohttpd
40libgnunet_plugin_rest_peerinfo_la_LDFLAGS = \
41 $(GN_PLUGIN_LDFLAGS)
42
43
22libgnunetpeerinfo_la_SOURCES = \ 44libgnunetpeerinfo_la_SOURCES = \
23 peerinfo_api.c peerinfo.h \ 45 peerinfo_api.c peerinfo.h \
24 peerinfo_api_notify.c 46 peerinfo_api_notify.c