aboutsummaryrefslogtreecommitdiff
path: root/src/peerinfo/Makefile.am
diff options
context:
space:
mode:
authorSchanzenbach, Martin <mschanzenbach@posteo.de>2019-04-03 21:15:27 +0200
committerSchanzenbach, Martin <mschanzenbach@posteo.de>2019-04-03 21:15:27 +0200
commitcd3db61291fd47b5acde1ae3add16c7ccfc2f996 (patch)
tree00135a5868fa8c4bf4e4c12b2f86562b78764d60 /src/peerinfo/Makefile.am
parenta045962087fe78566bb1aa84693071df857a5d9c (diff)
downloadgnunet-cd3db61291fd47b5acde1ae3add16c7ccfc2f996.tar.gz
gnunet-cd3db61291fd47b5acde1ae3add16c7ccfc2f996.zip
fix rest plugin build
Diffstat (limited to 'src/peerinfo/Makefile.am')
-rw-r--r--src/peerinfo/Makefile.am20
1 files changed, 0 insertions, 20 deletions
diff --git a/src/peerinfo/Makefile.am b/src/peerinfo/Makefile.am
index 3c710eb93..d07ed3a5b 100644
--- a/src/peerinfo/Makefile.am
+++ b/src/peerinfo/Makefile.am
@@ -19,28 +19,8 @@ if USE_COVERAGE
19 XLIB = -lgcov 19 XLIB = -lgcov
20endif 20endif
21 21
22if HAVE_MHD
23if HAVE_JSON
24REST_PLUGIN = libgnunet_plugin_rest_peerinfo.la
25endif
26endif
27
28lib_LTLIBRARIES = libgnunetpeerinfo.la 22lib_LTLIBRARIES = libgnunetpeerinfo.la
29 23
30plugin_LTLIBRARIES = $(REST_PLUGIN)
31
32libgnunet_plugin_rest_peerinfo_la_SOURCES = \
33 plugin_rest_peerinfo.c
34libgnunet_plugin_rest_peerinfo_la_LIBADD = \
35 $(top_builddir)/src/hello/libgnunethello.la \
36 libgnunetpeerinfo.la \
37 $(top_builddir)/src/rest/libgnunetrest.la \
38 $(top_builddir)/src/json/libgnunetjson.la \
39 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
40 $(LTLIBINTL) -ljansson -lmicrohttpd
41libgnunet_plugin_rest_peerinfo_la_LDFLAGS = \
42 $(GN_PLUGIN_LDFLAGS)
43
44 24
45libgnunetpeerinfo_la_SOURCES = \ 25libgnunetpeerinfo_la_SOURCES = \
46 peerinfo_api.c peerinfo.h \ 26 peerinfo_api.c peerinfo.h \