aboutsummaryrefslogtreecommitdiff
path: root/src/peerstore/Makefile.am
diff options
context:
space:
mode:
authorOmar Tarabai <tarabai@devegypt.com>2014-04-25 18:00:04 +0000
committerOmar Tarabai <tarabai@devegypt.com>2014-04-25 18:00:04 +0000
commitf5961cc463e301090c16577f2f0cb28ca614d734 (patch)
treed864d47295159e892c5b2a824cdc380e7513a919 /src/peerstore/Makefile.am
parent344f48e48e8d4f1ea631f29d8fb3ae0faf3d7ef0 (diff)
downloadgnunet-f5961cc463e301090c16577f2f0cb28ca614d734.tar.gz
gnunet-f5961cc463e301090c16577f2f0cb28ca614d734.zip
towards PEERSTORE file plugin
Diffstat (limited to 'src/peerstore/Makefile.am')
-rw-r--r--src/peerstore/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/peerstore/Makefile.am b/src/peerstore/Makefile.am
index 0b111cc50..821700b5a 100644
--- a/src/peerstore/Makefile.am
+++ b/src/peerstore/Makefile.am
@@ -1,5 +1,7 @@
1AM_CPPFLAGS = -I$(top_srcdir)/src/include 1AM_CPPFLAGS = -I$(top_srcdir)/src/include
2 2
3plugindir = $(libdir)/gnunet
4
3pkgcfgdir= $(pkgdatadir)/config.d/ 5pkgcfgdir= $(pkgdatadir)/config.d/
4 6
5libexecdir= $(pkglibdir)/libexec/ 7libexecdir= $(pkglibdir)/libexec/
@@ -44,6 +46,21 @@ libgnunetpeerstore_la_LIBADD = \
44libgnunetpeerstore_la_LDFLAGS = \ 46libgnunetpeerstore_la_LDFLAGS = \
45 $(GNUNET_LDFLAGS) 47 $(GNUNET_LDFLAGS)
46 48
49plugin_LTLIBRARIES = \
50 libgnunet_plugin_peerstore_file.la
51
52libgnunet_plugin_peerstore_file_la_SOURCES = \
53 plugin_peerstore_file.c
54libgnunet_plugin_peerstore_file_la_LIBADD = \
55 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \
56 $(top_builddir)/src/util/libgnunetutil.la \
57 $(LTLIBINTL)
58libgnunet_plugin_peerstore_file_la_LDFLAGS = \
59 $(GN_PLUGIN_LDFLAGS)
60libgnunet_plugin_peerstore_file_la_DEPENDENCIES = \
61 $(top_builddir)/src/util/libgnunetutil.la \
62 libgnunetpeerstore.la
63
47check_PROGRAMS = \ 64check_PROGRAMS = \
48 test_peerstore_api 65 test_peerstore_api
49 66