aboutsummaryrefslogtreecommitdiff
path: root/src/peerstore/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <mschanzenbach@posteo.de>2016-05-25 09:54:46 +0000
committerMartin Schanzenbach <mschanzenbach@posteo.de>2016-05-25 09:54:46 +0000
commit0623fdd510f1dacd25f1b8ff592ff6de038c51dc (patch)
treeb97f37a5a523ab6015940e2d279490e1617d7348 /src/peerstore/Makefile.am
parentc651b45f01ccd44defd30f82fd21beb4426fea65 (diff)
downloadgnunet-0623fdd510f1dacd25f1b8ff592ff6de038c51dc.tar.gz
gnunet-0623fdd510f1dacd25f1b8ff592ff6de038c51dc.zip
- add peerstore tests
Diffstat (limited to 'src/peerstore/Makefile.am')
-rw-r--r--src/peerstore/Makefile.am23
1 files changed, 19 insertions, 4 deletions
diff --git a/src/peerstore/Makefile.am b/src/peerstore/Makefile.am
index dbb86553d..a12fdde2a 100644
--- a/src/peerstore/Makefile.am
+++ b/src/peerstore/Makefile.am
@@ -52,8 +52,8 @@ libgnunetpeerstore_la_LDFLAGS = \
52 $(GN_LIB_LDFLAGS) 52 $(GN_LIB_LDFLAGS)
53 53
54if HAVE_EXPERIMENTAL 54if HAVE_EXPERIMENTAL
55 FLAT_PLUGIN = libgnunet_plugin_peerstore_flat.la 55FLAT_PLUGIN = libgnunet_plugin_peerstore_flat.la
56 56FLAT_TESTS = test_plugin_peerstore_flat
57libgnunet_plugin_peerstore_flat_la_SOURCES = \ 57libgnunet_plugin_peerstore_flat_la_SOURCES = \
58 plugin_peerstore_flat.c 58 plugin_peerstore_flat.c
59libgnunet_plugin_peerstore_flat_la_LIBADD = \ 59libgnunet_plugin_peerstore_flat_la_LIBADD = \
@@ -66,7 +66,9 @@ endif
66 66
67if HAVE_SQLITE 67if HAVE_SQLITE
68SQLITE_PLUGIN = libgnunet_plugin_peerstore_sqlite.la 68SQLITE_PLUGIN = libgnunet_plugin_peerstore_sqlite.la
69 69if HAVE_TESTING
70SQLITE_TESTS = test_plugin_peerstore_sqlite
71endif
70libgnunet_plugin_peerstore_sqlite_la_SOURCES = \ 72libgnunet_plugin_peerstore_sqlite_la_SOURCES = \
71 plugin_peerstore_sqlite.c 73 plugin_peerstore_sqlite.c
72libgnunet_plugin_peerstore_sqlite_la_LIBADD = \ 74libgnunet_plugin_peerstore_sqlite_la_LIBADD = \
@@ -81,13 +83,26 @@ plugin_LTLIBRARIES = \
81 $(SQLITE_PLUGIN) \ 83 $(SQLITE_PLUGIN) \
82 $(FLAT_PLUGIN) 84 $(FLAT_PLUGIN)
83 85
86test_plugin_peerstore_sqlite_SOURCES = \
87 test_plugin_peerstore.c
88test_plugin_peerstore_sqlite_LDADD = \
89 $(top_builddir)/src/testing/libgnunettesting.la \
90 $(top_builddir)/src/util/libgnunetutil.la
91
92test_plugin_peerstore_flat_SOURCES = \
93 test_plugin_peerstore.c
94test_plugin_peerstore_flat_LDADD = \
95 $(top_builddir)/src/testing/libgnunettesting.la \
96 $(top_builddir)/src/util/libgnunetutil.la
84 97
85check_PROGRAMS = \ 98check_PROGRAMS = \
86 test_peerstore_api_store \ 99 test_peerstore_api_store \
87 test_peerstore_api_iterate \ 100 test_peerstore_api_iterate \
88 test_peerstore_api_watch \ 101 test_peerstore_api_watch \
89 test_peerstore_api_sync \ 102 test_peerstore_api_sync \
90 perf_peerstore_store 103 perf_peerstore_store \
104 $(SQLITE_TESTS) \
105 $(FLAT_TESTS)
91 106
92EXTRA_DIST = \ 107EXTRA_DIST = \
93 test_peerstore_api_data.conf 108 test_peerstore_api_data.conf