aboutsummaryrefslogtreecommitdiff
path: root/src/psyc/Makefile.am
diff options
context:
space:
mode:
authorGabor X Toth <*@tg-x.net>2013-09-16 16:46:43 +0000
committerGabor X Toth <*@tg-x.net>2013-09-16 16:46:43 +0000
commit4839fff11f31cac9af0cfbe1d67b6961d5f1b88f (patch)
tree2ccae35bf637e1bec185656f8c25b2693d0a29d4 /src/psyc/Makefile.am
parent2745a5145a07c6effa7075391fb9ea74288ec83a (diff)
downloadgnunet-4839fff11f31cac9af0cfbe1d67b6961d5f1b88f.tar.gz
gnunet-4839fff11f31cac9af0cfbe1d67b6961d5f1b88f.zip
psyc service skeleton
Diffstat (limited to 'src/psyc/Makefile.am')
-rw-r--r--src/psyc/Makefile.am71
1 files changed, 71 insertions, 0 deletions
diff --git a/src/psyc/Makefile.am b/src/psyc/Makefile.am
new file mode 100644
index 000000000..b65f9ec7a
--- /dev/null
+++ b/src/psyc/Makefile.am
@@ -0,0 +1,71 @@
1AM_CPPFLAGS = -I$(top_srcdir)/src/include
2
3pkgcfgdir= $(pkgdatadir)/config.d/
4
5libexecdir= $(pkglibdir)/libexec/
6
7pkgcfg_DATA = \
8 psyc.conf
9
10
11if MINGW
12 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
13endif
14
15if USE_COVERAGE
16 AM_CFLAGS = --coverage -O0
17 XLIB = -lgcov
18endif
19
20lib_LTLIBRARIES = libgnunetpsyc.la
21
22libgnunetpsyc_la_SOURCES = \
23 psyc_api.c \
24 psyc.h
25libgnunetpsyc_la_LIBADD = \
26 $(top_builddir)/src/util/libgnunetutil.la \
27 $(GN_LIBINTL) $(XLIB)
28libgnunetpsyc_la_LDFLAGS = \
29 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
30 -version-info 0:0:0
31libgnunetpsyc_la_DEPENDENCIES = \
32 $(top_builddir)/src/util/libgnunetutil.la
33
34bin_PROGRAMS =
35
36libexec_PROGRAMS = \
37 gnunet-service-psyc
38
39gnunet_service_psyc_SOURCES = \
40 gnunet-service-psyc.c
41gnunet_service_psyc_LDADD = \
42 $(top_builddir)/src/statistics/libgnunetstatistics.la \
43 $(top_builddir)/src/util/libgnunetutil.la \
44 $(GN_LIBINTL)
45gnunet_service_psyc_DEPENDENCIES = \
46 $(top_builddir)/src/statistics/libgnunetstatistics.la \
47 $(top_builddir)/src/util/libgnunetutil.la
48
49
50if HAVE_TESTING
51check_PROGRAMS = \
52 test_psyc
53endif
54
55if ENABLE_TEST_RUN
56TESTS = $(check_PROGRAMS)
57endif
58
59test_psyc_SOURCES = \
60 test_psyc.c
61test_psyc_LDADD = \
62 libgnunetpsyc.la \
63 $(top_builddir)/src/testing/libgnunettesting.la \
64 $(top_builddir)/src/util/libgnunetutil.la
65test_psyc_DEPENDENCIES = \
66 libgnunetpsyc.la \
67 $(top_builddir)/src/testing/libgnunettesting.la \
68 $(top_builddir)/src/util/libgnunetutil.la
69
70EXTRA_DIST = \
71 test_psyc.conf