aboutsummaryrefslogtreecommitdiff
path: root/src/psyc/Makefile.am
diff options
context:
space:
mode:
authorGabor X Toth <*@tg-x.net>2014-03-06 23:46:45 +0000
committerGabor X Toth <*@tg-x.net>2014-03-06 23:46:45 +0000
commit8a0b8a4604526e5f832c4971f9c3b1b48d79bea4 (patch)
treedfd18a61272a18381fe9ce9b09849a965480a303 /src/psyc/Makefile.am
parenta21beab58c1d2abc747359a98326f19aaad4e8cd (diff)
downloadgnunet-8a0b8a4604526e5f832c4971f9c3b1b48d79bea4.tar.gz
gnunet-8a0b8a4604526e5f832c4971f9c3b1b48d79bea4.zip
PSYC: implement slave to master requests, tests, fixes, reorg
Multicast lib: handle member to origin requests. Keep track of members and origins and call their callbacks when necessary.
Diffstat (limited to 'src/psyc/Makefile.am')
-rw-r--r--src/psyc/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/psyc/Makefile.am b/src/psyc/Makefile.am
index 7860b3995..162b42b2b 100644
--- a/src/psyc/Makefile.am
+++ b/src/psyc/Makefile.am
@@ -21,7 +21,7 @@ lib_LTLIBRARIES = libgnunetpsyc.la
21 21
22libgnunetpsyc_la_SOURCES = \ 22libgnunetpsyc_la_SOURCES = \
23 psyc_api.c \ 23 psyc_api.c \
24 psyc.h 24 psyc_common.c
25libgnunetpsyc_la_LIBADD = \ 25libgnunetpsyc_la_LIBADD = \
26 $(top_builddir)/src/util/libgnunetutil.la \ 26 $(top_builddir)/src/util/libgnunetutil.la \
27 $(top_builddir)/src/env/libgnunetenv.la \ 27 $(top_builddir)/src/env/libgnunetenv.la \
@@ -39,7 +39,8 @@ libexec_PROGRAMS = \
39 gnunet-service-psyc 39 gnunet-service-psyc
40 40
41gnunet_service_psyc_SOURCES = \ 41gnunet_service_psyc_SOURCES = \
42 gnunet-service-psyc.c 42 gnunet-service-psyc.c \
43 psyc_common.c
43gnunet_service_psyc_LDADD = \ 44gnunet_service_psyc_LDADD = \
44 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 45 $(top_builddir)/src/statistics/libgnunetstatistics.la \
45 $(top_builddir)/src/util/libgnunetutil.la \ 46 $(top_builddir)/src/util/libgnunetutil.la \
@@ -51,6 +52,7 @@ gnunet_service_psyc_DEPENDENCIES = \
51 $(top_builddir)/src/util/libgnunetutil.la \ 52 $(top_builddir)/src/util/libgnunetutil.la \
52 $(top_builddir)/src/multicast/libgnunetmulticast.la \ 53 $(top_builddir)/src/multicast/libgnunetmulticast.la \
53 $(top_builddir)/src/psycstore/libgnunetpsycstore.la 54 $(top_builddir)/src/psycstore/libgnunetpsycstore.la
55gnunet_service_psyc_CFLAGS = $(AM_CFLAGS)
54 56
55 57
56if HAVE_TESTING 58if HAVE_TESTING