summaryrefslogtreecommitdiff
path: root/src/psycstore/Makefile.am
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2016-09-30 01:59:49 +0000
committerDaniel Golle <daniel@makrotopia.org>2016-09-30 01:59:49 +0000
commit8ceb8babcaf90a1574e784045cbce2d804973849 (patch)
treecc099eb6afbd760892b40af3b5c14d72a74d92c7 /src/psycstore/Makefile.am
parentcd9b18db5c906675a904e67d0ee865ac40c1324f (diff)
downloadgnunet-8ceb8babcaf90a1574e784045cbce2d804973849.tar.gz
gnunet-8ceb8babcaf90a1574e784045cbce2d804973849.zip
psycstore: add postgres database plugin
botched up based on mysql plugin. still mostly untested...
Diffstat (limited to 'src/psycstore/Makefile.am')
-rw-r--r--src/psycstore/Makefile.am29
1 files changed, 28 insertions, 1 deletions
diff --git a/src/psycstore/Makefile.am b/src/psycstore/Makefile.am
index 4da0a89d8..30e2a9673 100644
--- a/src/psycstore/Makefile.am
+++ b/src/psycstore/Makefile.am
@@ -27,6 +27,13 @@ MYSQL_TESTS = test_plugin_psycstore_mysql
27endif 27endif
28endif 28endif
29 29
30if HAVE_POSTGRESQL
31POSTGRES_PLUGIN = libgnunet_plugin_psycstore_postgres.la
32if HAVE_TESTING
33POSTGRES_TESTS = test_plugin_psycstore_postgres
34endif
35endif
36
30if HAVE_SQLITE 37if HAVE_SQLITE
31SQLITE_PLUGIN = libgnunet_plugin_psycstore_sqlite.la 38SQLITE_PLUGIN = libgnunet_plugin_psycstore_sqlite.la
32if HAVE_TESTING 39if HAVE_TESTING
@@ -61,7 +68,9 @@ gnunet_service_psycstore_LDADD = \
61 68
62plugin_LTLIBRARIES = \ 69plugin_LTLIBRARIES = \
63 $(SQLITE_PLUGIN) \ 70 $(SQLITE_PLUGIN) \
64 $(MYSQL_PLUGIN) 71 $(MYSQL_PLUGIN) \
72 $(POSTGRES_PLUGIN)
73
65 74
66libgnunet_plugin_psycstore_mysql_la_SOURCES = \ 75libgnunet_plugin_psycstore_mysql_la_SOURCES = \
67 plugin_psycstore_mysql.c 76 plugin_psycstore_mysql.c
@@ -75,6 +84,17 @@ libgnunet_plugin_psycstore_mysql_la_LIBADD = \
75libgnunet_plugin_psycstore_mysql_la_LDFLAGS = \ 84libgnunet_plugin_psycstore_mysql_la_LDFLAGS = \
76 $(GN_PLUGIN_LDFLAGS) 85 $(GN_PLUGIN_LDFLAGS)
77 86
87libgnunet_plugin_psycstore_postgres_la_SOURCES = \
88 plugin_psycstore_postgres.c
89libgnunet_plugin_psycstore_postgres_la_LIBADD = \
90 libgnunetpsycstore.la \
91 $(top_builddir)/src/postgres/libgnunetpostgres.la \
92 $(top_builddir)/src/pq/libgnunetpq.la \
93 $(top_builddir)/src/statistics/libgnunetstatistics.la \
94 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lpq \
95 $(LTLIBINTL)
96libgnunet_plugin_psycstore_postgres_la_LDFLAGS = \
97 $(GN_PLUGIN_LDFLAGS) $(POSTGRESQL_LDFLAGS)
78 98
79libgnunet_plugin_psycstore_sqlite_la_SOURCES = \ 99libgnunet_plugin_psycstore_sqlite_la_SOURCES = \
80 plugin_psycstore_sqlite.c 100 plugin_psycstore_sqlite.c
@@ -92,6 +112,7 @@ if HAVE_TESTING
92check_PROGRAMS = \ 112check_PROGRAMS = \
93 $(SQLITE_TESTS) \ 113 $(SQLITE_TESTS) \
94 $(MYSQL_TESTS) \ 114 $(MYSQL_TESTS) \
115 $(POSTGRES_TESTS) \
95 test_psycstore 116 test_psycstore
96endif 117endif
97endif 118endif
@@ -124,3 +145,9 @@ test_plugin_psycstore_mysql_LDADD = \
124 $(top_builddir)/src/testing/libgnunettesting.la \ 145 $(top_builddir)/src/testing/libgnunettesting.la \
125 $(top_builddir)/src/util/libgnunetutil.la 146 $(top_builddir)/src/util/libgnunetutil.la
126 147
148test_plugin_psycstore_postgres_SOURCES = \
149 test_plugin_psycstore.c
150test_plugin_psycstore_postgres_LDADD = \
151 $(top_builddir)/src/testing/libgnunettesting.la \
152 $(top_builddir)/src/util/libgnunetutil.la
153