aboutsummaryrefslogtreecommitdiff
path: root/src/pt/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <mschanzenbach@posteo.de>2012-06-27 10:26:20 +0000
committerMartin Schanzenbach <mschanzenbach@posteo.de>2012-06-27 10:26:20 +0000
commitf68e5cda5acb6f39abaaeec839cb7e7cf2b77053 (patch)
tree82a9eb484330322585b067191e4c823ce8fef955 /src/pt/Makefile.am
parentb7daa03785d09510b3f36d4e6bbab37b005c3619 (diff)
downloadgnunet-f68e5cda5acb6f39abaaeec839cb7e7cf2b77053.tar.gz
gnunet-f68e5cda5acb6f39abaaeec839cb7e7cf2b77053.zip
-fix order
Diffstat (limited to 'src/pt/Makefile.am')
-rw-r--r--src/pt/Makefile.am66
1 files changed, 66 insertions, 0 deletions
diff --git a/src/pt/Makefile.am b/src/pt/Makefile.am
index 385bff672..af2817bf9 100644
--- a/src/pt/Makefile.am
+++ b/src/pt/Makefile.am
@@ -29,3 +29,69 @@ gnunet_daemon_pt_LDADD = \
29 $(top_builddir)/src/util/libgnunetutil.la \ 29 $(top_builddir)/src/util/libgnunetutil.la \
30 $(top_builddir)/src/mesh/libgnunetmesh.la \ 30 $(top_builddir)/src/mesh/libgnunetmesh.la \
31 $(GN_LIBINTL) 31 $(GN_LIBINTL)
32
33check_PROGRAMS = $(VPN_TEST)
34
35if ENABLE_TEST_RUN
36TESTS = $(check_PROGRAMS)
37endif
38
39EXTRA_DIST = \
40 test_gnunet_vpn.conf \
41 test_gns_vpn.conf
42
43if HAVE_MHD
44 VPN_TEST = \
45 test_gnunet_vpn-4_to_6 \
46 test_gnunet_vpn-6_to_4 \
47 test_gnunet_vpn-6_over \
48 test_gnunet_vpn-4_over \
49 test_gns_vpn
50endif
51
52
53test_gns_vpn_SOURCES = \
54 test_gns_vpn.c
55test_gns_vpn_LDADD = -lmicrohttpd @LIBCURL@ \
56 $(top_builddir)/src/namestore/libgnunetnamestore.la \
57 $(top_builddir)/src/testing/libgnunettesting.la \
58 $(top_builddir)/src/util/libgnunetutil.la
59test_gnunet_vpn_4_over_CPPFLAGS = \
60 @LIBCURL_CPPFLAGS@
61
62test_gnunet_vpn_4_over_SOURCES = \
63 test_gnunet_vpn.c
64test_gnunet_vpn_4_over_LDADD = -lmicrohttpd @LIBCURL@ \
65 $(top_builddir)/src/vpn/libgnunetvpn.la \
66 $(top_builddir)/src/testing/libgnunettesting.la \
67 $(top_builddir)/src/util/libgnunetutil.la
68test_gnunet_vpn_4_over_CPPFLAGS = \
69 @LIBCURL_CPPFLAGS@
70
71test_gnunet_vpn_6_over_SOURCES = \
72 test_gnunet_vpn.c
73test_gnunet_vpn_6_over_LDADD = -lmicrohttpd @LIBCURL@ \
74 $(top_builddir)/src/vpn/libgnunetvpn.la \
75 $(top_builddir)/src/testing/libgnunettesting.la \
76 $(top_builddir)/src/util/libgnunetutil.la
77test_gnunet_vpn_6_over_CPPFLAGS = \
78 @LIBCURL_CPPFLAGS@
79
80test_gnunet_vpn_4_to_6_SOURCES = \
81 test_gnunet_vpn.c
82test_gnunet_vpn_4_to_6_LDADD = -lmicrohttpd @LIBCURL@ \
83 $(top_builddir)/src/vpn/libgnunetvpn.la \
84 $(top_builddir)/src/testing/libgnunettesting.la \
85 $(top_builddir)/src/util/libgnunetutil.la
86test_gnunet_vpn_4_to_6_CPPFLAGS = \
87 @LIBCURL_CPPFLAGS@
88
89test_gnunet_vpn_6_to_4_SOURCES = \
90 test_gnunet_vpn.c
91test_gnunet_vpn_6_to_4_LDADD = -lmicrohttpd @LIBCURL@ \
92 $(top_builddir)/src/vpn/libgnunetvpn.la \
93 $(top_builddir)/src/testing/libgnunettesting.la \
94 $(top_builddir)/src/util/libgnunetutil.la
95test_gnunet_vpn_6_to_4_CPPFLAGS = \
96 @LIBCURL_CPPFLAGS@
97