aboutsummaryrefslogtreecommitdiff
path: root/src/regex/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-06-20 08:32:50 +0000
committerChristian Grothoff <christian@grothoff.org>2013-06-20 08:32:50 +0000
commit21a2b4f95b4488645ba5a6254fcb8919c4915f73 (patch)
tree00c92cb7103cc14fba7e63e8dee99fe711856863 /src/regex/Makefile.am
parent5533b105943b4f6dd688c1758350cd83ebeab3b9 (diff)
downloadgnunet-21a2b4f95b4488645ba5a6254fcb8919c4915f73.tar.gz
gnunet-21a2b4f95b4488645ba5a6254fcb8919c4915f73.zip
continuing refactoring of regex library structure, disambiguating symbol names between old regex library which is now internal and the public API; moving IP-to-regex conversion functions to tun library, as only vpn is using those to begin with
Diffstat (limited to 'src/regex/Makefile.am')
-rw-r--r--src/regex/Makefile.am104
1 files changed, 48 insertions, 56 deletions
diff --git a/src/regex/Makefile.am b/src/regex/Makefile.am
index cbd66fa1d..6e6fd443a 100644
--- a/src/regex/Makefile.am
+++ b/src/regex/Makefile.am
@@ -22,21 +22,24 @@ libexec_PROGRAMS = \
22 22
23gnunet_service_regex_SOURCES = \ 23gnunet_service_regex_SOURCES = \
24 gnunet-service-regex.c 24 gnunet-service-regex.c
25gnunet_service_regex_LDADD = \ 25gnunet_service_regex_LDADD = -lm \
26 $(top_builddir)/src/regex/libgnunetregex.la \ 26 $(top_builddir)/src/regex/libgnunetregex_internal.a \
27 $(top_builddir)/src/regex/libgnunetregexblock.la \
27 $(top_builddir)/src/dht/libgnunetdht.la \ 28 $(top_builddir)/src/dht/libgnunetdht.la \
28 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 29 $(top_builddir)/src/statistics/libgnunetstatistics.la \
29 $(top_builddir)/src/util/libgnunetutil.la \ 30 $(top_builddir)/src/util/libgnunetutil.la \
30 $(GN_LIBINTL) 31 $(GN_LIBINTL)
31gnunet_service_regex_DEPENDENCIES = \ 32gnunet_service_regex_DEPENDENCIES = \
32 libgnunetregex.la 33 libgnunetregex_internal.a
33# todo: link files from libgnunetregex statically into gnunet_service_regex, 34# todo: link files from libgnunetregex statically into gnunet_service_regex,
34# rename API prefix to avoid collision with 'libgnunetregexnew'... 35# rename API prefix to avoid collision with 'libgnunetregexnew'...
35 36
37noinst_LIBRARIES = \
38 libgnunetregex_internal.a \
39 libgnunetregextest.a
36 40
37lib_LTLIBRARIES = \ 41lib_LTLIBRARIES = \
38 libgnunetregexblock.la \ 42 libgnunetregexblock.la \
39 libgnunetregex.la \
40 libgnunetregexnew.la 43 libgnunetregexnew.la
41 44
42 45
@@ -50,20 +53,13 @@ libgnunetregexblock_la_LDFLAGS = \
50 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 53 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
51 -version-info 1:0:0 54 -version-info 1:0:0
52 55
53libgnunetregex_la_SOURCES = \ 56
57libgnunetregex_internal_a_SOURCES = \
54 regex_internal.h regex.c \ 58 regex_internal.h regex.c \
55 regex_graph.c regex_random.c \ 59 regex_graph.c regex_random.c \
56 regex_dht.c 60 regex_dht.c
57libgnunetregex_la_LIBADD = -lm \ 61libgnunetregex_internal_a_DEPENDENCIES = \
58 $(top_builddir)/src/util/libgnunetutil.la \
59 $(top_builddir)/src/dht/libgnunetdht.la \
60 $(top_builddir)/src/statistics/libgnunetstatistics.la \
61 $(top_builddir)/src/regex/libgnunetregexblock.la
62libgnunetregex_la_DEPENDENCIES = \
63 libgnunetregexblock.la 62 libgnunetregexblock.la
64libgnunetregex_la_LDFLAGS = \
65 $(GN_LIB_LDFLAGS) \
66 -version-info 2:0:1
67 63
68 64
69libgnunetregexnew_la_SOURCES = \ 65libgnunetregexnew_la_SOURCES = \
@@ -75,8 +71,6 @@ libgnunetregexnew_la_LDFLAGS = \
75 -version-info 3:0:0 71 -version-info 3:0:0
76 72
77 73
78plugindir = $(libdir)/gnunet
79
80plugin_LTLIBRARIES = \ 74plugin_LTLIBRARIES = \
81 libgnunet_plugin_block_regex.la 75 libgnunet_plugin_block_regex.la
82 76
@@ -99,21 +93,19 @@ gnunet_regex_simulation_profiler_SOURCES = \
99 gnunet-regex-simulation-profiler.c 93 gnunet-regex-simulation-profiler.c
100gnunet_regex_simulation_profiler_LDADD = \ 94gnunet_regex_simulation_profiler_LDADD = \
101 $(top_builddir)/src/util/libgnunetutil.la \ 95 $(top_builddir)/src/util/libgnunetutil.la \
102 $(top_builddir)/src/regex/libgnunetregex.la \ 96 $(top_builddir)/src/regex/libgnunetregex_internal.a \
103 $(top_builddir)/src/mysql/libgnunetmysql.la 97 $(top_builddir)/src/mysql/libgnunetmysql.la
104gnunet_regex_simulation_profiler_DEPENDENCIES = \ 98gnunet_regex_simulation_profiler_DEPENDENCIES = \
105 libgnunetregex.la 99 libgnunetregex_internal.a
106endif 100endif
107 101
108noinst_LTLIBRARIES = libgnunetregextest.la 102libgnunetregextest_a_SOURCES = \
109
110libgnunetregextest_la_SOURCES = \
111 regex_test_lib.c regex_test_lib.h 103 regex_test_lib.c regex_test_lib.h
112libgnunetregextest_la_LIBADD = \ 104libgnunetregextest_a_LIBADD = \
113 $(top_builddir)/src/util/libgnunetutil.la \ 105 $(top_builddir)/src/util/libgnunetutil.la \
114 $(top_builddir)/src/regex/libgnunetregex.la 106 $(top_builddir)/src/regex/libgnunetregex_internal.a
115libgnunetregextest_la_DEPENDENCIES = \ 107libgnunetregextest_a_DEPENDENCIES = \
116 libgnunetregex.la 108 libgnunetregex_internal.a
117 109
118 110
119noinst_PROGRAMS = $(noinst_mysql_progs) \ 111noinst_PROGRAMS = $(noinst_mysql_progs) \
@@ -123,43 +115,46 @@ noinst_PROGRAMS = $(noinst_mysql_progs) \
123 115
124perf_regex_SOURCES = \ 116perf_regex_SOURCES = \
125 perf-regex.c 117 perf-regex.c
126perf_regex_LDADD = \ 118perf_regex_LDADD = -lm \
127 $(top_builddir)/src/util/libgnunetutil.la \ 119 $(top_builddir)/src/util/libgnunetutil.la \
128 $(top_builddir)/src/regex/libgnunetregex.la \ 120 $(top_builddir)/src/regex/libgnunetregex_internal.a \
129 $(top_builddir)/src/regex/libgnunetregextest.la 121 $(top_builddir)/src/regex/libgnunetregexblock.la \
122 $(top_builddir)/src/regex/libgnunetregextest.a
130perf_regex_DEPENDENCIES = \ 123perf_regex_DEPENDENCIES = \
131 libgnunetregex.la \ 124 libgnunetregex_internal.a \
132 libgnunetregextest.la 125 libgnunetregextest.a
133 126
134gnunet_regex_profiler_SOURCES = \ 127gnunet_regex_profiler_SOURCES = \
135 gnunet-regex-profiler.c 128 gnunet-regex-profiler.c
136gnunet_regex_profiler_LDADD = \ 129gnunet_regex_profiler_LDADD = -lm \
137 $(top_builddir)/src/util/libgnunetutil.la \ 130 $(top_builddir)/src/util/libgnunetutil.la \
138 $(top_builddir)/src/arm/libgnunetarm.la \ 131 $(top_builddir)/src/arm/libgnunetarm.la \
139 $(top_builddir)/src/dht/libgnunetdht.la \ 132 $(top_builddir)/src/dht/libgnunetdht.la \
140 $(top_builddir)/src/testbed/libgnunettestbed.la \ 133 $(top_builddir)/src/testbed/libgnunettestbed.la \
141 $(top_builddir)/src/regex/libgnunetregex.la \ 134 $(top_builddir)/src/regex/libgnunetregex_internal.a \
142 $(top_builddir)/src/regex/libgnunetregextest.la \ 135 $(top_builddir)/src/regex/libgnunetregexblock.la \
136 $(top_builddir)/src/regex/libgnunetregextest.a \
143 $(top_builddir)/src/statistics/libgnunetstatistics.la 137 $(top_builddir)/src/statistics/libgnunetstatistics.la
144gnunet_regex_profiler_DEPENDENCIES = \ 138gnunet_regex_profiler_DEPENDENCIES = \
145 $(top_builddir)/src/arm/libgnunetarm.la \ 139 $(top_builddir)/src/arm/libgnunetarm.la \
146 $(top_builddir)/src/dht/libgnunetdht.la \ 140 $(top_builddir)/src/dht/libgnunetdht.la \
147 libgnunetregex.la \ 141 libgnunetregex_internal.a \
148 libgnunetregextest.la 142 libgnunetregextest.a
149 143
150 144
151gnunet_daemon_regexprofiler_SOURCES = \ 145gnunet_daemon_regexprofiler_SOURCES = \
152 gnunet-daemon-regexprofiler.c 146 gnunet-daemon-regexprofiler.c
153gnunet_daemon_regexprofiler_LDADD = \ 147gnunet_daemon_regexprofiler_LDADD = -lm \
154 $(top_builddir)/src/util/libgnunetutil.la \ 148 $(top_builddir)/src/util/libgnunetutil.la \
155 $(top_builddir)/src/dht/libgnunetdht.la \ 149 $(top_builddir)/src/dht/libgnunetdht.la \
156 $(top_builddir)/src/regex/libgnunetregex.la \ 150 $(top_builddir)/src/regex/libgnunetregex_internal.a \
157 $(top_builddir)/src/regex/libgnunetregextest.la \ 151 $(top_builddir)/src/regex/libgnunetregexblock.la \
152 $(top_builddir)/src/regex/libgnunetregextest.a \
158 $(top_builddir)/src/statistics/libgnunetstatistics.la 153 $(top_builddir)/src/statistics/libgnunetstatistics.la
159gnunet_daemon_regexprofiler_DEPENDENCIES = \ 154gnunet_daemon_regexprofiler_DEPENDENCIES = \
160 $(top_builddir)/src/dht/libgnunetdht.la \ 155 $(top_builddir)/src/dht/libgnunetdht.la \
161 libgnunetregextest.la \ 156 libgnunetregextest.a \
162 libgnunetregex.la 157 libgnunetregex_internal.a
163 158
164 159
165 160
@@ -167,8 +162,7 @@ check_PROGRAMS = \
167 test_regex_eval_api \ 162 test_regex_eval_api \
168 test_regex_iterate_api \ 163 test_regex_iterate_api \
169 test_regex_proofs \ 164 test_regex_proofs \
170 test_regex_graph_api \ 165 test_regex_graph_api
171 test_regex_iptoregex
172 166
173if ENABLE_TEST_RUN 167if ENABLE_TEST_RUN
174 TESTS = $(check_PROGRAMS) 168 TESTS = $(check_PROGRAMS)
@@ -176,34 +170,32 @@ endif
176 170
177test_regex_eval_api_SOURCES = \ 171test_regex_eval_api_SOURCES = \
178 test_regex_eval_api.c 172 test_regex_eval_api.c
179test_regex_eval_api_LDADD = \ 173test_regex_eval_api_LDADD = -lm \
180 $(top_builddir)/src/regex/libgnunetregex.la \ 174 $(top_builddir)/src/regex/libgnunetregex_internal.a \
175 $(top_builddir)/src/regex/libgnunetregexblock.la \
181 $(top_builddir)/src/util/libgnunetutil.la 176 $(top_builddir)/src/util/libgnunetutil.la
182 177
183test_regex_iterate_api_SOURCES = \ 178test_regex_iterate_api_SOURCES = \
184 test_regex_iterate_api.c 179 test_regex_iterate_api.c
185test_regex_iterate_api_LDADD = \ 180test_regex_iterate_api_LDADD = -lm \
186 $(top_builddir)/src/regex/libgnunetregex.la \ 181 $(top_builddir)/src/regex/libgnunetregex_internal.a \
182 $(top_builddir)/src/regex/libgnunetregexblock.la \
187 $(top_builddir)/src/util/libgnunetutil.la 183 $(top_builddir)/src/util/libgnunetutil.la
188 184
189test_regex_proofs_SOURCES = \ 185test_regex_proofs_SOURCES = \
190 test_regex_proofs.c 186 test_regex_proofs.c
191test_regex_proofs_LDADD = \ 187test_regex_proofs_LDADD = -lm \
192 $(top_builddir)/src/regex/libgnunetregex.la \ 188 $(top_builddir)/src/regex/libgnunetregex_internal.a \
189 $(top_builddir)/src/regex/libgnunetregexblock.la \
193 $(top_builddir)/src/util/libgnunetutil.la 190 $(top_builddir)/src/util/libgnunetutil.la
194 191
195test_regex_graph_api_SOURCES = \ 192test_regex_graph_api_SOURCES = \
196 test_regex_graph_api.c 193 test_regex_graph_api.c
197test_regex_graph_api_LDADD = \ 194test_regex_graph_api_LDADD = -lm \
198 $(top_builddir)/src/regex/libgnunetregex.la \ 195 $(top_builddir)/src/regex/libgnunetregex_internal.a \
196 $(top_builddir)/src/regex/libgnunetregexblock.la \
199 $(top_builddir)/src/util/libgnunetutil.la 197 $(top_builddir)/src/util/libgnunetutil.la
200 198
201test_regex_iptoregex_SOURCES = \
202 test_regex_iptoregex.c
203test_regex_iptoregex_LDADD = \
204 $(top_builddir)/src/util/libgnunetutil.la \
205 $(top_builddir)/src/regex/libgnunetregex.la
206
207 199
208EXTRA_DIST = \ 200EXTRA_DIST = \
209 regex_simulation_profiler_test.conf 201 regex_simulation_profiler_test.conf