aboutsummaryrefslogtreecommitdiff
path: root/src/regex/Makefile.am
diff options
context:
space:
mode:
authorBart Polot <bart@net.in.tum.de>2012-09-28 10:08:46 +0000
committerBart Polot <bart@net.in.tum.de>2012-09-28 10:08:46 +0000
commit621528a6cecd405813525b0d44479fea1e2ef479 (patch)
treefc3981458e6d069713725357ccf3ce0f3989cc49 /src/regex/Makefile.am
parentb764304d2ebf70d837e0636e3c34cd172285110f (diff)
downloadgnunet-621528a6cecd405813525b0d44479fea1e2ef479.tar.gz
gnunet-621528a6cecd405813525b0d44479fea1e2ef479.zip
- Big regex testcase
Diffstat (limited to 'src/regex/Makefile.am')
-rw-r--r--src/regex/Makefile.am18
1 files changed, 16 insertions, 2 deletions
diff --git a/src/regex/Makefile.am b/src/regex/Makefile.am
index ca7e52265..40bf01a73 100644
--- a/src/regex/Makefile.am
+++ b/src/regex/Makefile.am
@@ -24,10 +24,16 @@ check_PROGRAMS = \
24 test_regex_iterate_api \ 24 test_regex_iterate_api \
25 test_regex_proofs \ 25 test_regex_proofs \
26 test_regex_graph_api \ 26 test_regex_graph_api \
27 test_regex_iptoregex 27 test_regex_iptoregex \
28 test_regex_big
29
28 30
29if ENABLE_TEST_RUN 31if ENABLE_TEST_RUN
30TESTS = $(check_PROGRAMS) 32TESTS = \
33 test_regex_eval_api \
34 test_regex_iterate_api \
35 test_regex_proofs \
36 test_regex_graph_api
31endif 37endif
32 38
33test_regex_eval_api_SOURCES = \ 39test_regex_eval_api_SOURCES = \
@@ -54,10 +60,18 @@ test_regex_graph_api_LDADD = \
54$(top_builddir)/src/regex/libgnunetregex.la \ 60$(top_builddir)/src/regex/libgnunetregex.la \
55$(top_builddir)/src/util/libgnunetutil.la 61$(top_builddir)/src/util/libgnunetutil.la
56 62
63test_regex_big_SOURCES = \
64test_regex_big.c
65test_regex_big_LDADD = \
66 $(top_builddir)/src/regex/libgnunetregex.la \
67 $(top_builddir)/src/util/libgnunetutil.la \
68 $(top_builddir)/src/testbed/libgnunettestbed.la
69
57test_regex_iptoregex_SOURCES = \ 70test_regex_iptoregex_SOURCES = \
58test_regex_iptoregex.c 71test_regex_iptoregex.c
59test_regex_iptoregex_LDADD = \ 72test_regex_iptoregex_LDADD = \
60$(top_builddir)/src/regex/libgnunetregex.la 73$(top_builddir)/src/regex/libgnunetregex.la
61 74
75
62EXTRA_DIST = 76EXTRA_DIST =
63# test_regex_data.conf 77# test_regex_data.conf