aboutsummaryrefslogtreecommitdiff
path: root/src/regex/Makefile.am
diff options
context:
space:
mode:
authorMaximilian Szengel <gnunet@maxsz.de>2012-10-26 14:33:59 +0000
committerMaximilian Szengel <gnunet@maxsz.de>2012-10-26 14:33:59 +0000
commit7a741b2fa8c96076f8b05a2d08e4b6b3ba78360b (patch)
treebd6c9d2d20fe9fb8f405075e929b3056cdd67736 /src/regex/Makefile.am
parent993a74c191842519ad6c82216fb7a0ee2bb09456 (diff)
downloadgnunet-7a741b2fa8c96076f8b05a2d08e4b6b3ba78360b.tar.gz
gnunet-7a741b2fa8c96076f8b05a2d08e4b6b3ba78360b.zip
- Added path compression parameter to DFA construction API
- Moved NFA construction to internal header - Added regex simulation profiler (for profiling the NFA, that results by merging several DFAs in the DHT, in a database)
Diffstat (limited to 'src/regex/Makefile.am')
-rw-r--r--src/regex/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/regex/Makefile.am b/src/regex/Makefile.am
index 212e2ffcd..fe882a1e9 100644
--- a/src/regex/Makefile.am
+++ b/src/regex/Makefile.am
@@ -19,6 +19,20 @@ libgnunetregex_la_LDFLAGS = \
19 $(GN_LIB_LDFLAGS) \ 19 $(GN_LIB_LDFLAGS) \
20 -version-info 0:0:0 20 -version-info 0:0:0
21 21
22if HAVE_MYSQL
23noinst_PROGRAMS = \
24gnunet-regex-simulation-profiler
25
26gnunet_regex_simulation_profiler_SOURCES = \
27 gnunet-regex-simulation-profiler.c
28gnunet_regex_simulation_profiler_LDADD = \
29 $(top_builddir)/src/util/libgnunetutil.la \
30 $(top_builddir)/src/regex/libgnunetregex.la \
31 $(top_builddir)/src/mysql/libgnunetmysql.la
32gnunet_regex_simulation_profiler_DEPENDENCIES = \
33 libgnunetregex.la
34endif
35
22check_PROGRAMS = \ 36check_PROGRAMS = \
23 test_regex_eval_api \ 37 test_regex_eval_api \
24 test_regex_iterate_api \ 38 test_regex_iterate_api \