aboutsummaryrefslogtreecommitdiff
path: root/src/regex/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-07-02 14:38:54 +0000
committerChristian Grothoff <christian@grothoff.org>2013-07-02 14:38:54 +0000
commit15a8471c0edc4134f57c19884c033a63f49a04dd (patch)
tree4465bb0b1198f1869163706e6cfeeaba5ff3fabf /src/regex/Makefile.am
parent2a453cf6aec60af36f655bd053847ab15ff7ae8f (diff)
downloadgnunet-15a8471c0edc4134f57c19884c033a63f49a04dd.tar.gz
gnunet-15a8471c0edc4134f57c19884c033a63f49a04dd.zip
-implementing regex test
Diffstat (limited to 'src/regex/Makefile.am')
-rw-r--r--src/regex/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/src/regex/Makefile.am b/src/regex/Makefile.am
index b09413565..ba3b8f78d 100644
--- a/src/regex/Makefile.am
+++ b/src/regex/Makefile.am
@@ -165,7 +165,8 @@ check_PROGRAMS = \
165 test_regex_eval_api \ 165 test_regex_eval_api \
166 test_regex_iterate_api \ 166 test_regex_iterate_api \
167 test_regex_proofs \ 167 test_regex_proofs \
168 test_regex_graph_api 168 test_regex_graph_api \
169 test_regex_api
169 170
170if ENABLE_TEST_RUN 171if ENABLE_TEST_RUN
171 TESTS = $(check_PROGRAMS) 172 TESTS = $(check_PROGRAMS)
@@ -180,6 +181,13 @@ test_regex_eval_api_LDADD = -lm \
180 $(top_builddir)/src/regex/libgnunetregexblock.la \ 181 $(top_builddir)/src/regex/libgnunetregexblock.la \
181 $(top_builddir)/src/util/libgnunetutil.la 182 $(top_builddir)/src/util/libgnunetutil.la
182 183
184test_regex_api_SOURCES = \
185 test_regex_api.c
186test_regex_api_LDADD = -lm \
187 $(top_builddir)/src/regex/libgnunetregex.la \
188 $(top_builddir)/src/testing/libgnunettesting.la \
189 $(top_builddir)/src/util/libgnunetutil.la
190
183test_regex_iterate_api_SOURCES = \ 191test_regex_iterate_api_SOURCES = \
184 test_regex_iterate_api.c 192 test_regex_iterate_api.c
185test_regex_iterate_api_LDADD = -lm \ 193test_regex_iterate_api_LDADD = -lm \
@@ -208,4 +216,5 @@ test_regex_graph_api_LDADD = -lm \
208 216
209 217
210EXTRA_DIST = \ 218EXTRA_DIST = \
211 regex_simulation_profiler_test.conf 219 regex_simulation_profiler_test.conf \
220 test_regex_api_data.conf